CC: kernel: update to 3.18.45, refresh targets
authorZoltan HERPAI <wigyori@uid0.hu>
Mon, 19 Dec 2016 12:57:31 +0000 (13:57 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Mon, 19 Dec 2016 13:19:47 +0000 (14:19 +0100)
Compile-tested on ar71xx, imx6, lantiq, mvebu
Runtime-tested on sunxi.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
19 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch
target/linux/ar71xx/patches-3.18/736-MIPS-ath79-add-MC-MAC1200R-support.patch
target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch
target/linux/ar71xx/patches-3.18/738-MIPS-ath79-add-meraki-mr12-mr16-support.patch
target/linux/ar71xx/patches-3.18/800-MIPS-ath79-add-RB922GS-support.patch
target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-mr1750-support.patch
target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch
target/linux/ar71xx/patches-3.18/816-MIPS-ath79-add-om5pacv-support.patch
target/linux/ar71xx/patches-3.18/903-MIPS-ath79-ubnt-rocket-m-xw-support.patch
target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch
target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-WPN824N.patch
target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch
target/linux/ar71xx/patches-3.18/908-MIPS-ath79-add-domywifi-dw33d-support.patch
target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch
target/linux/generic/patches-3.18/201-extra_optimization.patch
target/linux/generic/patches-3.18/550-ubifs-symlink-xattr-support.patch

index 861fbbf..2f6d279 100644 (file)
@@ -2,9 +2,9 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .44
+LINUX_VERSION-3.18 = .45
 
-LINUX_KERNEL_MD5SUM-3.18.44 = 7c52da2f54381a84960118b5bf23381a
+LINUX_KERNEL_MD5SUM-3.18.45 = c527bae0aa1a5d6f3ebe31ad348c5339
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index ae8d9ff..99e96aa 100644 (file)
  
  config ATH79_MACH_UBNT_XM
        bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1144,106 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1155,106 @@ config ATH79_MACH_UBNT_XM
          Say 'Y' here if you want your kernel to support the
          Ubiquiti Networks XM (rev 1.0) board.
  
  endmenu
  
  config SOC_AR71XX
-@@ -124,7 +1285,10 @@ config ATH79_DEV_DSA
+@@ -124,7 +1296,10 @@ config ATH79_DEV_DSA
  config ATH79_DEV_ETH
        def_bool n
  
        def_bool n
  
  config ATH79_DEV_GPIO_BUTTONS
-@@ -154,6 +1318,11 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -154,6 +1329,11 @@ config ATH79_PCI_ATH9K_FIXUP
        def_bool n
  
  config ATH79_ROUTERBOOT
index 813d7f8..3d264d2 100644 (file)
@@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1266,6 +1266,10 @@ config SOC_AR934X
+@@ -1277,6 +1277,10 @@ config SOC_AR934X
        select PCI_AR724X if PCI
        def_bool n
  
@@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
  config SOC_QCA955X
        select HW_HAS_PCI
        select PCI_AR724X if PCI
-@@ -1308,7 +1312,7 @@ config ATH79_DEV_USB
+@@ -1319,7 +1323,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
index 0da8142..abb8d03 100644 (file)
  }
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1286,6 +1286,12 @@ config SOC_QCA955X
+@@ -1297,6 +1297,12 @@ config SOC_QCA955X
        select PCI_AR724X if PCI
        def_bool n
  
  config ATH79_DEV_M25P80
        select ATH79_DEV_SPI
        def_bool n
-@@ -1323,7 +1329,7 @@ config ATH79_DEV_USB
+@@ -1334,7 +1340,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
index b4d3ec1..d4f4e6a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -599,6 +599,16 @@ config ATH79_MACH_R6100
+@@ -610,6 +610,16 @@ config ATH79_MACH_R6100
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
index 137a09a..f863107 100644 (file)
@@ -10,7 +10,7 @@
        ATH79_MACH_PB42,                /* Atheros PB42 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -752,6 +752,7 @@ config ATH79_MACH_OM2P
+@@ -763,6 +763,7 @@ config ATH79_MACH_OM2P
  config ATH79_MACH_OM5P
        bool "OpenMesh OM5P board support"
        select SOC_AR934X
index 84ae400..90f68e4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -769,6 +769,26 @@ config ATH79_MACH_ONION_OMEGA
+@@ -780,6 +780,26 @@ config ATH79_MACH_ONION_OMEGA
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
index a387bdd..6ab94fc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -644,6 +644,16 @@ config ATH79_MACH_RB91X
+@@ -655,6 +655,16 @@ config ATH79_MACH_RB91X
        select ATH79_DEV_USB
        select ATH79_ROUTERBOOT
  
index d34712b..878d805 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -858,6 +858,16 @@ config ATH79_MACH_CAP4200AG
+@@ -869,6 +869,16 @@ config ATH79_MACH_CAP4200AG
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
index 4eea429..5d66025 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -779,6 +779,15 @@ config ATH79_MACH_OM5P
+@@ -790,6 +790,15 @@ config ATH79_MACH_OM5P
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
index aca37c9..05108c7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -788,6 +788,16 @@ config ATH79_MACH_OM5P_AC
+@@ -799,6 +799,16 @@ config ATH79_MACH_OM5P_AC
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
index bab5cc7..b55ae90 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -184,6 +184,7 @@ enum ath79_mach_type {
+@@ -185,6 +185,7 @@ enum ath79_mach_type {
        ATH79_MACH_UBNT_NANO_M,         /* Ubiquiti NanoStation M */
        ATH79_MACH_UBNT_NANO_M_XW,      /* Ubiquiti NanoStation M XW */
        ATH79_MACH_UBNT_ROCKET_M,       /* Ubiquiti Rocket M */
index 5cb5db1..ac6b7ba 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -925,6 +925,16 @@ config ATH79_MACH_EAP7660D
+@@ -936,6 +936,16 @@ config ATH79_MACH_EAP7660D
        select ATH79_DEV_LEDS_GPIO
        select ATH79_DEV_M25P80
  
index 8921fb7..a8135ee 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -750,7 +750,7 @@ config ATH79_MACH_WNR2000
+@@ -761,7 +761,7 @@ config ATH79_MACH_WNR2000
        select ATH79_DEV_WMAC
  
  config ATH79_MACH_WNR2000_V3
@@ -11,7 +11,7 @@
        select ATH79_DEV_ETH
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -211,6 +211,7 @@ enum ath79_mach_type {
+@@ -212,6 +212,7 @@ enum ath79_mach_type {
        ATH79_MACH_WNR2200,             /* NETGEAR WNR2200 */
        ATH79_MACH_WNR612_V2,           /* NETGEAR WNR612 v2 */
        ATH79_MACH_WNR1000_V2,          /* NETGEAR WNR1000 v2 */
index f84bce6..16f65e1 100644 (file)
@@ -10,7 +10,7 @@
        ATH79_MACH_TL_WDR4900_V2,       /* TP-LINK TL-WDR4900 v2 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1052,6 +1052,15 @@ config ATH79_MACH_TL_WA901ND_V2
+@@ -1063,6 +1063,15 @@ config ATH79_MACH_TL_WA901ND_V2
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
index ee575d5..5a7cefb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -480,6 +480,22 @@
+@@ -480,6 +480,22 @@ config ATH79_MACH_DLAN_PRO_1200_AC
        select ATH79_DEV_NFC
        select ATH79_DEV_USB
  
@@ -25,7 +25,7 @@
        select SOC_AR933X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -69,6 +69,7 @@
+@@ -69,6 +69,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_615_C1)  += m
  obj-$(CONFIG_ATH79_MACH_DIR_615_I1)   += mach-dir-615-i1.o
  obj-$(CONFIG_ATH79_MACH_DIR_825_B1)   += mach-dir-825-b1.o
  obj-$(CONFIG_ATH79_MACH_DIR_825_C1)   += mach-dir-825-c1.o
@@ -35,7 +35,7 @@
  obj-$(CONFIG_ATH79_MACH_EW_DORIN)     += mach-ew-dorin.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -57,6 +57,7 @@
+@@ -57,6 +57,7 @@ enum ath79_mach_type {
        ATH79_MACH_DIR_835_A1,          /* D-Link DIR-835 rev. A1 */
        ATH79_MACH_DLAN_PRO_500_WP,     /* devolo dLAN pro 500 Wireless+ */
        ATH79_MACH_DLAN_PRO_1200_AC,    /* devolo dLAN pro 1200+ WiFi ac*/
index c75af99..6c26a47 100644 (file)
@@ -44,7 +44,7 @@ Miklos
 
 --- a/fs/overlayfs/copy_up.c
 +++ b/fs/overlayfs/copy_up.c
-@@ -313,6 +313,9 @@ int ovl_copy_up_one(struct dentry *paren
+@@ -315,6 +315,9 @@ int ovl_copy_up_one(struct dentry *paren
        struct cred *override_cred;
        char *link = NULL;
  
index 7ec93a4..2e2ed66 100644 (file)
@@ -1,7 +1,7 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -612,9 +612,9 @@ include $(srctree)/arch/$(SRCARCH)/Makef
- KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
+@@ -614,9 +614,9 @@ KBUILD_CFLAGS      += $(call cc-option,-fno-P
+ KBUILD_AFLAGS += $(call cc-option,-fno-PIE)
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
index 42ae9cb..6e08ca3 100644 (file)
@@ -39,7 +39,7 @@
  
 --- a/fs/ubifs/xattr.c
 +++ b/fs/ubifs/xattr.c
-@@ -209,12 +209,12 @@ static int change_xattr(struct ubifs_inf
+@@ -210,12 +210,12 @@ static int change_xattr(struct ubifs_inf
                goto out_free;
        }
        inode->i_size = ui->ui_size = size;