ar71xx: Add support for Black Swift
authorJohn Crispin <blogic@openwrt.org>
Mon, 17 Aug 2015 13:18:56 +0000 (13:18 +0000)
committerJohn Crispin <blogic@openwrt.org>
Mon, 17 Aug 2015 13:18:56 +0000 (13:18 +0000)
Add support for the Black Swift board:
http://www.black-swift.com/

Took relevant parts and slightly adapted from:
https://github.com/blackswift/openwrt/blob/master/bsb.patch

Signed-off-by: Bruno Randolf <br1@einfach.org>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46674 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-3.18
target/linux/ar71xx/files/arch/mips/ath79/mach-bsb.c [new file with mode: 0644]
target/linux/ar71xx/generic/profiles/smartelectronics.mk [new file with mode: 0644]
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch [new file with mode: 0644]

index d6c7ec9..ece7098 100644 (file)
@@ -38,6 +38,9 @@ get_status_led() {
        aw-nr580)
                status_led="aw-nr580:green:ready"
                ;;
+       bsb)
+               status_led="bsb:red:sys"
+               ;;
        bullet-m | rocket-m | rocket-m-xw | nano-m | nanostation-m | nanostation-m-xw | loco-m-xw)
                status_led="ubnt:green:link4"
                ;;
index ae45503..d628f1a 100644 (file)
@@ -46,6 +46,10 @@ ap113)
        ucidef_set_led_usbdev "usb" "USB" "ap113:green:usb" "1-1"
        ;;
 
+bsb)
+       ucidef_set_led_default "sys" "SYS" "bsb:red:sys" "1"
+       ;;
+
 bullet-m | \
 nanostation-m | \
 rocket-m | \
index d577fc6..7e26886 100644 (file)
@@ -64,6 +64,13 @@ tl-wdr4900-v2)
        ucidef_add_switch_vlan "switch0" "2" "1 6"
        ;;
 
+bsb)
+       ucidef_set_interfaces_lan_wan "eth1" "eth0"
+       ucidef_add_switch "switch0" "1" "1"
+       ucidef_add_switch_vlan "switch0" "1" "0 1 3"
+       ucidef_set_interface_wlan
+       ;;
+
 cpe510)
        ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
        ucidef_add_switch "switch0" "1" "1"
index 4c10ab2..cacf362 100755 (executable)
@@ -664,6 +664,9 @@ ar71xx_board_detect() {
        *"SMART-300")
                name="smart-300"
                ;;
+       "Smart Electronics Black Swift board"*)
+               name="bsb"
+               ;;
        *TEW-632BRP)
                name="tew-632brp"
                ;;
index f3dd61b..e5376ef 100755 (executable)
@@ -260,6 +260,7 @@ platform_check_image() {
                return 1
                ;;
 
+       bsb | \
        dir-825-b1 | \
        tew-673gru)
                dir825b_check_image "$1" && return 0
index 4f52332..d661aa7 100644 (file)
@@ -43,6 +43,7 @@ CONFIG_ATH79_MACH_AW_NR580=y
 CONFIG_ATH79_MACH_ANTMINER_S1=y
 CONFIG_ATH79_MACH_ANTMINER_S3=y
 CONFIG_ATH79_MACH_BHU_BXU2000N2_A=y
+CONFIG_ATH79_MACH_BSB=y
 CONFIG_ATH79_MACH_CAP4200AG=y
 CONFIG_ATH79_MACH_CARAMBOLA2=y
 CONFIG_ATH79_MACH_CPE510=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-bsb.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-bsb.c
new file mode 100644 (file)
index 0000000..9f9be02
--- /dev/null
@@ -0,0 +1,83 @@
+/*
+ *  Smart Electronics Black Swift board support
+ *
+ *  Copyright (C) 2014 Dmitriy Zherebkov dzh@black-swift.com
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define BSB_GPIO_LED_SYS               27
+
+#define BSB_GPIO_BTN_RESET             11
+
+#define BSB_KEYS_POLL_INTERVAL         20      /* msecs */
+#define BSB_KEYS_DEBOUNCE_INTERVAL     (3 * BSB_KEYS_POLL_INTERVAL)
+
+#define BSB_MAC_OFFSET                 0x0000
+#define BSB_CALDATA_OFFSET             0x1000
+
+static struct gpio_led bsb_leds_gpio[] __initdata = {
+       {
+               .name           = "bsb:red:sys",
+               .gpio           = BSB_GPIO_LED_SYS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button bsb_gpio_keys[] __initdata = {
+       {
+               .desc           = "reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = BSB_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = BSB_GPIO_BTN_RESET,
+               .active_low     = 1,
+       },
+};
+
+static void __init bsb_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+       /* disable PHY_SWAP and PHY_ADDR_SWAP bits */
+       ath79_setup_ar933x_phy4_switch(false,false);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(bsb_leds_gpio),
+                                bsb_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, BSB_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(bsb_gpio_keys),
+                                       bsb_gpio_keys);
+
+       ath79_register_usb();
+
+       ath79_register_m25p80(NULL);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, art + BSB_MAC_OFFSET, 1);
+       ath79_init_mac(ath79_eth1_data.mac_addr, art + BSB_MAC_OFFSET, 2);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_wmac(art + BSB_CALDATA_OFFSET,
+                           art + BSB_MAC_OFFSET);
+}
+
+MIPS_MACHINE(ATH79_MACH_BSB, "BSB", "Smart Electronics Black Swift board",
+               bsb_setup);
+
diff --git a/target/linux/ar71xx/generic/profiles/smartelectronics.mk b/target/linux/ar71xx/generic/profiles/smartelectronics.mk
new file mode 100644 (file)
index 0000000..6d3dc8c
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BSB
+        NAME:=Smart Electronics Black Swift board
+        PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/BSB/Description
+        Package set optimized for the Smart Electronics Black Swift board.
+endef
+
+$(eval $(call Profile,BSB))
index 3c77465..bb5de17 100644 (file)
@@ -120,6 +120,14 @@ define Device/Default
   IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
 endef
 
+define Device/bsb
+  BOARDNAME = BSB
+  IMAGE_SIZE = 16000k
+  CONSOLE = ttyATH0,115200
+  MTDPARTS = spi0.0:128k(u-boot)ro,64k(u-boot-env)ro,16128k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += bsb
+
 define Device/carambola2
   BOARDNAME = CARAMBOLA2
   IMAGE_SIZE = 16000k
diff --git a/target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch b/target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch
new file mode 100644 (file)
index 0000000..15196bb
--- /dev/null
@@ -0,0 +1,45 @@
+Index: linux-3.18.19/arch/mips/ath79/Kconfig
+===================================================================
+--- linux-3.18.19.orig/arch/mips/ath79/Kconfig 2015-08-10 17:08:03.191320098 +0100
++++ linux-3.18.19/arch/mips/ath79/Kconfig      2015-08-10 17:08:03.195320098 +0100
+@@ -866,6 +866,16 @@
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
++config ATH79_MACH_BSB
++      bool "Smart Electronics Black Swift board"
++      select SOC_AR933X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_ARCHER_C7
+       bool "TP-LINK Archer C5/C7/TL-WDR4900 v2 board support"
+       select SOC_QCA955X
+Index: linux-3.18.19/arch/mips/ath79/Makefile
+===================================================================
+--- linux-3.18.19.orig/arch/mips/ath79/Makefile        2015-08-10 17:08:03.191320098 +0100
++++ linux-3.18.19/arch/mips/ath79/Makefile     2015-08-10 17:08:03.195320098 +0100
+@@ -54,6 +54,7 @@
+ obj-$(CONFIG_ATH79_MACH_ARCHER_C7)    += mach-archer-c7.o
+ obj-$(CONFIG_ATH79_MACH_AW_NR580)     += mach-aw-nr580.o
+ obj-$(CONFIG_ATH79_MACH_BHU_BXU2000N2_A)+= mach-bhu-bxu2000n2-a.o
++obj-$(CONFIG_ATH79_MACH_BSB)          += mach-bsb.o
+ obj-$(CONFIG_ATH79_MACH_CAP4200AG)    += mach-cap4200ag.o
+ obj-$(CONFIG_ATH79_MACH_CPE510)               += mach-cpe510.o
+ obj-$(CONFIG_ATH79_MACH_DB120)                += mach-db120.o
+Index: linux-3.18.19/arch/mips/ath79/machtypes.h
+===================================================================
+--- linux-3.18.19.orig/arch/mips/ath79/machtypes.h     2015-08-10 17:08:03.191320098 +0100
++++ linux-3.18.19/arch/mips/ath79/machtypes.h  2015-08-10 17:10:41.455317386 +0100
+@@ -37,6 +37,7 @@
+       ATH79_MACH_ARCHER_C7,           /* TP-LINK Archer C7 board */
+       ATH79_MACH_AW_NR580,            /* AzureWave AW-NR580 */
+       ATH79_MACH_BHU_BXU2000N2_A1,    /* BHU BXU2000n-2 A1 */
++      ATH79_MACH_BSB,                 /* Smart Electronics Black Swift board */
+       ATH79_MACH_CAP4200AG,           /* Senao CAP4200AG */
+       ATH79_MACH_CARAMBOLA2,          /* 8devices Carambola2 */
+       ATH79_MACH_CPE510,              /* TP-LINK CPE510 */