image: disable compile target within image builder
authorFelix Fietkau <nbd@openwrt.org>
Mon, 11 May 2015 09:17:51 +0000 (09:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 11 May 2015 09:17:51 +0000 (09:17 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45674 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index b8be838..921d78d 100644 (file)
@@ -359,7 +359,7 @@ endef
 
 define Device/Check
   _TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)
-  _COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
+  _COMPILE_TARGET = $$(if $(if $(IB),,$(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES))),compile,compile-disabled)
 endef
 
 ifndef IB