curl: fix compile with cyassl version 3.0.0
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 May 2014 14:05:37 +0000 (14:05 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 May 2014 14:05:37 +0000 (14:05 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40622 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/curl/patches/001-cyassl-Use-error-ssl.h-when-available.patch [new file with mode: 0644]
libs/curl/patches/100-check_long_long.patch

diff --git a/libs/curl/patches/001-cyassl-Use-error-ssl.h-when-available.patch b/libs/curl/patches/001-cyassl-Use-error-ssl.h-when-available.patch
new file mode 100644 (file)
index 0000000..d7190af
--- /dev/null
@@ -0,0 +1,45 @@
+From 0204e17bc656e6c59b4010283e67f9251eb12c41 Mon Sep 17 00:00:00 2001
+From: Dan Fandrich <dan@coneharvesters.com>
+Date: Wed, 23 Apr 2014 11:01:30 +0200
+Subject: [PATCH] cyassl: Use error-ssl.h when available
+
+Versions since at least 2.9.4 renamed error.h to error-ssl.h, so use
+whichever one is available.
+---
+ configure.ac      |    3 +++
+ lib/vtls/cyassl.c |    9 +++++++--
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -2003,6 +2003,9 @@ if test "$curl_ssl_msg" = "$init_ssl_msg
+       dnl cyassl/ctaocrypt/types.h needs SIZEOF_LONG_LONG defined!
+       AC_CHECK_SIZEOF(long long)
++      dnl Versions since at least 2.9.4 renamed error.h to error-ssl.h
++      AC_CHECK_HEADERS(cyassl/error-ssl.h)
++
+       LIBS="-lcyassl -lm $LIBS"
+       if test -n "$cyassllib"; then
+--- a/lib/vtls/cyassl.c
++++ b/lib/vtls/cyassl.c
+@@ -47,11 +47,16 @@
+ #define _MPRINTF_REPLACE /* use our functions only */
+ #include <curl/mprintf.h>
+ #include "curl_memory.h"
+-/* The last #include file should be: */
+-#include "memdebug.h"
++
+ #include <cyassl/ssl.h>
++#ifdef HAVE_CYASSL_ERROR_SSL_H
++#include <cyassl/error-ssl.h>
++#else
+ #include <cyassl/error.h>
++#endif
++/* The last #include file should be: */
++#include "memdebug.h"
+ static Curl_recv cyassl_recv;
+ static Curl_send cyassl_send;
index 1285fa9..7e014cd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2901,6 +2901,7 @@ CURL_VERIFY_RUNTIMELIBS
+@@ -2904,6 +2904,7 @@ CURL_VERIFY_RUNTIMELIBS
  
  AC_CHECK_SIZEOF(size_t)
  AC_CHECK_SIZEOF(long)