wifidog: moved to github
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Jul 2015 19:35:34 +0000 (19:35 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Jul 2015 19:35:34 +0000 (19:35 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@46324 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/wifidog/Makefile [deleted file]
net/wifidog/files/wifidog.init [deleted file]

diff --git a/net/wifidog/Makefile b/net/wifidog/Makefile
deleted file mode 100644 (file)
index a2d9d02..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Copyright (C) 2006,2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=wifidog
-PKG_VERSION:=20130917
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/wifidog/wifidog-gateway.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=440445db60b0c3aff528ea703a828b0567293387
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/wifidog
-  SUBMENU:=Captive Portals
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+iptables-mod-extra +iptables-mod-ipopt +iptables-mod-nat-extra +libpthread
-  TITLE:=A wireless captive portal solution
-  URL:=http://www.wifidog.org
-endef
-
-define Package/wifidog/description
-       The Wifidog project is a complete and embeddable captive
-       portal solution for wireless community groups or individuals
-       who wish to open a free Hotspot while still preventing abuse
-       of their Internet connection.
-endef
-
-define Package/wifidog/conffiles
-/etc/wifidog.conf
-endef
-
-define Package/wifidog/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/init.d/wifidog $(1)/usr/bin/wifidog-init
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/wifidog $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/wdctl $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhttpd.so* $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/wifidog.conf $(1)/etc/
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/wifidog-msg.html $(1)/etc/
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/wifidog.init $(1)/etc/init.d/wifidog
-endef
-
-$(eval $(call BuildPackage,wifidog))
diff --git a/net/wifidog/files/wifidog.init b/net/wifidog/files/wifidog.init
deleted file mode 100644 (file)
index 9db075d..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-START=65
-EXTRA_COMMANDS="status"
-EXTRA_HELP="        status Print the status of the service"
-
-start() {
-       /usr/bin/wifidog-init start
-}
-
-stop() {
-       /usr/bin/wifidog-init stop
-}
-
-status() {
-       /usr/bin/wifidog-init status
-}
\ No newline at end of file