amule: remove dependency to libbfd.so
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Apr 2014 19:30:54 +0000 (19:30 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Apr 2014 19:30:54 +0000 (19:30 +0000)
This removes the dependency to libbfd.so and removes some removed configure options.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40594 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/amule/Makefile
net/amule/patches/001-no_backtrace.patch [new file with mode: 0644]

index 02769aa..dfb7eb8 100644 (file)
@@ -30,7 +30,6 @@ define Package/amule
 endef
 
 CONFIGURE_ARGS+= \
-       --enable-shared \
        --disable-static \
        --disable-rpath \
        --with-gnu-ld \
@@ -41,21 +40,16 @@ CONFIGURE_ARGS+= \
        --disable-monolithic \
        --enable-amule-daemon \
        --enable-amulecmd \
-       --disable-amulecmdgui \
        --enable-webserver \
-       --disable-webservergui \
        --disable-amule-gui \
        --disable-cas \
        --disable-wxcas \
        --disable-ed2k \
        --disable-alc \
        --disable-alcc \
-       --disable-systray \
-       --disable-utf8-systray \
-       --enable-embedded-crypto \
-       --enable-gsocket \
-       --disable-gtktest \
-       --disable-crypto \
+       --disable-fileview \
+       --disable-plasmamule \
+       --without-wxdebug \
        \
        --with-zlib="$(STAGING_DIR)/usr" \
        --with-gdlib-prefix="$(STAGING_DIR)/usr" \
diff --git a/net/amule/patches/001-no_backtrace.patch b/net/amule/patches/001-no_backtrace.patch
new file mode 100644 (file)
index 0000000..df3bee8
--- /dev/null
@@ -0,0 +1,69 @@
+--- a/configure
++++ b/configure
+@@ -13984,66 +13984,6 @@ fi
+-# Check for bfd.h (to have proper backtraces without using wxExecute)
+-
+-      { $as_echo "$as_me:${as_lineno-$LINENO}: checking for bfd" >&5
+-$as_echo_n "checking for bfd... " >&6; }
+-      result=no
+-      for bfd_ldadd in "" "${LIBINTL}" "-ldl" "-ldl ${LIBINTL}"; do
+-              mule_backup_LIBS="$LIBS"
+-              mule_backup_LDFLAGS="$LDFLAGS"
+-              LIBS="-lbfd -liberty ${bfd_ldadd} ${ZLIB_LIBS} $LIBS"
+-              LDFLAGS="$LDFLAGS ${ZLIB_LDFLAGS}"
+-              cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h.  */
+-
+-
+-                              #include <ansidecl.h>
+-                              #include <bfd.h>
+-
+-int
+-main ()
+-{
+-
+-                              char *dummy = bfd_errmsg(bfd_get_error());
+-
+-  ;
+-  return 0;
+-}
+-
+-_ACEOF
+-if ac_fn_c_try_link "$LINENO"; then :
+-
+-                      result=yes
+-                      BFD_CPPFLAGS="-DHAVE_BFD"
+-                      BFD_LIBS="-lbfd -liberty ${bfd_ldadd}"
+-                      LIBS="$mule_backup_LIBS"
+-                      LDFLAGS="$mule_backup_LDFLAGS"
+-                      break
+-
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+-    conftest$ac_exeext conftest.$ac_ext
+-              LIBS="$mule_backup_LIBS"
+-              LDFLAGS="$mule_backup_LDFLAGS"
+-      done
+-
+-      { $as_echo "$as_me:${as_lineno-$LINENO}: result: $result" >&5
+-$as_echo "$result" >&6; }
+-
+-      if test $result = no; then :
+-  { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING:
+-        bfd.h not found or unusable, please install binutils development
+-        package if you are a developer or want to help testing aMule" >&5
+-$as_echo "$as_me: WARNING:
+-        bfd.h not found or unusable, please install binutils development
+-        package if you are a developer or want to help testing aMule" >&2;}
+-_mule_warning_10=yes
+-_mule_has_warnings=yes
+-
+-fi
+-
+-
+       { $as_echo "$as_me:${as_lineno-$LINENO}: checking for <execinfo.h> and backtrace()" >&5
+ $as_echo_n "checking for <execinfo.h> and backtrace()... " >&6; }