softflowd: moved to github
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2014 20:02:29 +0000 (20:02 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2014 20:02:29 +0000 (20:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41536 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/softflowd/Makefile [deleted file]
net/softflowd/files/softflowd.config [deleted file]
net/softflowd/files/softflowd.init [deleted file]

diff --git a/net/softflowd/Makefile b/net/softflowd/Makefile
deleted file mode 100644 (file)
index 8c97143..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2007-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=softflowd
-PKG_VERSION:=0.9.8
-PKG_RELEASE:=3
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.mindrot.org/files/softflowd/
-PKG_MD5SUM:=0054d1c80494396cc15edb0a1c7748b1
-
-PKG_FIXUP:=autoreconf
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/softflowd
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libpcap
-  TITLE:=softflowd
-  URL:=http://www.mindrot.org/projects/softflowd/
-endef
-
-define Package/softflowd/description
-       Software netflow exporter
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" softflowd softflowctl
-endef
-
-define Package/softflowd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/softflowd $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/softflowctl $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
-endef
-
-define Package/softflowd/conffiles
-/etc/config/softflowd
-endef
-
-$(eval $(call BuildPackage,softflowd))
diff --git a/net/softflowd/files/softflowd.config b/net/softflowd/files/softflowd.config
deleted file mode 100644 (file)
index 6fe5a3e..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-config softflowd
-       option enabled        '0'
-       option interface      'br-lan'
-       option pcap_file      ''
-       option timeout        ''
-       option max_flows      '8192'
-       option host_port      ''
-       option pid_file       '/var/run/softflowd.pid'
-       option control_socket '/var/run/softflowd.ctl'
-       option export_version '5'
-       option hoplimit       ''
-       option tracking_level 'full'
-       option track_ipv6     '0'
diff --git a/net/softflowd/files/softflowd.init b/net/softflowd/files/softflowd.init
deleted file mode 100644 (file)
index 4beddc0..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2007-2011 OpenWrt.org
-
-START=50
-
-append_bool() {
-       local section="$1"
-       local option="$2"
-       local value="$3"
-       local _val
-       config_get_bool _val "$section" "$option" '0'
-       [ "$_val" -gt 0 ] && append args "$3"
-}
-
-append_string() {
-       local section="$1"
-       local option="$2"
-       local value="$3"
-       local _val
-       config_get _val "$section" "$option"
-       [ -n "$_val" ] && append args "$3 $_val"
-}
-
-start_instance() {
-       local section="$1"
-
-       config_get_bool enabled "$section" 'enabled' '0'
-       [ $enabled -gt 0 ] || return 1
-
-       config_get pid_file "$section" 'pid_file'
-
-       args=""
-       append_string "$section" 'interface' '-i'
-       append_string "$section" 'pcap_file' '-r'
-       append_string "$section" 'timeout' '-t'
-       append_string "$section" 'max_flows' '-m'
-       append_string "$section" 'host_port' '-n'
-       append_string "$section" 'pid_file' '-p'
-       append_string "$section" 'control_socket' '-c'
-       append_string "$section" 'export_version' '-v'
-       append_string "$section" 'hoplimit' '-L'
-       append_string "$section" 'tracking_level' '-T'
-       append_bool "$section" track_ipv6 '-6'
-
-       SERVICE_PID_FILE="$pid_file" \
-       service_start /usr/sbin/softflowd $args${pid_file:+ -p $pid_file}
-}
-
-stop_instance() {
-       local section="$1"
-
-       config_get_bool enabled "$section" 'enabled' '0'
-       [ $enabled -gt 0 ] || return 1
-
-       config_get control_socket "$section" 'control_socket'
-
-       [ -n "control_socket" -a -S $control_socket ] && {
-               /usr/sbin/softflowctl -c $control_socket exit
-       }
-}
-
-start() {
-       mkdir -m 0755 -p /var/empty
-
-       config_load 'softflowd'
-       config_foreach start_instance 'softflowd'
-}
-
-stop() {
-       config_load 'softflowd'
-       config_foreach stop_instance 'softflowd'
-       service_stop /usr/sbin/softflowd
-}