pptpd: bump to version 1.4.0 (fix bugs #12909, #15490, #15635)
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 May 2014 11:02:55 +0000 (11:02 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 May 2014 11:02:55 +0000 (11:02 +0000)
Old pptpd 1.3.4 suffers from an old bug that gcc 4.8 has apparently brought
to surface (analysed in bug #12909).

The problem has been fixed upstream and is included in 1.4.0 release from
October 2013.
http://sourceforge.net/p/poptop/mailman/message/30453437/
http://sourceforge.net/p/poptop/git/ci/db9a847936fa1c890d337ed609b9d3600834870a/
http://sourceforge.net/projects/poptop/

The patch bumps pptpd from 6-year old 1.3.4 to 1.4.0.

Related bugs #15428, #15635, #12909, #15490.
https://dev.openwrt.org/ticket/12909
https://dev.openwrt.org/ticket/15428  (AA12.09)
https://dev.openwrt.org/ticket/15490
https://dev.openwrt.org/ticket/15635

I have compiled and briefly tested on ar71xx/wndr3700 with trunk.

signed-off-by: hannu.nyman@iki.fi

git-svn-id: svn://svn.openwrt.org/openwrt/packages@40671 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/pptpd/Makefile
net/pptpd/patches/001-bad_pqueue_debug.patch
net/pptpd/patches/002-makefile_fix.patch
net/pptpd/patches/003-opt_flags.patch

index 40982c2..2a44c7c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptpd
-PKG_VERSION:=1.3.4
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/poptop
-PKG_MD5SUM:=b38df9c431041922c997c1148bedf591
+PKG_MD5SUM:=36f9f45c6ffa92bc3b6e24ae2d053505
 
 PKG_INSTALL:=1
 
index 8e8f5a5..50d5252 100644 (file)
@@ -1,5 +1,5 @@
---- pptpd-1.3.4.orig/pqueue.c  2005-08-03 10:53:22.000000000 +0200
-+++ pptpd-1.3.4/pqueue.c       2009-12-03 17:47:26.976174000 +0100
+--- a/pqueue.c
++++ b/pqueue.c
 @@ -7,13 +7,11 @@
  #include "pqueue.h"
  
index 554b0a1..74e3335 100644 (file)
@@ -1,5 +1,5 @@
---- pptpd-1.3.4.orig/plugins/Makefile  2006-08-03 04:02:01.000000000 +0200
-+++ pptpd-1.3.4/plugins/Makefile       2009-12-03 21:18:09.678467590 +0100
+--- a/plugins/Makefile
++++ b/plugins/Makefile
 @@ -18,7 +18,7 @@ all: $(PLUGINS)
  %.so: %.c
        $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
index 213fb03..cc136c5 100644 (file)
@@ -1,7 +1,6 @@
-diff -ruN pptpd-1.3.0-old/Makefile.in pptpd-1.3.0-new/Makefile.in
---- pptpd-1.3.0-old/Makefile.in        2005-08-03 09:47:42.000000000 +0200
-+++ pptpd-1.3.0-new/Makefile.in        2006-10-27 18:22:00.000000000 +0200
-@@ -106,7 +106,7 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -153,7 +153,7 @@ AUTOMAKE = @AUTOMAKE@
  AWK = @AWK@
  CC = @CC@
  CCDEPMODE = @CCDEPMODE@