collectd: Fix collectd / Luci statistics breakage due to r39119 / #15010
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 May 2014 19:12:00 +0000 (19:12 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 May 2014 19:12:00 +0000 (19:12 +0000)
Collectd / Luci statistics module has been broken since r39119 (in December
2013). Buildbot has not built it succesfully since then.

Bug 15010 describes the issue:  https://dev.openwrt.org/ticket/15010
Changeset 39119:  https://dev.openwrt.org/changeset/39119

The build breakage only concerns one collectd plugin, netlink, which expects
iproute2 to be compiled with "fpic" option, which was removed by r39119 in
order to make iproute2 smaller.
http://buildbot.openwrt.org:8010/broken_packages/ar71xx/collectd/compile.txt

There are two alternative fixes:
- add fpic back to iproute2 compile options. But devs apparently
intentionally removed it to decrease size
- alternatively, disable netlink plugin in collectd by marking it broken

It is unfortunate that the whole collectd remains uncompiled in buildbot
snapshots due to that one minor plugin. Other bugs related to this (e.g.
#15077 and #14642) were closed three weeks ago as duplicates of #15010, but I
have seen no action regarding actually fixing the issue.

So, please find attached a patch marking the netlink plugin broken.
All other collectd modules do compile. I compile-tested them with ar71xx.

Signed-off-by: hannu.nyman@iki.fi
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40645 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/collectd/Makefile

index 90d6f82..2d96017 100644 (file)
@@ -279,7 +279,7 @@ $(eval $(call BuildPlugin,madwifi,MadWifi status input,madwifi,))
 $(eval $(call BuildPlugin,mysql,MySQL status input,mysql,+PACKAGE_collectd-mod-mysql:libmysqlclient-r))
 $(eval $(call BuildPlugin,memory,physical memory usage input,memory,))
 $(eval $(call BuildPlugin,modbus,read variables through libmodbus,modbus,+PACKAGE_collectd-mod-modbus:libmodbus @BROKEN))
-$(eval $(call BuildPlugin,netlink,netlink input,netlink,+PACKAGE_collectd-mod-netlink:ip))
+$(eval $(call BuildPlugin,netlink,netlink input,netlink,+PACKAGE_collectd-mod-netlink:ip @BROKEN))
 $(eval $(call BuildPlugin,network,network input/output,network))
 $(eval $(call BuildPlugin,nginx,nginx status input,nginx,+PACKAGE_collectd-mod-nginx:libcurl))
 $(eval $(call BuildPlugin,ntpd,NTP daemon status input,ntpd,))