AA: mac80211: b43: load b43 on core rev 17 and 18.
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jul 2013 14:24:06 +0000 (14:24 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jul 2013 14:24:06 +0000 (14:24 +0000)
This is now controlled by a module parameter and the default
configuration depends on brcmsmac being installed.
This patch causes b43 to take core rev 17 and 18 always by default.

Backport of r37307

git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@37308 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile
package/mac80211/patches/847-b43-always-take-overlapping-devs.patch [new file with mode: 0644]

index 2f7fbbe..e4fa925 100644 (file)
@@ -1221,7 +1221,7 @@ endif
 config-$(call config_package,carl9170) += CARL9170
 
 config-$(call config_package,b43) += B43
-config-y += B43_SSB B43_BCMA B43_BCMA_EXTRA B43_PHY_LP
+config-y += B43_SSB B43_BCMA B43_PHY_LP
 config-$(CONFIG_PACKAGE_B43_PHY_N) += B43_PHY_N
 config-$(CONFIG_PACKAGE_B43_PHY_HT) += B43_PHY_HT
 config-$(CONFIG_PACKAGE_B43_PIO) += B43_PIO
diff --git a/package/mac80211/patches/847-b43-always-take-overlapping-devs.patch b/package/mac80211/patches/847-b43-always-take-overlapping-devs.patch
new file mode 100644 (file)
index 0000000..9d1d419
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/drivers/net/wireless/b43/main.c
++++ b/drivers/net/wireless/b43/main.c
+@@ -118,7 +118,7 @@ static int b43_modparam_pio = 0;
+ module_param_named(pio, b43_modparam_pio, int, 0644);
+ MODULE_PARM_DESC(pio, "Use PIO accesses by default: 0=DMA, 1=PIO");
+-static int modparam_allhwsupport = !IS_ENABLED(CPTCFG_BRCMSMAC);
++static int modparam_allhwsupport = 1;
+ module_param_named(allhwsupport, modparam_allhwsupport, int, 0444);
+ MODULE_PARM_DESC(allhwsupport, "Enable support for all hardware (even it if overlaps with the brcmsmac driver)");