AA: openssl: Support multi-threaded applications
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 14 Feb 2014 16:15:07 +0000 (16:15 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 14 Feb 2014 16:15:07 +0000 (16:15 +0000)
(This is a backport of r39048 from trunk).

Allow multi-threaded applications to work properly by
removing the "no-threads" flag that is enabled by default.

Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@39585 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openssl/Makefile

index a8b3257..fa08774 100644 (file)
@@ -75,7 +75,7 @@ endef
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
-OPENSSL_OPTIONS:= shared no-ec no-err no-hw no-threads zlib-dynamic no-sse2
+OPENSSL_OPTIONS:= shared no-ec no-err no-hw zlib-dynamic no-sse2
 
 ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
   OPENSSL_OPTIONS += -DHAVE_CRYPTODEV