move some code to utils.[ch]
authorFelix Fietkau <nbd@openwrt.org>
Wed, 7 Sep 2011 07:15:42 +0000 (09:15 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 7 Sep 2011 07:16:05 +0000 (09:16 +0200)
CMakeLists.txt
main.c
netifd.h
utils.c [new file with mode: 0644]
utils.h [new file with mode: 0644]

index bb65a4b..c06733e 100644 (file)
@@ -9,5 +9,5 @@ IF(DEBUG)
   ADD_DEFINITIONS(-DDEBUG -O0)
 ENDIF()
 
-ADD_EXECUTABLE(netifd main.c interface.c interface-ip.c proto.c proto-static.c config.c device.c bridge.c vlan.c ubus.c system-dummy.c)
+ADD_EXECUTABLE(netifd main.c utils.c interface.c interface-ip.c proto.c proto-static.c config.c device.c bridge.c vlan.c ubus.c system-dummy.c)
 TARGET_LINK_LIBRARIES(netifd ubox ubus uci)
diff --git a/main.c b/main.c
index 4f6a4f6..69aa5cd 100644 (file)
--- a/main.c
+++ b/main.c
@@ -6,11 +6,6 @@
 #include "netifd.h"
 #include "ubus.h"
 
-int avl_strcmp(const void *k1, const void *k2, void *ptr)
-{
-       return strcmp(k1, k2);
-}
-
 static int usage(const char *progname)
 {
        fprintf(stderr, "Usage: %s [options]\n"
index 1559c50..2535972 100644 (file)
--- a/netifd.h
+++ b/netifd.h
@@ -7,23 +7,12 @@
 #include <stdbool.h>
 #include <stdio.h>
 
-#include <libubox/list.h>
 #include <libubox/uloop.h>
 
 #include <libubus.h>
 #include <uci.h>
 
-#ifdef DEBUG
-#define DPRINTF(format, ...) fprintf(stderr, "%s(%d): " format, __func__, __LINE__, ## __VA_ARGS__)
-#else
-#define DPRINTF(format, ...) no_debug(format, ## __VA_ARGS__)
-#endif
-
-static inline void no_debug(const char *fmt, ...)
-{
-}
-
-#define __init __attribute__((constructor))
+#include "utils.h"
 
 struct device;
 struct interface;
@@ -31,38 +20,6 @@ struct interface;
 extern struct uci_context *uci_ctx;
 extern bool config_init;
 
-int avl_strcmp(const void *k1, const void *k2, void *ptr);
 void config_init_interfaces(const char *name);
 
-#ifdef __linux__
-static inline int fls(int x)
-{
-    int r = 32;
-
-    if (!x)
-        return 0;
-    if (!(x & 0xffff0000u)) {
-        x <<= 16;
-        r -= 16;
-    }
-    if (!(x & 0xff000000u)) {
-        x <<= 8;
-        r -= 8;
-    }
-    if (!(x & 0xf0000000u)) {
-        x <<= 4;
-        r -= 4;
-    }
-    if (!(x & 0xc0000000u)) {
-        x <<= 2;
-        r -= 2;
-    }
-    if (!(x & 0x80000000u)) {
-        x <<= 1;
-        r -= 1;
-    }
-    return r;
-}
-#endif
-
 #endif
diff --git a/utils.c b/utils.c
new file mode 100644 (file)
index 0000000..cf0718a
--- /dev/null
+++ b/utils.c
@@ -0,0 +1,8 @@
+#include <string.h>
+#include "utils.h"
+
+int avl_strcmp(const void *k1, const void *k2, void *ptr)
+{
+       return strcmp(k1, k2);
+}
+
diff --git a/utils.h b/utils.h
new file mode 100644 (file)
index 0000000..09df8c6
--- /dev/null
+++ b/utils.h
@@ -0,0 +1,51 @@
+#ifndef __NETIFD_UTILS_H
+#define __NETIFD_UTILS_H
+
+#include <libubox/list.h>
+
+#ifdef DEBUG
+#define DPRINTF(format, ...) fprintf(stderr, "%s(%d): " format, __func__, __LINE__, ## __VA_ARGS__)
+#else
+#define DPRINTF(format, ...) no_debug(format, ## __VA_ARGS__)
+#endif
+
+static inline void no_debug(const char *fmt, ...)
+{
+}
+
+#define __init __attribute__((constructor))
+
+#ifdef __linux__
+static inline int fls(int x)
+{
+    int r = 32;
+
+    if (!x)
+        return 0;
+    if (!(x & 0xffff0000u)) {
+        x <<= 16;
+        r -= 16;
+    }
+    if (!(x & 0xff000000u)) {
+        x <<= 8;
+        r -= 8;
+    }
+    if (!(x & 0xf0000000u)) {
+        x <<= 4;
+        r -= 4;
+    }
+    if (!(x & 0xc0000000u)) {
+        x <<= 2;
+        r -= 2;
+    }
+    if (!(x & 0x80000000u)) {
+        x <<= 1;
+        r -= 1;
+    }
+    return r;
+}
+#endif
+
+int avl_strcmp(const void *k1, const void *k2, void *ptr);
+
+#endif