luci-base: fix luci-base host tool install on OpenWrt 813/head
authorMatthias Schiffer <mschiffer@universe-factory.net>
Mon, 3 Oct 2016 22:34:30 +0000 (00:34 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Mon, 3 Oct 2016 22:34:30 +0000 (00:34 +0200)
OpenWrt doesn't provide an argument to Host/Install like LEDE does; use
HOST_BUILD_PREFIX instead, which is available on both.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
modules/luci-base/Makefile

index 972a451..4fb278b 100644 (file)
@@ -37,9 +37,9 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(1)/bin
-       $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
+       $(INSTALL_DIR) $(HOST_BUILD_PREFIX)/bin
+       $(INSTALL_BIN) src/po2lmo $(HOST_BUILD_PREFIX)/bin/po2lmo
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(HOST_BUILD_PREFIX)/bin/LuaSrcDiet
 endef
 
 $(eval $(call HostBuild))