Merge pull request #564 from cshore/pull-request-app-firewall-timedate
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 15 Dec 2015 22:08:17 +0000 (23:08 +0100)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 15 Dec 2015 22:08:17 +0000 (23:08 +0100)
Pull request app firewall timedate

CONTRIBUTING.md
modules/luci-base/Makefile
modules/luci-base/luasrc/cbi.lua
modules/luci-base/root/etc/luci-uploads/.placeholder [new file with mode: 0644]
modules/luci-base/root/lib/uci/upload/.placeholder [deleted file]

index a392ade..e4edf0c 100644 (file)
@@ -10,7 +10,7 @@ Regardless of whether you send a patch or open a pull request, please try to fol
 * Have a useful subject prefixed with the component name
     (E.g.: "luci-mod-admin-full: fix wifi channel selection on multiple STA networks")
 * Shortly explain the changes made and - if applicable - the reasoning behind them
-* Include Signed-off-by in the comment
+* Commit message of each commit should include a Signed-off-by line
     (See <https://dev.openwrt.org/wiki/SubmittingPatches#a10.Signyourwork>)
        
 In case you like to send patches by mail, please use the [LuCI mailinglist](https://lists.subsignal.org/mailman/listinfo/luci)
index 26cbe08..a9c5e71 100644 (file)
@@ -22,6 +22,10 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/LuaSrcDiet-0.12.1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Package/luci-base/conffiles
+/etc/luci-uploads
+endef
+
 include ../../luci.mk
 
 define Host/Configure
index b5b2c8d..8fd0a33 100644 (file)
@@ -38,7 +38,7 @@ function load(cbimap, ...)
        require("luci.config")
        require("luci.util")
 
-       local upldir = "/lib/uci/upload/"
+       local upldir = "/etc/luci-uploads/"
        local cbidir = luci.util.libpath() .. "/model/cbi/"
        local func, err
 
diff --git a/modules/luci-base/root/etc/luci-uploads/.placeholder b/modules/luci-base/root/etc/luci-uploads/.placeholder
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/modules/luci-base/root/lib/uci/upload/.placeholder b/modules/luci-base/root/lib/uci/upload/.placeholder
deleted file mode 100644 (file)
index e69de29..0000000