* Added public webif pages:
authorSteven Barth <steven@midlink.org>
Sat, 19 Apr 2008 20:09:38 +0000 (20:09 +0000)
committerSteven Barth <steven@midlink.org>
Sat, 19 Apr 2008 20:09:38 +0000 (20:09 +0000)
15 files changed:
core/Makefile
core/src/ffluci/bits.lua [new file with mode: 0644]
core/src/ffluci/sys.lua
module/public-core/src/controller/public/index.lua
module/public-core/src/controller/public/status.lua [new file with mode: 0644]
module/public-core/src/controller/sudo/status.lua [new file with mode: 0644]
module/public-core/src/model/menu/00public.lua
module/public-core/src/view/public_index/contact.htm
module/public-core/src/view/public_index/index.htm
module/public-core/src/view/public_status/index.htm [new file with mode: 0644]
module/public-core/src/view/public_status/internet.htm [new file with mode: 0644]
module/public-core/src/view/public_status/iwscan.htm [new file with mode: 0644]
module/public-core/src/view/public_status/routes.htm [new file with mode: 0644]
module/public-core/src/view/sudo_status/iwscan.htm [new file with mode: 0644]
themes/fledermaus/contrib/media/cascade.css

index c6c7ede..6421a41 100644 (file)
@@ -3,7 +3,7 @@ LUAC_OPTIONS = -s
 
 FILES = ffluci/debug.lua ffluci/view/*.htm ffluci/view/cbi/*.htm ffluci/i18n/*
 
-CFILES = ffluci/util.lua ffluci/http.lua ffluci/fs.lua \
+CFILES = ffluci/bits.lua ffluci/util.lua ffluci/http.lua ffluci/fs.lua \
 ffluci/sys.lua ffluci/model/uci.lua ffluci/model/ipkg.lua \
 ffluci/config.lua ffluci/i18n.lua ffluci/template.lua \
 ffluci/cbi.lua ffluci/dispatcher.lua ffluci/menu.lua ffluci/init.lua 
diff --git a/core/src/ffluci/bits.lua b/core/src/ffluci/bits.lua
new file mode 100644 (file)
index 0000000..f8434c3
--- /dev/null
@@ -0,0 +1,542 @@
+--[[
+/*
+ * Copyright (c) 2007 Tim Kelly/Dialectronics
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining 
+ * a copy of this software and associated documentation files (the 
+ * "Software"),  to deal in the Software without restriction, including 
+ * without limitation the rights to use, copy, modify, merge, publish, 
+ * distribute, sublicense, and/or sell copies of the Software, and to permit 
+ * persons to whom the Software is furnished to do so, subject to the 
+ * following conditions:
+ *
+ * The above copyright notice and this permission notice shall be 
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, 
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF 
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  
+ * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY 
+ * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT 
+ * OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR 
+ * THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+--]]
+
+--[[
+/*
+ * Copyright (c) 2007 Tim Kelly/Dialectronics
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining 
+ * a copy of this software and associated documentation files (the 
+ * "Software"),  to deal in the Software without restriction, including 
+ * without limitation the rights to use, copy, modify, merge, publish, 
+ * distribute, sublicense, and/or sell copies of the Software, and to permit 
+ * persons to whom the Software is furnished to do so, subject to the 
+ * following conditions:
+ *
+ * The above copyright notice and this permission notice shall be 
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, 
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF 
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  
+ * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY 
+ * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT 
+ * OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR 
+ * THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+--]]
+
+module("ffluci.bits", package.seeall);
+
+local hex2bin = {
+       ["0"] = "0000",
+       ["1"] = "0001",
+       ["2"] = "0010",
+       ["3"] = "0011",
+       ["4"] = "0100",
+       ["5"] = "0101",
+       ["6"] = "0110",
+       ["7"] = "0111",
+       ["8"] = "1000",
+       ["9"] = "1001",
+       ["a"] = "1010",
+        ["b"] = "1011",
+        ["c"] = "1100",
+        ["d"] = "1101",
+        ["e"] = "1110",
+        ["f"] = "1111"
+       }
+
+
+
+local bin2hex = {
+       ["0000"] = "0",
+       ["0001"] = "1",
+       ["0010"] = "2",
+       ["0011"] = "3",
+       ["0100"] = "4",
+       ["0101"] = "5",
+       ["0110"] = "6",
+       ["0111"] = "7",
+       ["1000"] = "8",
+       ["1001"] = "9",
+       ["1010"] = "A",
+        ["1011"] = "B",
+        ["1100"] = "C",
+        ["1101"] = "D",
+        ["1110"] = "E",
+        ["1111"] = "F"
+       }
+
+--[[
+local dec2hex = {
+       ["0"] = "0",
+       ["1"] = "1",
+       ["2"] = "2",
+       ["3"] = "3",
+       ["4"] = "4",
+       ["5"] = "5",
+       ["6"] = "6",
+       ["7"] = "7",
+       ["8"] = "8",
+       ["9"] = "9",
+       ["10"] = "A",
+       ["11"] = "B",
+       ["12"] = "C",
+       ["13"] = "D",
+       ["14"] = "E",
+       ["15"] = "F"
+       }
+--]]
+
+
+-- These functions are big-endian and take up to 32 bits
+
+-- Hex2Bin
+-- Bin2Hex
+-- Hex2Dec
+-- Dec2Hex
+-- Bin2Dec
+-- Dec2Bin
+
+
+function Hex2Bin(s)
+
+-- s   -> hexadecimal string
+
+local ret = ""
+local i = 0
+
+
+       for i in string.gfind(s, ".") do
+               i = string.lower(i)
+
+               ret = ret..hex2bin[i]
+
+       end
+
+       return ret
+end
+
+
+function Bin2Hex(s)
+
+-- s   -> binary string
+
+local l = 0
+local h = ""
+local b = ""
+local rem
+
+l = string.len(s)
+rem = l % 4
+l = l-1
+h = ""
+
+       -- need to prepend zeros to eliminate mod 4
+       if (rem > 0) then
+               s = string.rep("0", 4 - rem)..s
+       end
+
+       for i = 1, l, 4 do
+               b = string.sub(s, i, i+3)
+               h = h..bin2hex[b]
+       end
+
+       return h
+
+end
+
+
+function Bin2Dec(s)
+
+-- s   -> binary string
+
+local num = 0
+local ex = string.len(s) - 1
+local l = 0
+
+       l = ex + 1
+       for i = 1, l do
+               b = string.sub(s, i, i)
+               if b == "1" then
+                       num = num + 2^ex
+               end
+               ex = ex - 1
+       end
+
+       return string.format("%u", num)
+
+end
+
+
+
+function Dec2Bin(s, num)
+
+-- s   -> Base10 string
+-- num  -> string length to extend to
+
+local n
+
+       if (num == nil) then
+               n = 0
+       else
+               n = num
+       end
+
+       s = string.format("%x", s)
+
+       s = Hex2Bin(s)
+
+       while string.len(s) < n do
+               s = "0"..s
+       end
+
+       return s
+
+end
+
+
+
+
+function Hex2Dec(s)
+
+-- s   -> hexadecimal string
+
+local s = Hex2Bin(s)
+
+       return Bin2Dec(s)
+
+end
+
+
+
+function Dec2Hex(s)
+
+-- s   -> Base10 string
+
+       s = string.format("%x", s)
+
+       return s
+
+end
+
+
+
+
+-- These functions are big-endian and will extend to 32 bits
+
+-- BMAnd
+-- BMNAnd
+-- BMOr
+-- BMXOr
+-- BMNot
+
+
+function BMAnd(v, m)
+
+-- v   -> hex string to be masked
+-- m   -> hex string mask
+
+-- s   -> hex string as masked
+
+-- bv  -> binary string of v
+-- bm  -> binary string mask
+
+local bv = Hex2Bin(v)
+local bm = Hex2Bin(m)
+
+local i = 0
+local s = ""
+
+       while (string.len(bv) < 32) do
+               bv = "0000"..bv
+       end
+
+       while (string.len(bm) < 32) do
+               bm = "0000"..bm
+       end
+
+
+       for i = 1, 32 do
+               cv = string.sub(bv, i, i)
+               cm = string.sub(bm, i, i)
+               if cv == cm then
+                       if cv == "1" then
+                               s = s.."1"
+                       else
+                               s = s.."0"
+                       end
+               else
+                       s = s.."0"
+
+               end
+       end
+
+       return Bin2Hex(s)
+
+end
+
+
+function BMNAnd(v, m)
+
+-- v   -> hex string to be masked
+-- m   -> hex string mask
+
+-- s   -> hex string as masked
+
+-- bv  -> binary string of v
+-- bm  -> binary string mask
+
+local bv = Hex2Bin(v)
+local bm = Hex2Bin(m)
+
+local i = 0
+local s = ""
+
+       while (string.len(bv) < 32) do
+               bv = "0000"..bv
+       end
+
+       while (string.len(bm) < 32) do
+               bm = "0000"..bm
+       end
+
+
+       for i = 1, 32 do
+               cv = string.sub(bv, i, i)
+               cm = string.sub(bm, i, i)
+               if cv == cm then
+                       if cv == "1" then
+                               s = s.."0"
+                       else
+                               s = s.."1"
+                       end
+               else
+                       s = s.."1"
+
+               end
+       end
+
+       return Bin2Hex(s)
+
+end
+
+
+
+function BMOr(v, m)
+
+-- v   -> hex string to be masked
+-- m   -> hex string mask
+
+-- s   -> hex string as masked
+
+-- bv  -> binary string of v
+-- bm  -> binary string mask
+
+local bv = Hex2Bin(v)
+local bm = Hex2Bin(m)
+
+local i = 0
+local s = ""
+
+       while (string.len(bv) < 32) do
+               bv = "0000"..bv
+       end
+
+       while (string.len(bm) < 32) do
+               bm = "0000"..bm
+       end
+
+
+       for i = 1, 32 do
+               cv = string.sub(bv, i, i)
+               cm = string.sub(bm, i, i)
+               if cv == "1" then
+                               s = s.."1"
+               elseif cm == "1" then
+                               s = s.."1"
+               else
+                       s = s.."0"
+               end
+       end
+
+       return Bin2Hex(s)
+
+end
+
+function BMXOr(v, m)
+
+-- v   -> hex string to be masked
+-- m   -> hex string mask
+
+-- s   -> hex string as masked
+
+-- bv  -> binary string of v
+-- bm  -> binary string mask
+
+local bv = Hex2Bin(v)
+local bm = Hex2Bin(m)
+
+local i = 0
+local s = ""
+
+       while (string.len(bv) < 32) do
+               bv = "0000"..bv
+       end
+
+       while (string.len(bm) < 32) do
+               bm = "0000"..bm
+       end
+
+
+       for i = 1, 32 do
+               cv = string.sub(bv, i, i)
+               cm = string.sub(bm, i, i)
+               if cv == "1" then
+                       if cm == "0" then
+                               s = s.."1"
+                       else
+                               s = s.."0"
+                       end
+               elseif cm == "1" then
+                       if cv == "0" then
+                               s = s.."1"
+                       else
+                               s = s.."0"
+                       end
+               else
+                       -- cv and cm == "0"
+                       s = s.."0"
+               end
+       end
+
+       return Bin2Hex(s)
+
+end
+
+
+function BMNot(v, m)
+
+-- v   -> hex string to be masked
+-- m   -> hex string mask
+
+-- s   -> hex string as masked
+
+-- bv  -> binary string of v
+-- bm  -> binary string mask
+
+local bv = Hex2Bin(v)
+local bm = Hex2Bin(m)
+
+local i = 0
+local s = ""
+
+       while (string.len(bv) < 32) do
+               bv = "0000"..bv
+       end
+
+       while (string.len(bm) < 32) do
+               bm = "0000"..bm
+       end
+
+
+       for i = 1, 32 do
+               cv = string.sub(bv, i, i)
+               cm = string.sub(bm, i, i)
+               if cm == "1" then
+                       if cv == "1" then
+                               -- turn off
+                               s = s.."0"
+                       else
+                               -- turn on
+                               s = s.."1"
+                       end
+               else
+                       -- leave untouched
+                       s = s..cv
+
+               end
+       end
+
+       return Bin2Hex(s)
+
+end
+
+
+-- these functions shift right and left, adding zeros to lost or gained bits
+-- returned values are 32 bits long
+
+-- BShRight(v, nb)
+-- BShLeft(v, nb)
+
+
+function BShRight(v, nb)
+
+-- v   -> hexstring value to be shifted
+-- nb  -> number of bits to shift to the right
+
+-- s   -> binary string of v
+
+local s = Hex2Bin(v)
+
+       while (string.len(s) < 32) do
+               s = "0000"..s
+       end
+
+       s = string.sub(s, 1, 32 - nb)
+
+       while (string.len(s) < 32) do
+               s = "0"..s
+       end
+
+       return Bin2Hex(s)
+
+end
+
+function BShLeft(v, nb)
+
+-- v   -> hexstring value to be shifted
+-- nb  -> number of bits to shift to the right
+
+-- s   -> binary string of v
+
+local s = Hex2Bin(v)
+
+       while (string.len(s) < 32) do
+               s = "0000"..s
+       end
+
+       s = string.sub(s, nb + 1, 32)
+
+       while (string.len(s) < 32) do
+               s = s.."0"
+       end
+
+       return Bin2Hex(s)
+
+end
\ No newline at end of file
index 334768c..f50b014 100644 (file)
@@ -26,6 +26,8 @@ limitations under the License.
 
 module("ffluci.sys", package.seeall)
 require("posix")
+require("ffluci.bits")
+require("ffluci.util")
 
 -- Runs "command" and returns its output
 function exec(command)
@@ -68,6 +70,11 @@ function hostname()
        return io.lines("/proc/sys/kernel/hostname")()
 end
 
+-- Returns the contents of a documented referred by an URL
+function httpget(url)
+       return exec("wget -qO- '"..url:gsub("'", "").."'")
+end
+
 -- Returns the load average
 function loadavg()
        local loadavg = io.lines("/proc/loadavg")()
@@ -79,11 +86,49 @@ function reboot()
        return os.execute("reboot >/dev/null 2>&1")
 end
 
+-- Returns the system type, cpu name, and installed physical memory
+function sysinfo()
+       local c1 = "cat /proc/cpuinfo|grep system\\ typ|cut -d: -f2 2>/dev/null"
+       local c2 = "uname -m 2>/dev/null"
+       local c3 = "cat /proc/cpuinfo|grep model\\ name|cut -d: -f2 2>/dev/null"
+       local c4 = "cat /proc/cpuinfo|grep cpu\\ model|cut -d: -f2 2>/dev/null"
+       local c5 = "cat /proc/meminfo|grep MemTotal|cut -d: -f2 2>/dev/null"
+       
+       local s = ffluci.util.trim(exec(c1))
+       local m = ""
+       local r = ""
+       
+       if s == "" then
+               s = ffluci.util.trim(exec(c2))
+               m = ffluci.util.trim(exec(c3))
+       else
+               m = ffluci.util.trim(exec(c4))
+       end
+       
+       r = ffluci.util.trim(exec(c5))
+       
+       return s, m, r
+end
+
 
 group = {}
 group.getgroup = posix.getgroup
 
 net = {}
+-- Returns whether an IP-Adress belongs to a certain net
+function net.belongs(ip, net)
+       local netparts = ffluci.util.split(net, "/")
+       
+       if #netparts ~= 2 then
+               return nil
+       end
+       
+       local binadr = net.ip4bin(ip)
+       local binnet = net.ip4bin(netparts[1])
+       
+       return (binadr:sub(1, netparts[2]) == binnet:sub(1, netparts[2]))
+end
+
 -- Returns all available network interfaces
 function net.devices()
        local devices = {}
@@ -93,6 +138,52 @@ function net.devices()
        return devices
 end
 
+-- Returns the kernel routing table
+function net.routes()
+       return _parse_delimited_table(io.lines("/proc/net/route"))
+end
+
+-- Returns the numeric IP to a given hexstring
+function net.hexip4(hex)
+       if #hex ~= 8 then
+               return nil
+       end
+       
+       local hexdec = ffluci.bits.Hex2Dec
+       
+       local ip = ""
+       ip = ip .. tostring(hexdec(hex:sub(7,8))) .. "."
+       ip = ip .. tostring(hexdec(hex:sub(5,6))) .. "."
+       ip = ip .. tostring(hexdec(hex:sub(3,4))) .. "."
+       ip = ip .. tostring(hexdec(hex:sub(1,2)))
+       
+       return ip
+end
+
+-- Returns the binary IP to a given IP
+function net.ip4bin(ip)
+       local parts = ffluci.util.split(ip, '%.')
+       if #parts ~= 4 then
+               return nil
+       end
+       
+       local decbin = ffluci.bits.Dec2Bin
+       
+       local bin = ""
+       bin = bin .. decbin(parts[1], 8)
+       bin = bin .. decbin(parts[2], 8)
+       bin = bin .. decbin(parts[3], 8)
+       bin = bin .. decbin(parts[4], 8)
+       
+       return bin
+end
+
+-- Tests whether a host is pingable
+function net.pingtest(host)
+       return os.execute("ping -c1 '"..host:gsub("'", '').."' >/dev/null 2>&1")
+end
+
+
 process = {}
 process.info = posix.getpid 
 
@@ -123,4 +214,94 @@ function user.setpasswd(user, pwd)
        local cmd = "(echo '"..pwd.."';sleep 1;echo '"..pwd.."')|"
        cmd = cmd .. "passwd '"..user.."' >/dev/null 2>&1"
        return os.execute(cmd)
+end
+
+
+wifi = {}
+
+function wifi.getiwconfig()
+       local cnt = exec("/usr/sbin/iwconfig 2>/dev/null")
+       local iwc = {}
+       
+       for i, l in pairs(ffluci.util.split(ffluci.util.trim(cnt), "\n\n")) do
+               local k = l:match("^(.-) ")
+               l = l:gsub("^(.-) +", "", 1)
+               if k then
+                       iwc[k] = _parse_mixed_record(l)
+               end
+       end
+       
+       return iwc      
+end
+
+function wifi.iwscan()
+       local cnt = exec("iwlist scan 2>/dev/null")
+       local iws = {}
+       
+       for i, l in pairs(ffluci.util.split(ffluci.util.trim(cnt), "\n\n")) do
+               local k = l:match("^(.-) ")
+               l = l:gsub("^[^\n]+", "", 1)
+               if k then
+                       iws[k] = {}
+                       for j, c in pairs(ffluci.util.split(l, "\n          Cell")) do
+                               c = c:gsub("^(.-)- ", "", 1)
+                               c = ffluci.util.split(c, "\n", 7)
+                               c = table.concat(c, "\n", 1, 7)
+                               table.insert(iws[k], _parse_mixed_record(c))
+                       end
+               end
+       end
+       
+       return iws      
+end
+
+
+-- Internal functions
+
+function _parse_delimited_table(iter, delimiter)
+       delimiter = delimiter or "\t+"
+       
+       local data  = {}
+       local trim  = ffluci.util.trim
+       local split = ffluci.util.split
+       
+       local keys = split(trim(iter()), delimiter)
+       for i, j in pairs(keys) do
+               keys[i] = trim(keys[i])
+       end
+       
+       for line in iter do
+               local row = {}
+               line = trim(line)
+               if #line > 0 then
+                       for i, j in pairs(split(line, delimiter)) do
+                               if keys[i] then
+                                       row[keys[i]] = j
+                               end
+                       end
+               end
+               table.insert(data, row)
+       end
+       
+       return data
+end
+
+function _parse_mixed_record(cnt)
+       local data = {}
+       
+       for i, l in pairs(ffluci.util.split(ffluci.util.trim(cnt), "\n")) do
+       for j, f in pairs(ffluci.util.split(ffluci.util.trim(l), "  ")) do
+               local k, x, v = f:match('([^%s][^:=]+) *([:=]*) *"*([^\n"]*)"*')
+
+            if k then
+                               if x == "" then
+                                       table.insert(data, k)                           
+                               else
+                       data[k] = v
+                               end
+            end
+       end
+       end
+               
+    return data
 end
\ No newline at end of file
index 4f8160a..f65478c 100644 (file)
@@ -1 +1 @@
-module(..., package.seeall)
\ No newline at end of file
+module("ffluci.controller.public.index", package.seeall)
\ No newline at end of file
diff --git a/module/public-core/src/controller/public/status.lua b/module/public-core/src/controller/public/status.lua
new file mode 100644 (file)
index 0000000..a786eb2
--- /dev/null
@@ -0,0 +1,22 @@
+module("ffluci.controller.public.status", package.seeall)
+
+function action_index()
+       local data = {}
+       
+       data.s, data.m, data.r = ffluci.sys.sysinfo()
+       
+       data.wifi = ffluci.sys.wifi.getiwconfig()
+       
+       data.routes = {}
+       for i, r in pairs(ffluci.sys.net.routes()) do
+               if r.Destination == "00000000" then
+                       r.Gateway = ffluci.sys.net.hexip4(r.Gateway)
+                       table.insert(data.routes, r)
+               end
+       end
+
+       
+       ffluci.template.render("public_status/index", data)
+end
+
+
diff --git a/module/public-core/src/controller/sudo/status.lua b/module/public-core/src/controller/sudo/status.lua
new file mode 100644 (file)
index 0000000..fd5127d
--- /dev/null
@@ -0,0 +1 @@
+module("ffluci.controller.sudo.status", package.seeall)
\ No newline at end of file
index c488f43..2e96a5b 100644 (file)
@@ -1,2 +1,7 @@
 add("public", "index", "Übersicht", 10)
 act("contact", "Kontakt")
+
+add("public", "status", "Status", 20)
+act("routes", "Routingtabelle")
+act("internet", "Internetzugang")
+act("iwscan", "WLAN-Scan")
\ No newline at end of file
index e5aee19..d19df7e 100644 (file)
@@ -1,13 +1,13 @@
 <%+header%>
 <% local contact = ffluci.model.uci.show("freifunk", "contact").freifunk.contact %>
 <h1><%:contact Kontakt%></h1>
-<table class="contact">
-       <tr><th style="text-align: right"><%:nickname Pseudonym%>:</th><td><%=contact.nickname%></td></tr>
-       <tr><th style="text-align: right"><%:name Name%>:</th><td><%=contact.name%></td></tr>
-       <tr><th style="text-align: right"><%:mail E-Mail%>:</th><td><%=contact.mail%></td></tr>
-       <tr><th style="text-align: right"><%:phone Telefon%>:</th><td><%=contact.phone%></td></tr>
-       <tr><th style="text-align: right"><%:location Standort%>:</th><td><%=contact.location%></td></tr>
-       <tr><th style="text-align: right"><%:geocoord Geokoordinaten%>:</th><td><%=contact.geo%></td></tr>
-       <tr><th style="text-align: right"><%:note Notiz%>:</th><td><%=contact.note%></td></tr>
+<table cellspacing="0" cellpadding="6">
+       <tr><th><%:nickname Pseudonym%>:</th><td><%=contact.nickname%></td></tr>
+       <tr><th><%:name Name%>:</th><td><%=contact.name%></td></tr>
+       <tr><th><%:mail E-Mail%>:</th><td><%=contact.mail%></td></tr>
+       <tr><th><%:phone Telefon%>:</th><td><%=contact.phone%></td></tr>
+       <tr><th><%:location Standort%>:</th><td><%=contact.location%></td></tr>
+       <tr><th><%:geocoord Geokoordinaten%>:</th><td><%=contact.geo%></td></tr>
+       <tr><th><%:note Notiz%>:</th><td><%=contact.note%></td></tr>
 </table>
 <%+footer%>
\ No newline at end of file
index 838bf02..a8a469e 100644 (file)
@@ -6,6 +6,6 @@
 <a href="<%=controller%>/public/index/contact"><%=ff.contact.nickname%></a>.</p>
 <p><%:public4 Weitere Informationen zur globalen Freifunkinitiative findest du unter%> <a href="http://freifunk.net">Freifunk.net</a>.<br />
 <%:public5 Hast du Interesse an diesem Projekt, dann wende dich an deine lokale Gemeinschaft%> <a href="<%=ff.community.homepage%>"><%=ff.community.name%></a>.</p>
-<p><strong><%:note Hinweis%></strong>:<%:public6 Der Internetzugang über das experimentelle Freifunknetz ist an technische und organisatorische Bedingungen geknüpft und deshalb möglicherweise
+<p><strong><%:note Hinweis%></strong>: <%:public6 Der Internetzugang über das experimentelle Freifunknetz ist an technische und organisatorische Bedingungen geknüpft und deshalb möglicherweise
 nicht (immer) gewährleistet.%></p>
 <%+footer%>
\ No newline at end of file
diff --git a/module/public-core/src/view/public_status/index.htm b/module/public-core/src/view/public_status/index.htm
new file mode 100644 (file)
index 0000000..d81125d
--- /dev/null
@@ -0,0 +1,74 @@
+<%+header%>
+<h1><%:status Status%></h1>
+<h2><%:system System%></h2>
+
+<br />
+<table cellspacing="0" cellpadding="6" class="smalltext">
+<tr>
+<th><%:system_type Systemtyp%>:</th>
+<td><%=s%></td>
+</tr>
+<tr>
+<th><%:cpu Prozessor%>:</th>
+<td><%=m%></td>
+</tr>
+<tr>
+<th><%:ram Hauptspeicher%>:</th>
+<td><%=r%></td>
+</tr>
+</table>
+<br /><br />
+
+<h2><%:wifi Drahtlos%></h2>
+<br />
+<table cellspacing="0" cellpadding="6" class="smalltext">
+<tr>
+<th><%:name Name%></th>
+<th><%:protocol Protokoll%></th>
+<th><%:frequency Frequenz%></th>
+<th><%:power Leistung%></th>
+<th><%:bitrate Bitrate%></th>
+<th><%:rts RTS%></th>
+<th><%:frag Frag.%></th>
+<th><%:link Verb.%></th>
+<th><%:signal Signal%></th>
+<th><%:noise Rausch%></th>
+</tr>
+<%for k, v in pairs(wifi) do%>
+<tr>
+<td rowspan="2"><%=k%></td>
+<td><%=v[1]%></td>
+<td><%=v.Frequency%></td>
+<td><%=v["Tx-Power"]%></td>
+<td><%=v["Bit Rate"]%></td>
+<td><%=v["RTS thr"]%></td>
+<td><%=v["Fragment thr"]%></td>
+<td><%=v["Link Quality"]%></td>
+<td><%=v["Signal level"]%></td>
+<td><%=v["Noise level"]%></td>
+</tr>
+<tr>
+<td colspan="4"><strong><%:essid ESSID%>: </strong><%=v.ESSID%></td>
+<td colspan="5"><strong><%:bssid BSSID%>: </strong><%=(v.Cell or v["Access Point"])%></td>
+</tr>
+<%end%>
+</table>
+<br />
+<br />
+<h2><%:defroutes Standardrouten%></h2>
+<br />
+<table cellspacing="0" cellpadding="6" class="smalltext">
+<tr>
+<th><%:gateway Gateway%></th>
+<th><%:metric Metrik%></th>
+<th><%:iface Schnittstelle%></th>
+</tr>
+<% for i, rt in pairs(routes) do%>
+<tr>
+<td><%=rt.Gateway%></th>
+<td><%=rt.Metric%></th>
+<td><%=rt.Iface%></th>
+</tr>
+<% end %>
+</table>
+<%+footer%>
\ No newline at end of file
diff --git a/module/public-core/src/view/public_status/internet.htm b/module/public-core/src/view/public_status/internet.htm
new file mode 100644 (file)
index 0000000..afa8fbf
--- /dev/null
@@ -0,0 +1,32 @@
+<%+header%>
+<h1><%:inetaccess Internetzugangstest%></h1>
+<br />
+
+<table cellspacing="0" cellpadding="6" class="smalltext">
+<tr>
+<th><%:target Ziel%></th>
+<th><%:host Host%></th>
+<th><%:result Ergebnis%></th>
+</tr>
+<%
+local tests = {}
+tests[1] = {descr = "Chaos Computer Club Deutschland", target = "213.73.91.29"}
+tests[2] = {descr = "Kernel.org - Mirror Niederlande", target = "199.6.1.164"}
+tests[3] = {descr = "Debian.org - Mirror Deutschland", target = "www.de.debian.org"}
+tests[4] = {descr = "Wikimedia Deutschland", target = "www.wikimedia.de"}
+
+for i, t in ipairs(tests) do 
+%>
+<tr>
+<td><%=t.descr%></td>
+<td><%=t.target%></td>
+<% if ffluci.sys.net.pingtest(t.target) == 0 then %>
+<td class="ok"><%:ok OK%></td>
+<% else %>
+<td class="error"><%:failed fehlgeschlagen%></td>
+<% end %>
+</tr>
+<% end %>
+</table>
+<br />
+<%+footer%>
\ No newline at end of file
diff --git a/module/public-core/src/view/public_status/iwscan.htm b/module/public-core/src/view/public_status/iwscan.htm
new file mode 100644 (file)
index 0000000..a8924c8
--- /dev/null
@@ -0,0 +1,21 @@
+<%+header%>
+<h1><%:iwscan WLAN-Scan%></h1>
+<p><%:iwscan1 Drahtlosnetzwerke in der lokalen Umgebung des Routers:%></p>
+
+<br />
+<table cellspacing="0" cellpadding="6" class="smalltext">
+<tr>
+<th><%:interface Schnittstelle%></th>
+<th><%:essid ESSID%></th>
+<th><%:bssid BSSID%></th>
+<th><%:mode Modus%></th>
+<th><%:channel Kanal%></th>
+<th><%:encr Vers.%></th>
+<th><%:link Verb.%></th>
+<th><%:signal Signal%></th>
+<th><%:noise Rausch%></th>
+</tr>
+<%=ffluci.sys.httpget("http://127.0.0.1" .. controller .. "/sudo/status/iwscan")%>
+</table>
+<br />
+<%+footer%>
\ No newline at end of file
diff --git a/module/public-core/src/view/public_status/routes.htm b/module/public-core/src/view/public_status/routes.htm
new file mode 100644 (file)
index 0000000..046c789
--- /dev/null
@@ -0,0 +1,24 @@
+<%+header%>
+<h1><%:routes Routen%></h1>
+
+<br />
+<table cellspacing="0" cellpadding="6" class="smalltext">
+<tr>
+<th><%:target Ziel%></th>
+<th><%:netmask Netzmaske%></th>
+<th><%:gateway Gateway%></th>
+<th><%:metric Metrik%></th>
+<th><%:iface Schnittstelle%></th>
+</tr>
+<% for i, r in pairs(ffluci.sys.net.routes()) do %>
+<tr>
+<td><%=ffluci.sys.net.hexip4(r.Destination)%></td>
+<td><%=ffluci.sys.net.hexip4(r.Mask)%></td>
+<td><%=ffluci.sys.net.hexip4(r.Gateway)%></td>
+<td><%=r.Metric%></td>
+<td><%=r.Iface%></td>
+</tr>
+<% end %>
+</table>
+<br />
+<%+footer%>
\ No newline at end of file
diff --git a/module/public-core/src/view/sudo_status/iwscan.htm b/module/public-core/src/view/sudo_status/iwscan.htm
new file mode 100644 (file)
index 0000000..483039f
--- /dev/null
@@ -0,0 +1,22 @@
+<%
+ffluci.http.textheader()
+for iface, cells in pairs(ffluci.sys.wifi.iwscan()) do
+       for i, cell in ipairs(cells) do 
+%>
+<tr>
+<td><%=iface%></td>
+<td><%=cell.ESSID%></td>
+<td><%=cell.Address%></td>
+<td><%=cell.Mode%></td>
+<td><%=cell.Channel%></td>
+<td><%=cell["Encryption key"]%></td>
+<td><%=cell.Quality%></td>
+<td><%=cell["Signal level"]%></td>
+<td><%=cell["Noise level"]%></td>
+</tr>
+<%
+       end
+end
+%>
+
+
index bc3c95e..ad1de6f 100644 (file)
@@ -182,6 +182,12 @@ code {
        white-space: pre;
 }
 
+table th, table, td {
+       vertical-align: top;
+       text-align: left;
+       border: 1px solid gray;
+}
+
 .cbi-section {
        margin-top: 1em;
 }