Merge pull request #939 from dibdot/master
authorHannu Nyman <hannu.nyman@iki.fi>
Thu, 12 Jan 2017 20:36:10 +0000 (22:36 +0200)
committerGitHub <noreply@github.com>
Thu, 12 Jan 2017 20:36:10 +0000 (22:36 +0200)
luci-app-travelmate: update gui elements

45 files changed:
applications/luci-app-fwknopd/luasrc/model/cbi/fwknopd.lua
applications/luci-app-fwknopd/luasrc/view/fwknopd-qr.htm
applications/luci-app-fwknopd/po/en/fwknopd.po
applications/luci-app-fwknopd/po/templates/fwknopd.pot
applications/luci-app-fwknopd/root/etc/uci-defaults/40_luci-fwknopd
applications/luci-app-fwknopd/root/usr/sbin/gen-qr.sh
applications/luci-app-olsr/luasrc/controller/olsr.lua
applications/luci-app-olsr/luasrc/view/status-olsr/neighbors.htm
applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/df.lua
applications/luci-app-wifischedule/luasrc/controller/wifischedule/wifi_schedule.lua
applications/luci-app-wifischedule/luasrc/model/cbi/wifischedule/wifi_schedule.lua
applications/luci-app-wifischedule/luasrc/view/wifischedule/file_viewer.htm
applications/luci-app-wifischedule/po/ja/wifischedule.po
applications/luci-app-wifischedule/po/templates/wifischedule.pot
applications/luci-app-wifischedule/po/zh-cn/wifischedule.po
collections/luci-ssl-openssl/Makefile
modules/luci-base/luasrc/tools/webadmin.lua
modules/luci-base/po/ca/base.po
modules/luci-base/po/cs/base.po
modules/luci-base/po/de/base.po
modules/luci-base/po/el/base.po
modules/luci-base/po/en/base.po
modules/luci-base/po/es/base.po
modules/luci-base/po/fr/base.po
modules/luci-base/po/he/base.po
modules/luci-base/po/hu/base.po
modules/luci-base/po/it/base.po
modules/luci-base/po/ja/base.po
modules/luci-base/po/ko/base.po
modules/luci-base/po/ms/base.po
modules/luci-base/po/no/base.po
modules/luci-base/po/pl/base.po
modules/luci-base/po/pt-br/base.po
modules/luci-base/po/pt/base.po
modules/luci-base/po/ro/base.po
modules/luci-base/po/ru/base.po
modules/luci-base/po/sk/base.po
modules/luci-base/po/sv/base.po
modules/luci-base/po/templates/base.pot
modules/luci-base/po/tr/base.po
modules/luci-base/po/uk/base.po
modules/luci-base/po/vi/base.po
modules/luci-base/po/zh-cn/base.po
modules/luci-base/po/zh-tw/base.po
modules/luci-mod-admin-full/luasrc/model/cbi/admin_network/wifi_add.lua

index 096724f..4358374 100644 (file)
@@ -1,19 +1,19 @@
 -- Copyright 2015 Jonathan Bennett <jbennett@incomsystems.biz>
 -- Licensed to the public under the GNU General Public License v2.
-
+tmp = 0
 m = Map("fwknopd", translate("Firewall Knock Operator"))
 
 s = m:section(TypedSection, "global", translate("Enable Uci/Luci control")) -- Set uci control on or off
 s.anonymous=true
 s:option(Flag, "uci_enabled", translate("Enable config overwrite"), translate("When unchecked, the config files in /etc/fwknopd will be used as is, ignoring any settings here."))
-qr = s:option(DummyValue, "note0", "dummy")
-qr.template = "fwknopd-qr"
-qr:depends("uci_enabled", "1")
 
 s = m:section(TypedSection, "access", translate("access.conf stanzas")) -- set the access.conf settings
 s.anonymous=true
 s.addremove=true
-s.dynamic=true
+qr = s:option(DummyValue, "note0", "dummy")
+qr.tmp = tmp
+qr.template = "fwknopd-qr"
+qr:depends("uci_enabled", "1")
 s:option(Value, "SOURCE", "SOURCE", translate("Use ANY for any source ip"))
 k1 = s:option(Value, "KEY", "KEY", translate("Define the symmetric key used for decrypting an incoming SPA packet that is encrypted by the fwknop client with Rijndael."))
 k1:depends("keytype", translate("Normal Key"))
@@ -40,15 +40,13 @@ s:option(Value, "REQUIRE_SOURCE_ADDRESS", "REQUIRE_SOURCE_ADDRESS", translate("F
                                        This makes it impossible to use the -s command line argument on the fwknop client command line, so either -R \
                                        has to be used to automatically resolve the external address (if the client behind a NAT) or the client must \
                                        know the external IP and set it via the -a argument."))
-s:option(DummyValue, "note1", translate("Enter custom access.conf variables below:"))
 
 s = m:section(TypedSection, "config", translate("fwknopd.conf config options")) 
 s.anonymous=true
-s.dynamic=true
 s:option(Value, "MAX_SPA_PACKET_AGE", "MAX_SPA_PACKET_AGE", translate("Maximum age in seconds that an SPA packet will be accepted. defaults to 120 seconds"))
 s:option(Value, "PCAP_INTF", "PCAP_INTF", translate("Specify the ethernet interface on which fwknopd will sniff packets."))
 s:option(Value, "ENABLE_IPT_FORWARDING", "ENABLE_IPT_FORWARDING", translate("Allow SPA clients to request access to services through an iptables firewall instead of just to it."))
-s:option(DummyValue, "note2", translate("Enter custom fwknopd.conf variables below:"))
+s:option(Value, "ENABLE_NAT_DNS", "ENABLE_NAT_DNS", translate("Allow SPA clients to request forwarding destination by DNS name."))
 
 return m
 
index 9e6e818..5773f52 100644 (file)
@@ -1 +1,2 @@
-<% print(luci.sys.exec("sh /usr/sbin/gen-qr.sh")) %>
+<% print(luci.sys.exec("sh /usr/sbin/gen-qr.sh " .. self.tmp)) %>
+<% self.tmp = self.tmp + 1 %>
index d75c99d..fbdd8d7 100644 (file)
@@ -17,6 +17,9 @@ msgstr ""
 "Allow SPA clients to request access to services through an iptables firewall "
 "instead of just to it."
 
+msgid "Allow SPA clients to request forwarding destination by DNS name."
+msgstr ""
+
 msgid "Base 64 key"
 msgstr "Base 64 key"
 
@@ -55,12 +58,6 @@ msgstr "Enable Uci/Luci control"
 msgid "Enable config overwrite"
 msgstr "Enable config overwrite"
 
-msgid "Enter custom access.conf variables below:"
-msgstr "Enter custom access.conf variables below:"
-
-msgid "Enter custom fwknopd.conf variables below:"
-msgstr "Enter custom fwknopd.conf variables below:"
-
 msgid "Firewall Knock Daemon"
 msgstr "Firewall Knock Daemon"
 
@@ -111,3 +108,9 @@ msgstr "access.conf stanzas"
 
 msgid "fwknopd.conf config options"
 msgstr "fwknopd.conf config options"
+
+#~ msgid "Enter custom access.conf variables below:"
+#~ msgstr "Enter custom access.conf variables below:"
+
+#~ msgid "Enter custom fwknopd.conf variables below:"
+#~ msgstr "Enter custom fwknopd.conf variables below:"
index 4fb616f..1010ba7 100644 (file)
@@ -6,6 +6,9 @@ msgid ""
 "instead of just to it."
 msgstr ""
 
+msgid "Allow SPA clients to request forwarding destination by DNS name."
+msgstr ""
+
 msgid "Base 64 key"
 msgstr ""
 
@@ -34,12 +37,6 @@ msgstr ""
 msgid "Enable config overwrite"
 msgstr ""
 
-msgid "Enter custom access.conf variables below:"
-msgstr ""
-
-msgid "Enter custom fwknopd.conf variables below:"
-msgstr ""
-
 msgid "Firewall Knock Daemon"
 msgstr ""
 
index 01b85de..65ef012 100644 (file)
@@ -16,6 +16,7 @@ uci set fwknopd.@access[0].hkeytype='Base 64 key'
 uci set fwknopd.@access[0].KEY_BASE64=`fwknopd --key-gen | awk '/^KEY/ {print $2;}'`
 uci set fwknopd.@access[0].HMAC_KEY_BASE64=`fwknopd --key-gen | awk '/^HMAC/ {print $2;}'`
 uci set fwknopd.@config[0].ENABLE_IPT_FORWARDING='y'
+uci set fwknopd.@config[0].ENABLE_NAT_DNS='y'
 
 uci commit fwknopd
 rm -f /tmp/luci-indexcache
index 97493da..abca5d3 100644 (file)
@@ -1,9 +1,13 @@
 #!/bin/sh
+entry_num=0
+if [ "$1" != "" ]; then
+entry_num=$1
+fi
 
-key_base64=$(uci get fwknopd.@access[0].KEY_BASE64)
-key=$(uci get fwknopd.@access[0].KEY)
-hmac_key_base64=$(uci get fwknopd.@access[0].HMAC_KEY_BASE64)
-hmac_key=$(uci get fwknopd.@access[0].HMAC_KEY)
+key_base64=$(uci get fwknopd.@access[$entry_num].KEY_BASE64)
+key=$(uci get fwknopd.@access[$entry_num].KEY)
+hmac_key_base64=$(uci get fwknopd.@access[$entry_num].HMAC_KEY_BASE64)
+hmac_key=$(uci get fwknopd.@access[$entry_num].HMAC_KEY)
 
 if [ $key_base64 != "" ]; then
 qr="KEY_BASE64:$key_base64"
index 9a997bd..0564bd4 100644 (file)
@@ -87,8 +87,8 @@ function action_json()
        local v4_port = uci:get("olsrd", "olsrd_jsoninfo", "port") or 9090
        local v6_port = uci:get("olsrd6", "olsrd_jsoninfo", "port") or 9090
 
-       jsonreq4 = utl.exec("(echo /status | nc 127.0.0.1 " .. v4_port .. ") 2>/dev/null" )
-       jsonreq6 = utl.exec("(echo /status | nc ::1 " .. v6_port .. ") 2>/dev/null")
+       jsonreq4 = utl.exec("(echo /status | nc 127.0.0.1 " .. v4_port .. " | sed -n '/^[}{ ]/p') 2>/dev/null" )
+       jsonreq6 = utl.exec("(echo /status | nc ::1 " .. v6_port .. " | sed -n '/^[}{ ]/p') 2>/dev/null")
        http.prepare_content("application/json")
        if not jsonreq4 or jsonreq4 == "" then
                jsonreq4 = "{}"
@@ -375,8 +375,8 @@ function fetch_jsoninfo(otable)
        local v4_port = uci:get("olsrd", "olsrd_jsoninfo", "port") or 9090
        local v6_port = uci:get("olsrd6", "olsrd_jsoninfo", "port") or 9090
 
-       jsonreq4 = utl.exec("(echo /" .. otable .. " | nc 127.0.0.1 " .. v4_port .. ") 2>/dev/null")
-       jsonreq6 = utl.exec("(echo /" .. otable .. " | nc ::1 " .. v6_port .. ") 2>/dev/null")
+       jsonreq4 = utl.exec("(echo /" .. otable .. " | nc 127.0.0.1 " .. v4_port .. " | sed -n '/^[}{ ]/p') 2>/dev/null")
+       jsonreq6 = utl.exec("(echo /" .. otable .. " | nc ::1 " .. v6_port .. " | sed -n '/^[}{ ]/p') 2>/dev/null")
        local jsondata4 = {}
        local jsondata6 = {}
        local data4 = {}
index 31dd7d0..c077c20 100644 (file)
@@ -12,8 +12,8 @@ local i = 1
 if luci.http.formvalue("status") == "1" then
        local rv = {}
        for k, link in ipairs(links) do
-               link.linkCost = tonumber(link.linkCost)/1024 or 0
-               if link.linkCost == 4096 then
+               link.linkCost = tonumber(link.linkCost) or 0
+               if link.linkCost == 4194304 then
                        link.linkCost = 0
                end
                local color = olsrtools.etx_color(link.linkCost)
@@ -129,8 +129,8 @@ end
                <tbody id="olsr_neigh_table">
                <%      local i = 1
                        for k, link in ipairs(links) do
-                       link.linkCost = tonumber(link.linkCost)/1024 or 0
-                       if link.linkCost == 4096 then
+                       link.linkCost = tonumber(link.linkCost) or 0
+                       if link.linkCost == 4194304 then
                                link.linkCost = 0
                        end
 
index fbc3884..b5633c1 100644 (file)
@@ -8,7 +8,6 @@ function rrdargs( graph, plugin, plugin_instance, dtype )
        return {
                title = "%H: Disk space usage on %pi",
                vlabel = "Bytes",
-               per_instance  = true,
                number_format = "%5.1lf%sB",
 
                data = {
index 4743453..261cf36 100644 (file)
 --
 -- Author: Nils Koenig <openwrt@newk.it>
 
-module("luci.controller.wifischedule.wifi_schedule", package.seeall)  
+module("luci.controller.wifischedule.wifi_schedule", package.seeall)
+
+local fs = require "nixio.fs"
+local sys = require "luci.sys"
+local template = require "luci.template"
+local i18n = require "luci.i18n"
 
 function index()
-     entry({"admin", "wifi_schedule"}, firstchild(), _("Wifi Schedule"), 60).dependent=false
-     entry({"admin", "wifi_schedule", "tab_from_cbi"}, cbi("wifischedule/wifi_schedule"), _("Schedule"), 1)
-     entry({"admin", "wifi_schedule", "wifi_schedule"}, call("wifi_schedule_log"), _("View Logfile"), 2)
-     entry({"admin", "wifi_schedule", "cronjob"}, call("view_crontab"), _("View Cron Jobs"), 3)
+    if not nixio.fs.access("/etc/config/wifi_schedule") then
+        return
+    end
+    entry({"admin", "services", "wifi_schedule"}, firstchild(), _("Wifi Schedule"), 60).dependent=false
+    entry({"admin", "services", "wifi_schedule", "tab_from_cbi"}, cbi("wifischedule/wifi_schedule"), _("Schedule"), 1)
+    entry({"admin", "services", "wifi_schedule", "wifi_schedule"}, call("wifi_schedule_log"), _("View Logfile"), 2)
+    entry({"admin", "services", "wifi_schedule", "cronjob"}, call("view_crontab"), _("View Cron Jobs"), 3)
 end
 
 function wifi_schedule_log()
-        local logfile = luci.sys.exec("cat /tmp/log/wifi_schedule.log")
-        luci.template.render("wifischedule/file_viewer", {title="Wifi Schedule Logfile", content=logfile})
+    local logfile = fs.readfile("/tmp/log/wifi_schedule.log") or ""
+    template.render("wifischedule/file_viewer",
+        {title = i18n.translate("Wifi Schedule Logfile"), content = logfile})
 end
 
 function view_crontab()
-        local crontab = luci.sys.exec("cat /etc/crontabs/root")
-        luci.template.render("wifischedule/file_viewer", {title="Cron Jobs", content=crontab})
+    local crontab = fs.readfile("/etc/crontabs/root") or ""
+    template.render("wifischedule/file_viewer",
+        {title = i18n.translate("Cron Jobs"), content = crontab})
 end
index 7c7f1b5..1d30121 100644 (file)
 --
 -- Author: Nils Koenig <openwrt@newk.it>
 
-function file_exists(name)
-   local f=io.open(name,"r")
-   if f~=nil then io.close(f) return true else return false end
-end
-
+local fs = require "nixio.fs"
+local sys = require "luci.sys"
 
 function time_validator(self, value, desc)
     if value ~= nil then
-        
         h_str, m_str = string.match(value, "^(%d%d?):(%d%d?)$")
         h = tonumber(h_str)
         m = tonumber(m_str)
@@ -32,16 +28,16 @@ function time_validator(self, value, desc)
              m <= 59) then
             return value
         end
-    end 
-    return nil, translate("The value '" .. desc .. "' is invalid")
+    end
+    return nil, translatef("The value %s is invalid", desc)
 end
 
 -- -------------------------------------------------------------------------------------------------
 
 -- BEGIN Map
-m = Map("wifi_schedule", translate("Wifi Schedule"), translate("Defines a schedule when to turn on and off wifi.")) 
+m = Map("wifi_schedule", translate("Wifi Schedule"), translate("Defines a schedule when to turn on and off wifi."))
 function m.on_commit(self)
-    luci.sys.exec("/usr/bin/wifi_schedule.sh cron")
+    sys.exec("/usr/bin/wifi_schedule.sh cron")
 end
 -- END Map
 
@@ -54,13 +50,13 @@ global_section.anonymous = true
 
 -- BEGIN Global Enable Checkbox
 global_enable = global_section:option(Flag, "enabled", translate("Enable Wifi Schedule"))
-global_enable.optional=false; 
-global_enable.rmempty = false;
+global_enable.optional = false
+global_enable.rmempty = false
 
 function global_enable.validate(self, value, global_section)
     if value == "1" then
-        if ( file_exists("/sbin/wifi") and
-             file_exists("/usr/bin/wifi_schedule.sh") )then
+        if ( fs.access("/sbin/wifi") and
+             fs.access("/usr/bin/wifi_schedule.sh") )then
             return value
         else
             return nil, translate("Could not find required /usr/bin/wifi_schedule.sh or /sbin/wifi")
@@ -71,39 +67,38 @@ function global_enable.validate(self, value, global_section)
 end
 -- END Global Enable Checkbox
 
-
 -- BEGIN Global Logging Checkbox
 global_logging = global_section:option(Flag, "logging", translate("Enable logging"))
-global_logging.optional=false; 
-global_logging.rmempty = false;
+global_logging.optional = false
+global_logging.rmempty = false
 global_logging.default = 0
 -- END Global Enable Checkbox
 
 -- BEGIN Global Activate WiFi Button
 enable_wifi = global_section:option(Button, "enable_wifi", translate("Activate wifi"))
 function enable_wifi.write()
-    luci.sys.exec("/usr/bin/wifi_schedule.sh start manual")
+    sys.exec("/usr/bin/wifi_schedule.sh start manual")
 end
 -- END Global Activate Wifi Button
 
 -- BEGIN Global Disable WiFi Gracefully Button
 disable_wifi_gracefully = global_section:option(Button, "disable_wifi_gracefully", translate("Disable wifi gracefully"))
 function disable_wifi_gracefully.write()
-    luci.sys.exec("/usr/bin/wifi_schedule.sh stop manual")
+    sys.exec("/usr/bin/wifi_schedule.sh stop manual")
 end
--- END Global Disable Wifi Gracefully Button 
+-- END Global Disable Wifi Gracefully Button
 
 -- BEGIN Disable WiFi Forced Button
 disable_wifi_forced = global_section:option(Button, "disable_wifi_forced", translate("Disabled wifi forced"))
 function disable_wifi_forced.write()
-    luci.sys.exec("/usr/bin/wifi_schedule.sh forcestop manual")
+    sys.exec("/usr/bin/wifi_schedule.sh forcestop manual")
 end
 -- END Global Disable WiFi Forced Button
 
 -- BEGIN Global Unload Modules Checkbox
 global_unload_modules = global_section:option(Flag, "unload_modules", translate("Unload Modules (experimental; saves more power)"))
-global_unload_modules.optional = false;
-global_unload_modules.rmempty = false;
+global_unload_modules.optional = false
+global_unload_modules.rmempty = false
 global_unload_modules.default = 0
 -- END Global Unload Modules Checkbox
 
@@ -111,13 +106,13 @@ global_unload_modules.default = 0
 -- BEGIN Modules
 modules = global_section:option(TextValue, "modules", "")
 modules:depends("unload_modules", global_unload_modules.enabled);
-modules.wrap    = "off"
-modules.rows    = 10
+modules.wrap = "off"
+modules.rows = 10
 
 function modules.cfgvalue(self, section)
-    mod=uci.get("wifi_schedule", section, "modules")
+    mod = uci.get("wifi_schedule", section, "modules")
     if mod == nil then
-        mod=""
+        mod = ""
     end
     return mod:gsub(" ", "\r\n")
 end
@@ -131,28 +126,27 @@ function modules.write(self, section, value)
 end
 -- END Modules
 
--- BEGIN Determine Modules 
+-- BEGIN Determine Modules
 determine_modules = global_section:option(Button, "determine_modules", translate("Determine Modules Automatically"))
 determine_modules:depends("unload_modules", global_unload_modules.enabled);
 function determine_modules.write(self, section)
-    output = luci.sys.exec("/usr/bin/wifi_schedule.sh getmodules")
+    output = sys.exec("/usr/bin/wifi_schedule.sh getmodules")
     modules:write(section, output)
 end
 -- END Determine Modules
 
-
 -- BEGIN Section
 d = m:section(TypedSection, "entry", translate("Schedule events"))
-d.addremove = true  
+d.addremove = true
 --d.anonymous = true
 -- END Section
 
 -- BEGIN Enable Checkbox
 c = d:option(Flag, "enabled", translate("Enable"))
-c.optional=false; c.rmempty = false;
+c.optional = false
+c.rmempty = false
 -- END Enable Checkbox
 
-
 -- BEGIN Day(s) of Week
 dow = d:option(MultiValue, "daysofweek", translate("Day(s) of Week"))
 dow.optional = false
@@ -168,8 +162,8 @@ dow:value("Sunday", translate("Sunday"))
 
 -- BEGIN Start Wifi Dropdown
 starttime =  d:option(Value, "starttime", translate("Start WiFi"))
-starttime.optional=false; 
-starttime.rmempty = false;
+starttime.optional = false
+starttime.rmempty = false
 starttime:value("00:00")
 starttime:value("01:00")
 starttime:value("02:00")
@@ -198,14 +192,12 @@ starttime:value("23:00")
 function starttime.validate(self, value, d)
     return time_validator(self, value, translate("Start Time"))
 end
-
 -- END Start Wifi Dropdown
 
-
 -- BEGIN Stop Wifi Dropdown
-stoptime =  d:option(Value, "stoptime", translate("Stop WiFi"))
-stoptime.optional=false;
-stoptime.rmempty = false;
+stoptime = d:option(Value, "stoptime", translate("Stop WiFi"))
+stoptime.optional = false
+stoptime.rmempty = false
 stoptime:value("00:00")
 stoptime:value("01:00")
 stoptime:value("02:00")
@@ -236,15 +228,14 @@ function stoptime.validate(self, value, d)
 end
 -- END Stop Wifi Dropdown
 
-
 -- BEGIN Force Wifi Stop Checkbox
 force_wifi = d:option(Flag, "forcewifidown", translate("Force disabling wifi even if stations associated"))
 force_wifi.default = false
-force_wifi.rmempty = false;
+force_wifi.rmempty = false
 
 function force_wifi.validate(self, value, d)
     if value == "0" then
-        if file_exists("/usr/bin/iwinfo") then
+        if fs.access("/usr/bin/iwinfo") then
             return value
         else
             return nil, translate("Could not find required programm /usr/bin/iwinfo")
@@ -255,5 +246,4 @@ function force_wifi.validate(self, value, d)
 end
 -- END Force Wifi Checkbox
 
-
 return m
index 2c7beba..f67a2be 100644 (file)
@@ -15,7 +15,7 @@ Author: Nils Koenig <openwrt@newk.it>
 -%>
 
 <%+header%>
-<h2 name="title"><%=translate(title)%></h2>
+<h2 name="title"><%=title%></h2>
 <div id="content_fileviewer">
 <textarea style="width: 100%" readonly="readonly" wrap="off" rows="<%=content:cmatch("\n")+1%>" id="content_id"><%=content:pcdata()%></textarea>
 </div>
index 52ec06d..3bc7864 100644 (file)
@@ -16,12 +16,14 @@ msgid "Activate wifi"
 msgstr "WiFiのアクティブ化"
 
 msgid "Could not find required /usr/bin/wifi_schedule.sh or /sbin/wifi"
-msgstr ""
-"必須の /usr/bin/wifi_schedule.sh または /sbin/wifi が見つかりませんでした。"
+msgstr "必須の /usr/bin/wifi_schedule.sh または /sbin/wifi が見つかりませんでした。"
 
 msgid "Could not find required programm /usr/bin/iwinfo"
 msgstr "必須のプログラム /usr/bin/iwinfo が見つかりませんでした。"
 
+msgid "Cron Jobs"
+msgstr "Cronジョブ"
+
 msgid "Day(s) of Week"
 msgstr "曜日"
 
@@ -82,8 +84,8 @@ msgstr "WiFiの停止"
 msgid "Sunday"
 msgstr "日曜日"
 
-msgid "The value '"
-msgstr ""
+msgid "The value %s is invalid"
+msgstr "%s の値が無効です"
 
 msgid "Thursday"
 msgstr "木曜日"
@@ -106,8 +108,5 @@ msgstr "水曜日"
 msgid "Wifi Schedule"
 msgstr "WiFi スケジュール"
 
-#~ msgid "Cron Jobs"
-#~ msgstr "Cronジョブ"
-
-#~ msgid "Wifi Schedule Logfile"
-#~ msgstr "WiFiスケジュール ログファイル"
+msgid "Wifi Schedule Logfile"
+msgstr "WiFiスケジュール ログファイル"
index 62ce9f5..639c432 100644 (file)
@@ -10,6 +10,9 @@ msgstr ""
 msgid "Could not find required programm /usr/bin/iwinfo"
 msgstr ""
 
+msgid "Cron Jobs"
+msgstr ""
+
 msgid "Day(s) of Week"
 msgstr ""
 
@@ -70,7 +73,7 @@ msgstr ""
 msgid "Sunday"
 msgstr ""
 
-msgid "The value '"
+msgid "The value %s is invalid"
 msgstr ""
 
 msgid "Thursday"
@@ -93,3 +96,6 @@ msgstr ""
 
 msgid "Wifi Schedule"
 msgstr ""
+
+msgid "Wifi Schedule Logfile"
+msgstr ""
index 858e42b..ab3a8d0 100644 (file)
@@ -10,11 +10,14 @@ msgstr "无法找到必需的 /usr/bin/wifi_schedule.sh 或 /sbin/wifi"
 msgid "Could not find required programm /usr/bin/iwinfo"
 msgstr "无法找到必需程序:/usr/bin/iwinfo"
 
+msgid "Cron Jobs"
+msgstr "计划任务"
+
 msgid "Day(s) of Week"
 msgstr "星期"
 
 msgid "Defines a schedule when to turn on and off wifi."
-msgstr "定义打开和关闭 WiFi 的时间表"
+msgstr "定义自动打开和关闭 WiFi 的计划表"
 
 msgid "Determine Modules Automatically"
 msgstr "自动确定模块"
@@ -29,7 +32,7 @@ msgid "Enable"
 msgstr "启用"
 
 msgid "Enable Wifi Schedule"
-msgstr "启用 WiFi 时间表"
+msgstr "启用 WiFi 计划"
 
 msgid "Enable logging"
 msgstr "启用日志"
@@ -50,7 +53,7 @@ msgid "Saturday"
 msgstr "星期六"
 
 msgid "Schedule"
-msgstr "时间表"
+msgstr "计划表"
 
 msgid "Schedule events"
 msgstr "计划事件"
@@ -70,8 +73,8 @@ msgstr "关闭 WiFi"
 msgid "Sunday"
 msgstr "星期日"
 
-msgid "The value '"
-msgstr ""
+msgid "The value %s is invalid"
+msgstr "%s 的值无效"
 
 msgid "Thursday"
 msgstr "星期四"
@@ -80,7 +83,7 @@ msgid "Tuesday"
 msgstr "星期二"
 
 msgid "Unload Modules (experimental; saves more power)"
-msgstr "å\8f\96æ¶\88å\8a 载模块(实验性的,节省更多电量)"
+msgstr "å\8d¸载模块(实验性的,节省更多电量)"
 
 msgid "View Cron Jobs"
 msgstr "查看计划任务"
@@ -92,10 +95,7 @@ msgid "Wednesday"
 msgstr "星期三"
 
 msgid "Wifi Schedule"
-msgstr "WiFi 时间表"
-
-#~ msgid "Cron Jobs"
-#~ msgstr "计划任务"
+msgstr "WiFi 计划"
 
-#~ msgid "Wifi Schedule Logfile"
-#~ msgstr "WiFi 时间表日志文件"
+msgid "Wifi Schedule Logfile"
+msgstr "WiFi 计划日志文件"
index 37442a3..b5f4b09 100644 (file)
@@ -11,7 +11,9 @@ LUCI_BASENAME:=ssl-openssl
 
 LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
 LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
- Note: px5g still requires libpolarssl
+ Note: px5g still requires libmbedtls (in LEDE) or libpolarssl (in Openwrt). \
+ In LEDE it is also possible to replace px5g with openssl-util as uhttpd can \
+ also generate keys with openssl commandline tools if px5g is not installed.
 LUCI_DEPENDS:=+luci +libustream-openssl +px5g
 
 include ../../luci.mk
index 8273175..106810a 100644 (file)
@@ -96,7 +96,7 @@ function iface_get_network(iface)
                        if net.l3_device == iface or net.device == iface then
                                -- cross check with uci to filter out @name style aliases
                                local uciname = cur:get("network", net.interface, "ifname")
-                               if not uciname or uciname:sub(1, 1) ~= "@" then
+                               if type(uciname) == "string" and uciname:sub(1,1) ~= "@" or uciname then
                                        return net.interface
                                end
                        end
index 06fd6b6..044339b 100644 (file)
@@ -292,9 +292,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -579,6 +576,9 @@ msgstr "Comprovació"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Suma de verificació"
 
index 5079cb9..8c850a2 100644 (file)
@@ -292,9 +292,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -578,6 +575,9 @@ msgstr "Kontrola"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Kontrolní součet"
 
index c43deb0..e44d8bb 100644 (file)
@@ -291,9 +291,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -578,6 +575,9 @@ msgstr "Prüfen"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Prüfsumme"
 
index b1ce7a3..a196f5b 100644 (file)
@@ -299,9 +299,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -587,6 +584,9 @@ msgstr "Έλεγχος"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Άθροισμα Ελέγχου"
 
index a784612..125314d 100644 (file)
@@ -290,9 +290,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -576,6 +573,9 @@ msgstr "Check"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Checksum"
 
index 3cab5bb..da786b6 100644 (file)
@@ -296,9 +296,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -583,6 +580,9 @@ msgstr "Comprobar"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Comprobación"
 
index 417d281..cce8ee2 100644 (file)
@@ -302,9 +302,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -588,6 +585,9 @@ msgstr "Vérification"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Somme de contrôle"
 
index d1c5821..0b11005 100644 (file)
@@ -289,9 +289,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -578,6 +575,9 @@ msgstr "לבדוק"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr ""
 
index 9045c59..2b85df1 100644 (file)
@@ -295,9 +295,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -583,6 +580,9 @@ msgstr "Ellenőrzés"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Ellenőrző összeg"
 
index 5c894d1..2f5350d 100644 (file)
@@ -302,9 +302,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -588,6 +585,9 @@ msgstr "Verifica"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Checksum"
 
index f6b10f1..ed72412 100644 (file)
@@ -290,9 +290,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr "常にデフォルト ルーターとして通知する"
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -581,6 +578,9 @@ msgstr "チェック"
 msgid "Check fileystems before mount"
 msgstr "マウント前にファイルシステムをチェックする"
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "チェックサム"
 
index 06a45df..9a1a815 100644 (file)
@@ -284,9 +284,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -572,6 +569,9 @@ msgstr ""
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr ""
 
index 05c44b8..8ba922f 100644 (file)
@@ -279,9 +279,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -562,6 +559,9 @@ msgstr ""
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Jumlah disemak "
 
index 37f7281..f9dad0a 100644 (file)
@@ -288,9 +288,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -574,6 +571,9 @@ msgstr "Kontroller"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Kontrollsum"
 
index 1e4c9bc..a78584c 100644 (file)
@@ -303,9 +303,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -592,6 +589,9 @@ msgstr "Sprawdź"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Suma kontrolna"
 
index 66a6600..0bcd639 100644 (file)
@@ -303,9 +303,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -589,6 +586,9 @@ msgstr "Verificar"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Soma de verificação"
 
index 5b63bbf..d8790dc 100644 (file)
@@ -301,9 +301,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -587,6 +584,9 @@ msgstr "Verificar"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Checksum"
 
index 90a643a..4135c79 100644 (file)
@@ -287,9 +287,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -570,6 +567,9 @@ msgstr "Verificare"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Suma de verificare"
 
index 43b1933..e704588 100644 (file)
@@ -300,9 +300,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -587,6 +584,9 @@ msgstr "Проверить"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Контрольная сумма"
 
index b39addb..f824029 100644 (file)
@@ -273,9 +273,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -556,6 +553,9 @@ msgstr ""
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr ""
 
index 737809b..4e22808 100644 (file)
@@ -279,9 +279,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -562,6 +559,9 @@ msgstr ""
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr ""
 
index 536425a..5a77cd2 100644 (file)
@@ -266,9 +266,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -549,6 +546,9 @@ msgstr ""
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr ""
 
index 4d4226e..7f0ea7e 100644 (file)
@@ -286,9 +286,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -569,6 +566,9 @@ msgstr ""
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr ""
 
index 0449e40..29b1514 100644 (file)
@@ -310,9 +310,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -596,6 +593,9 @@ msgstr "Перевірити"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Контрольна сума"
 
index cf9cbf4..0cc83bf 100644 (file)
@@ -280,9 +280,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -563,6 +560,9 @@ msgstr ""
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "Checksum"
 
index 2747da5..7c00f8f 100644 (file)
@@ -284,9 +284,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr "总是广播默认路由"
 
-msgid "An additional network will be created if you leave this checked."
-msgstr "如果选中此复选框,则会创建一个附加网络。"
-
 msgid "Annex"
 msgstr "Annex"
 
@@ -569,6 +566,9 @@ msgstr "检查"
 msgid "Check fileystems before mount"
 msgstr "在挂载前检查文件系统"
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "校验值"
 
@@ -3690,6 +3690,9 @@ msgstr "是"
 msgid "« Back"
 msgstr "« 后退"
 
+#~ msgid "An additional network will be created if you leave this checked."
+#~ msgstr "如果选中此复选框,则会创建一个附加网络。"
+
 #~ msgid "An additional network will be created if you leave this unchecked."
 #~ msgstr "取消选中将会另外创建一个新网络,而不会覆盖当前网络设置"
 
index 6c26078..15ffafc 100644 (file)
@@ -283,9 +283,6 @@ msgstr ""
 msgid "Always announce default router"
 msgstr ""
 
-msgid "An additional network will be created if you leave this checked."
-msgstr ""
-
 msgid "Annex"
 msgstr ""
 
@@ -568,6 +565,9 @@ msgstr "檢查"
 msgid "Check fileystems before mount"
 msgstr ""
 
+msgid "Check this option to delete the existing networks from this radio."
+msgstr ""
+
 msgid "Checksum"
 msgstr "效驗碼"
 
index 05b27a9..7dd094d 100644 (file)
@@ -44,7 +44,7 @@ m.hidden = {
 
 if iw and iw.mbssid_support then
        replace = m:field(Flag, "replace", translate("Replace wireless configuration"),
-               translate("An additional network will be created if you leave this checked."))
+               translate("Check this option to delete the existing networks from this radio."))
 
        function replace.cfgvalue() return "0" end
 else