* luci/contrib: let operate axhttpd in nph mode
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 13 Nov 2008 15:18:32 +0000 (15:18 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 13 Nov 2008 15:18:32 +0000 (15:18 +0000)
contrib/axtls/Makefile
contrib/axtls/patches/004-cgi-nph-mode.patch [new file with mode: 0644]

index 459a15c..b6ede0c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=axtls
 PKG_VERSION:=1.2.0
 
 PKG_NAME:=axtls
 PKG_VERSION:=1.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR=$(BUILD_DIR)/axTLS
 PKG_SOURCE:=axTLS-$(PKG_VERSION).tar.gz
 
 PKG_BUILD_DIR=$(BUILD_DIR)/axTLS
 PKG_SOURCE:=axTLS-$(PKG_VERSION).tar.gz
diff --git a/contrib/axtls/patches/004-cgi-nph-mode.patch b/contrib/axtls/patches/004-cgi-nph-mode.patch
new file mode 100644 (file)
index 0000000..2b6cc5c
--- /dev/null
@@ -0,0 +1,20 @@
+--- axTLS/httpd/proc.c 2008-11-13 14:05:02.000000000 +0100
++++ axTLS.new/httpd/proc.c     2008-11-13 16:07:12.000000000 +0100
+@@ -556,13 +556,13 @@
+     int tmp_stdout;
+ #endif
+-    snprintf(cgienv[0], MAXREQUESTLENGTH, 
++    if (cn->reqtype == TYPE_HEAD) 
++    {
++        snprintf(cgienv[0], MAXREQUESTLENGTH, 
+             HTTP_VERSION" 200 OK\nServer: %s\n%s",
+             server_version, (cn->reqtype == TYPE_HEAD) ? "\n" : "");
+-    special_write(cn, cgienv[0], strlen(cgienv[0]));
++        special_write(cn, cgienv[0], strlen(cgienv[0]));
+-    if (cn->reqtype == TYPE_HEAD) 
+-    {
+         removeconnection(cn);
+         return;
+     }