fix symlink creation
authorSteven Barth <steven@midlink.org>
Mon, 2 Jun 2008 15:34:59 +0000 (15:34 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 2 Jun 2008 15:34:59 +0000 (15:34 +0000)
Makefile

index ec0d76a..0e09682 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,8 @@ luahost: luabuild hostcopy
 hostcopy: 
        mkdir -p host
        for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
 hostcopy: 
        mkdir -p host
        for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
-       ln -sf .$(LUCI_INSTALLDIR) host/luci
+       rm -f host/luci
+       ln -s .$(LUCI_INSTALLDIR) host/luci
 
 run: host
        ./host/usr/bin/boa -c ./host/etc/boa -d
 
 run: host
        ./host/usr/bin/boa -c ./host/etc/boa -d