luci-0.9: merge r4957-r4959
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 1 Jul 2009 02:09:47 +0000 (02:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 1 Jul 2009 02:09:47 +0000 (02:09 +0000)
contrib/package/sysupgrade-atheros/Makefile
contrib/package/sysupgrade-atheros/files/lib/upgrade/platform.sh
modules/freifunk/root/usr/sbin/remote-update

index a101455..e4414b1 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sysupgrade-atheros
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -17,8 +17,8 @@ define Package/sysupgrade-atheros
   SECTION:=luci
   CATEGORY:=LuCI
   SUBMENU:=Freifunk
-  TITLE:=Experimental sysupgrade support for Atheros SoC
-  DEPENDS:=@TARGET_atheros
+  TITLE:=Experimental sysupgrade support for Atheros SoC and AR71xx target (UBNT RS)
+  DEPENDS:=@TARGET_atheros||@TARGET_ar71xx
 endef
 
 define Package/sysupgrade-atheros/description
index 2a8c31d..ac7e62e 100644 (file)
@@ -15,7 +15,7 @@ platform_check_image() {
                        fi
                ;;
                *)
-                       echo "Invalid image. Use Freifunk .img files on this platform"
+                       echo "Invalid image. Use combined .img files on this platform"
                        return 1
                ;;
        esac
index 67751d6..b900ada 100755 (executable)
@@ -22,6 +22,11 @@ find_image()
                                echo "openwrt-ubiquity-combined.img"
                        fi
                ;;
+               ar71xx)
+                       if grep -q '"kernel"' /proc/mtd; then
+                               echo "openwrt-ar71xx-combined.img"
+                       fi
+               ;;
                brcm-2.4)
                        echo "openwrt-brcm-2.4-squashfs.trx"
                ;;