Bump UCI version
authorSteven Barth <steven@midlink.org>
Sun, 2 Nov 2008 13:43:17 +0000 (13:43 +0000)
committerSteven Barth <steven@midlink.org>
Sun, 2 Nov 2008 13:43:17 +0000 (13:43 +0000)
contrib/uci/Makefile
libs/uci/luasrc/model/uci.lua

index 31551af..8e35420 100644 (file)
@@ -1,16 +1,16 @@
 include ../../build/config.mk
 include ../../build/gccconfig.mk
 
-UCI_VERSION  = 0.6.1
-UCI_SITE    = http://mirror2.openwrt.org/sources
-UCI_DIR     = uci-$(UCI_VERSION)
-UCI_FILE    = $(UCI_DIR).tar.gz
-UCI_URL     = $(UCI_SITE)/$(UCI_FILE)
-#UCI_GITREV   = 43124956bc9c1083e476f6cadaedf27b7788d004
-#UCI_SITE     = http://nbd.name
-#UCI_DIR      = uci.git
-#UCI_FILE     = uci-$(UCI_VERSION)$(UCI_APPEND).tar.gz
-#UCI_URL      = $(UCI_SITE)/gitweb.cgi?p=uci.git;a=snapshot;h=$(UCI_GITREV)
+UCI_VERSION  = 0.6.3
+#UCI_SITE    = http://mirror2.openwrt.org/sources
+#UCI_DIR     = uci-$(UCI_VERSION)
+#UCI_FILE    = $(UCI_DIR).tar.gz
+#UCI_URL     = $(UCI_SITE)/$(UCI_FILE)
+UCI_GITREV   = c79cc497e7b0caa0f9f6a2c978fa9a5f0f097463
+UCI_SITE     = http://nbd.name
+UCI_DIR      = uci.git
+UCI_FILE     = uci-$(UCI_VERSION)$(UCI_APPEND).tar.gz
+UCI_URL      = $(UCI_SITE)/gitweb.cgi?p=uci.git;a=snapshot;h=$(UCI_GITREV)
 UCI_PATCHDIR = patches
 
 all: compile
index 587cd63..ecb8f47 100644 (file)
@@ -164,25 +164,6 @@ function Cursor.set_list(self, config, section, option, value)
        return false
 end
 
-
-Cursor._changes = Cursor.changes
-function Cursor.changes(self, config)
-       if config then
-               return Cursor._changes(self, config)
-       else
-               local changes = Cursor._changes(self)
-               util.copcall(function()
-                       for k,v in pairs(require "luci.fs".dir(self:get_savedir())) do
-                               if v ~= "." and v ~= ".." then
-                                       util.update(changes, Cursor._changes(self, v))
-                               end
-                       end
-               end)
-               return changes
-       end
-end
-
-
 -- Return a list of initscripts affected by configuration changes.
 function Cursor._affected(self, configlist)
        configlist = type(configlist) == "table" and configlist or {configlist}