Added UVC-Streamer application
authorSteven Barth <steven@midlink.org>
Mon, 1 Sep 2008 21:56:30 +0000 (21:56 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 1 Sep 2008 21:56:30 +0000 (21:56 +0000)
Contributed by Yanira
Thanks a lot

applications/luci-uvc_streamer/Makefile [new file with mode: 0644]
applications/luci-uvc_streamer/ipkg/postinst [new file with mode: 0755]
applications/luci-uvc_streamer/luasrc/controller/uvc_streamer.lua [new file with mode: 0644]
applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.de.lua [new file with mode: 0644]
applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.de.xml [new file with mode: 0644]
applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.en.lua [new file with mode: 0644]
applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.en.xml [new file with mode: 0644]
applications/luci-uvc_streamer/luasrc/model/cbi/uvc_streamer.lua [new file with mode: 0644]
applications/luci-uvc_streamer/root/etc/uci-defaults/luci-uvc_streamer [new file with mode: 0644]
contrib/package/luci/Makefile

diff --git a/applications/luci-uvc_streamer/Makefile b/applications/luci-uvc_streamer/Makefile
new file mode 100644 (file)
index 0000000..81a96f6
--- /dev/null
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk
\ No newline at end of file
diff --git a/applications/luci-uvc_streamer/ipkg/postinst b/applications/luci-uvc_streamer/ipkg/postinst
new file mode 100755 (executable)
index 0000000..492bc85
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+        ( . /etc/uci-defaults/luci-uvc_streamer ) && rm -f /etc/uci-defaults/luci-uvc_streamer
+}
diff --git a/applications/luci-uvc_streamer/luasrc/controller/uvc_streamer.lua b/applications/luci-uvc_streamer/luasrc/controller/uvc_streamer.lua
new file mode 100644 (file)
index 0000000..a1f2296
--- /dev/null
@@ -0,0 +1,13 @@
+module("luci.controller.uvc_streamer", package.seeall)
+
+function index()
+       require("luci.i18n")
+       luci.i18n.loadc("uvc_streamer")
+       if not luci.fs.isfile("/etc/config/uvc-streamer") then
+               return
+       end
+
+       local page = entry({"admin", "services", "uvc_streamer"}, cbi("uvc_streamer"), luci.i18n.translate("uvc_streamer", "UVC Streaming"), 60)
+       page.i18n = "uvc_streamer"
+       page.dependent = true
+end
diff --git a/applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.de.lua b/applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.de.lua
new file mode 100644 (file)
index 0000000..cd7cb43
--- /dev/null
@@ -0,0 +1,4 @@
+uvc_streamer = [[Webcam Stream]]
+settings = [[Konfiguration]]
+resolution = [[Auflösung]]
+framespersecond = [[Bilder pro Sekunde]]
diff --git a/applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.de.xml b/applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.de.xml
new file mode 100644 (file)
index 0000000..9115096
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="utf-8"?>
+
+<i18n:msgs xmlns:i18n="http://luci.freifunk-halle.net/2008/i18n#" xmlns="http://www.w3.org/1999/xhtml">
+
+<i18n:msg xml:id="framespersecond">Bilder pro Sekunde</i18n:msg>
+<i18n:msg xml:id="resolution">Auflösung</i18n:msg>
+<i18n:msg xml:id="settings">Konfiguration</i18n:msg>
+<i18n:msg xml:id="uvc_streamer">Webcam Stream</i18n:msg>
+
+</i18n:msgs>
diff --git a/applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.en.lua b/applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.en.lua
new file mode 100644 (file)
index 0000000..46c9331
--- /dev/null
@@ -0,0 +1,4 @@
+uvc_streamer = [[Webcam streaming]]
+settings = [[Settings]]
+resolution = [[Resolution]]
+framespersecond = [[Frames per second]]
diff --git a/applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.en.xml b/applications/luci-uvc_streamer/luasrc/i18n/uvc_streamer.en.xml
new file mode 100644 (file)
index 0000000..8fe6480
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="utf-8"?>
+
+<i18n:msgs xmlns:i18n="http://luci.freifunk-halle.net/2008/i18n#" xmlns="http://www.w3.org/1999/xhtml">
+
+<i18n:msg xml:id="framespersecond">Frames per second</i18n:msg>
+<i18n:msg xml:id="resolution">Resolution</i18n:msg>
+<i18n:msg xml:id="settings">Settings</i18n:msg>
+<i18n:msg xml:id="uvc_streamer">Webcam streaming</i18n:msg>
+
+</i18n:msgs>
diff --git a/applications/luci-uvc_streamer/luasrc/model/cbi/uvc_streamer.lua b/applications/luci-uvc_streamer/luasrc/model/cbi/uvc_streamer.lua
new file mode 100644 (file)
index 0000000..69a6525
--- /dev/null
@@ -0,0 +1,20 @@
+m = Map("uvc-streamer", translate("uvc_streamer"))
+
+s = m:section(TypedSection, "uvc-streamer", translate("settings"))
+s.addremove = false
+s.anonymous = true
+
+s:option(Flag, "enabled", translate("enabled", "Enable"))
+
+s:option(Value, "device", translate("device")).rmempty = true
+
+nm = s:option(Value, "resolution", translate("resolution"))
+nm:value("640x480")
+nm:value("320x240")
+nm:value("160x120")
+
+s:option(Value, "framespersecond", translate("framespersecond")).rmempty = true
+
+s:option(Value, "port", translate("port", "Port")).rmempty = true
+
+return m
diff --git a/applications/luci-uvc_streamer/root/etc/uci-defaults/luci-uvc_streamer b/applications/luci-uvc_streamer/root/etc/uci-defaults/luci-uvc_streamer
new file mode 100644 (file)
index 0000000..6ecea2c
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+uci set luci.uci_oncommit.uvc_streamer='/sbin/luci-reload uvc-streamer'
+uci commit luci
index ba29946..f095d5a 100644 (file)
@@ -510,6 +510,18 @@ define Package/luci-app-samba/install
 endef
 
 
+define Package/luci-app-uvc_streamer
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +uvc-streamer
+  TITLE:=Webcam Streaming - UVC-Streamer module
+endef
+
+define Package/luci-app-uvc_streamer/install
+        $(call Package/luci/install/template,$(1),applications/luci-uvc_streamer)
+endef
+
+
+
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
@@ -710,6 +722,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-samba),)
        PKG_SELECTED_MODULES+=applications/luci-samba
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
+       PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -790,6 +805,7 @@ $(eval $(call BuildPackage,luci-app-upnp))
 $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
+$(eval $(call BuildPackage,luci-app-uvc_streamer))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))