contrib/package: make sgi-uhttpd and uhttpd tls support optional
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 27 Mar 2010 19:28:08 +0000 (19:28 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 27 Mar 2010 19:28:08 +0000 (19:28 +0000)
contrib/package/luci/Makefile

index 7666d04..6229646 100644 (file)
@@ -347,7 +347,7 @@ endef
 define Package/luci-web
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-http +luci-sys +luci-nixio +luci-uci \
-       +luci-sgi-cgi +luci-sgi-uhttpd +luci-lmo
+       +luci-sgi-cgi +luci-lmo
   TITLE:=MVC Webframework
   $(call Config,luci.main.lang,string,auto,Default Language)
 endef
@@ -782,7 +782,7 @@ endef
 define Package/luci-sgi-uhttpd
   $(call Package/luci/webservertemplate)
   TITLE:=Binding for the uHTTPd server
-  DEPENDS+=+uhttpd +uhttpd-mod-tls +uhttpd-mod-lua +px5g
+  DEPENDS+=+uhttpd +uhttpd-mod-lua
 endef
 
 define Package/luci-sgi-uhttpd/install