* luci/applications: add ushare package
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 24 Sep 2008 12:46:07 +0000 (12:46 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 24 Sep 2008 12:46:07 +0000 (12:46 +0000)
applications/luci-ushare/Makefile [new file with mode: 0644]
applications/luci-ushare/ipkg/postinst [new file with mode: 0644]
applications/luci-ushare/luasrc/controller/ushare.lua [new file with mode: 0644]
applications/luci-ushare/luasrc/i18n/ushare.en.lua [new file with mode: 0644]
applications/luci-ushare/luasrc/model/cbi/ushare.lua [new file with mode: 0644]
applications/luci-ushare/root/etc/uci-defaults/luci-ushare [new file with mode: 0644]
contrib/package/luci/Makefile

diff --git a/applications/luci-ushare/Makefile b/applications/luci-ushare/Makefile
new file mode 100644 (file)
index 0000000..f7fac77
--- /dev/null
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-ushare/ipkg/postinst b/applications/luci-ushare/ipkg/postinst
new file mode 100644 (file)
index 0000000..f392489
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/luci-ushare ) && rm -f /etc/uci-defaults/luci-ushare
+}
diff --git a/applications/luci-ushare/luasrc/controller/ushare.lua b/applications/luci-ushare/luasrc/controller/ushare.lua
new file mode 100644 (file)
index 0000000..2fdea4e
--- /dev/null
@@ -0,0 +1,28 @@
+--[[
+
+LuCI uShare
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+        http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+module("luci.controller.ushare", package.seeall)
+
+function index()
+       require("luci.i18n")
+       luci.i18n.loadc("ushare")
+       if not luci.fs.isfile("/etc/config/ushare") then
+               return
+       end
+
+       local page = entry({"admin", "services", "ushare"}, cbi("ushare"), luci.i18n.translate("ushare", "uShare"), 60)
+       page.i18n = "uvc_streamer"
+       page.dependent = true
+end
diff --git a/applications/luci-ushare/luasrc/i18n/ushare.en.lua b/applications/luci-ushare/luasrc/i18n/ushare.en.lua
new file mode 100644 (file)
index 0000000..2da960f
--- /dev/null
@@ -0,0 +1,3 @@
+settings = 'Settings'
+ushare = 'uShare'
+ushare_desc = 'uShare'
diff --git a/applications/luci-ushare/luasrc/model/cbi/ushare.lua b/applications/luci-ushare/luasrc/model/cbi/ushare.lua
new file mode 100644 (file)
index 0000000..254ea23
--- /dev/null
@@ -0,0 +1,38 @@
+--[[
+
+LuCI uShare
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+        http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+m = Map("ushare", translate("ushare"),
+       translatef("ushare_desc"))
+
+s = m:section(TypedSection, "ushare", translate("settings"))
+s.addremove = false
+s.anonymous = true
+
+s:option(Flag, "enabled", translate("enabled", "Enable"))
+
+s:option(Value, "username", translate("username"))
+
+s:option(Value, "servername", translate("servername"))
+
+dif = s:option( Value, "interface", translate("interface")) 
+for _, nif in ipairs(luci.sys.net.devices()) do                         
+        if nif ~= "lo" then dif:value(nif) end                          
+end 
+
+s:option(Value, "content_directories", translate("content_directories"))
+
+s:option(Value, "options", translate("options"))
+
+return m
diff --git a/applications/luci-ushare/root/etc/uci-defaults/luci-ushare b/applications/luci-ushare/root/etc/uci-defaults/luci-ushare
new file mode 100644 (file)
index 0000000..262420e
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+uci batch <<-EOF
+       add ucitrack ushare
+       set ucitrack.@ushare[-1].init=ushare
+       commit ucitrack
+EOF
index c94c323..08bb2c4 100644 (file)
@@ -474,6 +474,17 @@ define Package/luci-app-p910nd/install
 endef
 
 
+define Package/luci-app-ushare
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +ushare
+  TITLE:=ushare - UPnP A/V & DLNA Media Server
+endef
+
+define Package/luci-app-ushare/install
+        $(call Package/luci/install/template,$(1),applications/luci-ushare)
+endef
+
+
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
@@ -668,6 +679,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
         PKG_SELECTED_MODULES+=applications/luci-p910nd
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-ushare),)
+        PKG_SELECTED_MODULES+=applications/luci-ushare
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -746,6 +760,7 @@ $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
 $(eval $(call BuildPackage,luci-app-uvc_streamer))
 $(eval $(call BuildPackage,luci-app-p910nd))
+$(eval $(call BuildPackage,luci-app-ushare))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-luci))