Merge pull request #613 from tsl0922/tsl0922-patch-1
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 15 Jan 2016 14:17:42 +0000 (15:17 +0100)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 15 Jan 2016 14:17:42 +0000 (15:17 +0100)
luci-theme-material: set default font-size to 13px

12 files changed:
applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/controller/ddns.lua [changed mode: 0644->0755]
applications/luci-app-ddns/luasrc/tools/ddns.lua [changed mode: 0644->0755]
applications/luci-app-privoxy/Makefile
applications/luci-app-radicale/Makefile
contrib/package/community-profiles/files/etc/config/profile_cottbus
contrib/package/community-profiles/files/etc/config/profile_halle
contrib/package/freifunk-policyrouting/files/etc/init.d/freifunk-policyrouting
modules/luci-base/luasrc/dispatcher.lua
modules/luci-base/root/usr/share/acl.d/luci-base.json [new file with mode: 0644]
modules/luci-mod-admin-full/luasrc/model/cbi/admin_network/wifi.lua
protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_dslite.lua

index 0e1e5df..1e38c25 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.2.4
+PKG_VERSION:=2.3.1
 
 # Release == build
 # increase on changes of translation files
@@ -33,6 +33,6 @@ help
        $(PKG_MAINTAINER)
 endef
 
-include $(TOPDIR)/feeds/luci/luci.mk
+include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
old mode 100644 (file)
new mode 100755 (executable)
index 29598ea..abaf1c7
@@ -22,7 +22,7 @@ local srv_ver_min = "2.5.0"                   -- minimum version of service required
 local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
 local app_name    = "luci-app-ddns"
 local app_title   = "Dynamic DNS"
-local app_version = "2.3.0-1"
+local app_version = "2.3.1-1"
 
 function index()
        local nxfs      = require "nixio.fs"            -- global definitions not available
old mode 100644 (file)
new mode 100755 (executable)
index ecc4131..02331f4
@@ -166,8 +166,6 @@ function value_parse(self, section, novld)
                        return          -- so data is missing
                end
        end
-       -- for whatever reason errtxt set and not handled above
-       assert( not (errtxt and (#errtxt > 0)), "unhandled validate error" )
 
        -- lets continue with value returned from validate
        eq_cfg  = ( vvalue == cvalue )                  -- update equal_config flag
index 260f840..45d72d4 100644 (file)
@@ -33,6 +33,6 @@ help
        $(PKG_MAINTAINER)
 endef
 
-include $(TOPDIR)/feeds/luci/luci.mk
+include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 1501d4f..c403ba5 100644 (file)
@@ -36,6 +36,6 @@ help
        $(PKG_MAINTAINER)
 endef
 
-include $(TOPDIR)/feeds/luci/luci.mk
+include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 143c505..6f395a1 100644 (file)
@@ -7,11 +7,11 @@ config 'community' 'profile'
        option 'splash_network' '10.104.0.0/16'
        option 'splash_prefix' '27'
        option 'latitude' '51.757689'
-       option 'longitude' '13.40948'   
+       option 'longitude' '13.40948'
+
 config 'defaults' 'wifi_device'
        option 'channel' '13'
+
 config 'defaults' 'wifi_device_5'
        option 'channel' '36'
 
@@ -24,14 +24,14 @@ config 'defaults' 'wifi_iface_5'
 config 'defaults' 'bssidscheme'
        option '13'     'D2:CA:FF:EE:BA:BE'
        option '36'     '02:36:CA:FF:EE:EE'
+
 config 'defaults' 'ssidscheme'
        option '13'     'intern-ch13.cottbus.freifunk.net'
        option '36'     'intern-ch36.cottbus.freifunk.net'
+
 config 'defaults' 'interface'
        option 'netmask' '255.255.255.255'
        option 'dns' '85.214.20.141 213.73.91.35 194.150.168.168 2001:4ce8::53 2001:910:800::12'
+
 config 'dhcp' 'dhcp'
        option 'leasetime' '5m'
index 0e8e43f..30d0e8f 100644 (file)
@@ -1,12 +1,16 @@
 config 'community' 'profile'
        option 'name' 'Freifunk Halle'
-       option 'homepage' 'http://freifunk-halle.net'
+       option 'homepage' 'http://freifunk-halle.org'
        option 'ssid' 'halle.freifunk.net'
-       option 'mesh_network' '104.62.0.0/16'
-       option 'splash_network' '10.104.0.0/16'
+       option 'mesh_network' '10.62.0.0/16'
+       option 'splash_network' '6.0.0.0/8'
        option 'splash_prefix' '27'
        option 'latitude' '51.47911'
        option 'longitude' '11.96901'
+       option 'adhoc_dhcp_when_vap' '0'
+       option 'suffix' 'ffhal'
+       option 'vap' '1'
+       option 'batman' '1'
 
 config 'defaults' 'wifi_device'
        option 'channel' '13'
@@ -15,8 +19,17 @@ config 'defaults' 'wifi_device'
 config 'defaults' 'bssidscheme'
        option 'all' '02:CA:FF:EE:BA:BE'
 
+config 'defaults' 'luci_splash'
+       option 'redirect_url' 'http://freifunk-halle.org/willkommen.php'
+
 config 'defaults' 'interface'
-       option 'netmask' '255.0.0.0'
+       option 'netmask' '255.255.255.255'
+
+config 'defaults' 'wifi_iface'
+       option 'mcast_rate' '6000'
+
+config 'defaults' 'dhcp'
+       option 'leasetime' '5m'
 
 config 'defaults' 'olsrd'
        option 'AllowNoInt' 'yes'
@@ -38,3 +51,21 @@ config 'defaults' 'olsr_interface'
        option 'MidValidityTime'  '375.0'
        option 'HnaInterval' '25.0'
        option 'HnaValidityTime' '375.0'
+
+config widget 'rsshalle'
+       option cache '3600'
+       option width '50%'
+       option title 'neuste Foreneinträge in Halle'
+       option template 'rssfeed'
+       option enabled '1'
+       option max '5'
+       option url 'http://www.freifunk-halle.org/rss.php'
+
+config widget 'rssbundesweit'
+       option cache '3600'
+       option width '50%'
+       option title 'bundesweiter Freifunk Blog'
+       option template 'rssfeed'
+       option enabled '1'
+       option max '10'
+       option url 'http://blog.freifunk.net/rss.xml'
index 05a7540..4c91724 100755 (executable)
@@ -51,22 +51,33 @@ rt_tables() {
 
 }
 
-disable_dyngw() {
-       for cfg in $cfgs; do
-               local dyngwlib=`uci show $cfg |grep dyn_gw.so |awk {' FS="."; print $1"."$2 '}`
-               if [ -n "$dyngwlib" ]; then
-                       uci set $dyngwlib.ignore=1
-                       uci commit $cfg
-               fi
-
-               dyngwplainlib=`uci show $cfg |grep dyn_gw_plain |awk {' FS="."; print $1"."$2 '}`
-               if [ -n "$dyngwplainlib" ]; then
-                       rttable="$(uci -q get $dyngwplainlib.RtTable)"
-                       if [ -z "$rttable" ] || [ "$rttable" = "254" ]; then 
-                               uci set $dyngwplainlib.ignore=1
-                               uci commit $cfg
+handle_disable_dyngw() {
+       local cfg="$1"
+       local olsrd_cfg="$2"
+       config_get library "$cfg" library
+       case "$library" in
+               olsrd_dyn_gw_plain*)
+                       config_get RtTable "$cfg" RtTable
+                       if [ -z "$RtTable" ] || [ "$RtTable" = "254" ]; then
+                               config_set "$cfg" ignore '1'
+                               uci set $olsrd_cfg.$cfg.ignore="1"
+                               uci commit $olsrd_cfg
+                               logger -s -t policyrouting -p info "dyngw_plain plugin disabled."
                        fi
-               fi
+               ;;
+               olsrd_dyn_gw.so*)
+                       logger -s -t policyrouting -p info "$cfg"
+                       uci set $olsrd_cfg.$cfg.ignore="1"
+                               uci commit $olsrd_cfg
+                       logger -s -t policyrouting -p info "dyngw plugin disabled."
+               ;;
+       esac
+}
+
+disable_dyngw() {
+       for olsrd_cfg in $cfgs; do
+               config_load $olsrd_cfg
+               config_foreach handle_disable_dyngw LoadPlugin $olsrd_cfg
        done
 }
 
index cd5d77a..2fbc2c9 100644 (file)
@@ -402,9 +402,6 @@ function dispatch(request)
        end
 
        if track.setuser then
-               -- trigger ubus connection before dropping root privs
-               util.ubus()
-
                sys.process.setuser(track.setuser)
        end
 
diff --git a/modules/luci-base/root/usr/share/acl.d/luci-base.json b/modules/luci-base/root/usr/share/acl.d/luci-base.json
new file mode 100644 (file)
index 0000000..4d58236
--- /dev/null
@@ -0,0 +1,8 @@
+{
+       "user": "nobody",
+       "access": {
+               "system": {
+                       "methods": [ "board", "info" ]
+               }
+       }
+}
index 4452892..20edd68 100644 (file)
@@ -160,7 +160,7 @@ if found_sta then
                found_sta.channel, table.concat(found_sta.names, ", "))
 else
        ch = s:taboption("general", Value, "_mode_freq", '<br />'..translate("Operating frequency"))
-       ch.hwmodes = iw.hwmodelist
+       ch.hwmodes = hw_modes
        ch.freqlist = iw.freqlist
        ch.template = "cbi/wireless_modefreq"
 
@@ -174,7 +174,7 @@ else
 
        function ch.formvalue(self, section)
                return {
-                       m:formvalue(self:cbid(section) .. ".band") or (iw.hwmodelist.g and "11g" or "11a"),
+                       m:formvalue(self:cbid(section) .. ".band") or (hw_modes.g and "11g" or "11a"),
                        m:formvalue(self:cbid(section) .. ".channel") or "auto",
                        m:formvalue(self:cbid(section) .. ".htmode") or ""
                }
index 9069ff0..eca9750 100644 (file)
@@ -14,7 +14,7 @@ peeraddr = section:taboption("general", Value, "peeraddr",
        translate("DS-Lite AFTR address"))
 
 peeraddr.rmempty  = false
-peeraddr.datatype = "ip6addr"
+peeraddr.datatype = "or(hostname,ip6addr)"
 
 ip6addr = section:taboption("general", Value, "ip6addr",
        translate("Local IPv6 address"),