* luci/statistics: add postinstall for package, fix permissions of luci-ff-hannover...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Jun 2008 22:23:57 +0000 (22:23 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Jun 2008 22:23:57 +0000 (22:23 +0000)
contrib/package/luci/Makefile
contrib/package/luci/ipkg/luci-ff-hannover.postinst [changed mode: 0644->0755]
contrib/package/luci/ipkg/luci-statistics.postint [new file with mode: 0755]

index f941715..b438760 100644 (file)
@@ -317,6 +317,7 @@ define Package/luci-app-statistics/install
        $(call Package/luci/install/template,$(1),applications/luci-statistics)
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/usr/bin/stat-genconfig $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/etc/init.d/luci_statistics $(1)/etc/init.d
+       $(CP) -a ./ipkg/luci-statistics.postinst $(1)/CONTROL/postinst
 endef
 
 
diff --git a/contrib/package/luci/ipkg/luci-statistics.postint b/contrib/package/luci/ipkg/luci-statistics.postint
new file mode 100755 (executable)
index 0000000..69fe0c0
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/luci-statistics ) && rm -f /etc/uci-defaults/luci-statistics
+}