include: don't use extended regex for deps checking
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 31 Jan 2015 08:15:46 +0000 (08:15 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 31 Jan 2015 08:15:46 +0000 (08:15 +0000)
Closes: #18851

Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44224 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-ipkg.mk

index 815aef0..11edb9a 100644 (file)
@@ -66,7 +66,7 @@ ifneq ($(PKG_NAME),toolchain)
                                XARGS="$(XARGS)"; \
                        $(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
                ) | while read FILE; do \
-                       grep -qE "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
+                       grep -q "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
                                echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
                done; \
                if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \