[package] e2fsprogs: fix status reaping with fsck piped to logger, based on patch...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Apr 2012 15:18:17 +0000 (15:18 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Apr 2012 15:18:17 +0000 (15:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31377 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/e2fsprogs/Makefile
package/e2fsprogs/files/e2fsck.sh

index 9e0e9d9..79ab92c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=e2fsprogs
 PKG_VERSION:=1.42
 PKG_MD5SUM:=a3c4ffd7352310ab5e9412965d575610
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
index 3b34239..22031ed 100644 (file)
@@ -1,12 +1,15 @@
 #!/bin/sh
 # Copyright 2010 Vertical Communications
+# Copyright 2012 OpenWrt.org
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 fsck_e2fsck() {
+       set -o pipefail
        e2fsck -p "$device" 2>&1 | logger -t "fstab: e2fsck ($device)"
        local status="$?"
+       set +o pipefail
        case "$status" in
                0|1) ;; #success
                2) reboot;;