workaround a bootloader bug on the WBD111
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 May 2009 10:59:59 +0000 (10:59 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 May 2009 10:59:59 +0000 (10:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15818 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/gemini/image/Makefile

index 6fb7750..fc69ffc 100644 (file)
@@ -14,7 +14,9 @@ define Image/Prepare
 endef
 
 define Image/BuildKernel
-       cp $(KDIR)/openwrt-$(BOARD)-wbd111-zImage $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
+# workaround the bootloader's bug with extra nops
+       echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
+       cat $(KDIR)/openwrt-$(BOARD)-wbd111-zImage >> $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
 endef
 
 define Image/Build/jffs2-64k