build: override hardcoded paths to bison and m4 to make the SDK more relocatable
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Aug 2014 12:15:50 +0000 (12:15 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Aug 2014 12:15:50 +0000 (12:15 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42300 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index a84636a..c9efb9e 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -269,6 +269,9 @@ ifeq ($(CONFIG_BUILD_LOG),y)
   BUILD_LOG:=1
 endif
 
+export BISON_PKGDATADIR:=$(STAGING_DIR_HOST)/share/bison
+export M4:=$(STAGING_DIR_HOST)/bin/m4
+
 define shvar
 V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
 endef