modules: fixes ko files that were renamed in 3.1
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Nov 2011 15:16:50 +0000 (15:16 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Nov 2011 15:16:50 +0000 (15:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28724 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/i2c.mk
package/kernel/modules/spi.mk

index eb3ac83..0d525cc 100644 (file)
@@ -293,8 +293,13 @@ endef
 
 $(eval $(call KernelPackage,i2c-mux-pca9541))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+GPIO_PCA953X_MODULES:= \
+  CONFIG_GPIO_PCA953X:drivers/gpio/gpio-pca953x
+else
 GPIO_PCA953X_MODULES:= \
   CONFIG_GPIO_PCA953X:drivers/gpio/pca953x
+endif
 
 define KernelPackage/pca953x
   $(call i2c_defaults,$(GPIO_PCA953X_MODULES),51)
@@ -308,8 +313,13 @@ endef
 
 $(eval $(call KernelPackage,pca953x))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+GPIO_PCF857X_MODULES:= \
+  CONFIG_GPIO_PCF857X:drivers/gpio/gpio-pcf857x
+else
 GPIO_PCF857X_MODULES:= \
   CONFIG_GPIO_PCF857X:drivers/gpio/pcf857x
+endif
 
 define KernelPackage/pcf857x
   $(call i2c_defaults,$(GPIO_PCF857X_MODULES),51)
index 7cb2a35..0c187b3 100644 (file)
@@ -62,8 +62,13 @@ define KernelPackage/spi-gpio
   TITLE:=GPIO-based bitbanging SPI Master
   DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
   KCONFIG:=CONFIG_SPI_GPIO
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+  FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
+  AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
+else
   FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio.ko
   AUTOLOAD:=$(call AutoLoad,92,spi_gpio)
+endif
 endef
 
 define KernelPackage/spi-gpio/description