[kirkwood] Align jffs2 to pagesize and fix mkfs2.jffs2 opts
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Aug 2010 21:08:55 +0000 (21:08 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Aug 2010 21:08:55 +0000 (21:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22836 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/kirkwood/image/Makefile

index ee29a95..129ad95 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-JFFS2OPTS_NAND += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
+JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
 
 define Image/Prepare
        cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
@@ -25,6 +25,11 @@ define Image/Build
        )
 endef
 
+define Image/Build/jffs2-128k
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+               bs=2048 conv=sync
+endef
+
 define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        ( \