iptables: Makefile: only build ip6tc, if IPv6 is enabled
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:43:25 +0000 (12:43 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:43:25 +0000 (12:43 +0000)
when disabling ipv6, the iptables build breaks without a manul clean or this patch

Signed-off-by: Bastian Bittorf <bittorf@bluebottle.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40916 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iptables/Makefile

index fd84772..48b1879 100644 (file)
@@ -316,7 +316,7 @@ define Package/libiptc
 $(call Package/iptables/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libip4tc +libip6tc
+  DEPENDS:=+libip4tc +IPV6:libip6tc
   TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
 endef