kernel: ebtables depends on bridge
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Jul 2013 19:53:08 +0000 (19:53 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Jul 2013 19:53:08 +0000 (19:53 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37520 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netfilter.mk

index fb830fc..496a9f9 100644 (file)
@@ -425,7 +425,7 @@ $(eval $(call KernelPackage,arptables))
 define KernelPackage/ebtables
   SUBMENU:=$(NF_MENU)
   TITLE:=Bridge firewalling modules
-  DEPENDS:=+kmod-ipt-core
+  DEPENDS:=+kmod-ipt-core +kmod-bridge
   FILES:=$(foreach mod,$(EBTABLES-m),$(LINUX_DIR)/net/$(mod).ko)
   KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
        $(KCONFIG_EBTABLES)