[include] autotools.mk: introduce PKG_REMOVE_FILES to delete certain files after...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Dec 2010 15:55:05 +0000 (15:55 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Dec 2010 15:55:05 +0000 (15:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24348 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index a1a5d5d..b236aac 100644 (file)
@@ -17,11 +17,13 @@ endef
 
 define autoreconf
        (cd $(PKG_BUILD_DIR); \
+               $(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
                if [ -x ./autogen.sh ]; then \
                        ./autogen.sh || true; \
                elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
-                       rm -f ./GNUmakefile; \
+                       [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
                        $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               -B $(STAGING_DIR)/host/share/aclocal \
                                $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
                fi \
        );