[package] kernel/modules: Add kmod-zlib dependency to kmod-crypto-deflate
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 12 Apr 2011 23:34:28 +0000 (23:34 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 12 Apr 2011 23:34:28 +0000 (23:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26637 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/crypto.mk

index 0a843f8..63300a9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -215,10 +215,9 @@ $(eval $(call KernelPackage,crypto-des))
 
 define KernelPackage/crypto-deflate
   TITLE:=Deflate compression CryptoAPI module
-  KCONFIG:=CONFIG_ZLIB_DEFLATE \
-       CONFIG_CRYPTO_DEFLATE
-  FILES:=$(LINUX_DIR)/lib/zlib_deflate/zlib_deflate.ko \
-       $(LINUX_DIR)/crypto/deflate.ko
+  DEPENDS:=+kmod-zlib
+  KCONFIG:=CONFIG_CRYPTO_DEFLATE
+  FILES:=$(LINUX_DIR)/crypto/deflate.ko
   AUTOLOAD:=$(call AutoLoad,09,zlib_deflate deflate)
   $(call AddDepends/crypto)
 endef