acx-mac80211: fix build after recent mac80211 update and refresh patches
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Feb 2014 20:02:48 +0000 (20:02 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Feb 2014 20:02:48 +0000 (20:02 +0000)
This was only build tested.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39482 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/acx-mac80211/Makefile
package/kernel/acx-mac80211/patches/001-pci-mem-Fix-3.8-build.patch
package/kernel/acx-mac80211/patches/003-Fix-3.10-build.patch
package/kernel/acx-mac80211/patches/004-Fix-3.14-build.patch [new file with mode: 0644]
package/kernel/acx-mac80211/patches/200-initial-macaddr.patch

index 3f0fad9..6d0f7fb 100644 (file)
@@ -190,7 +190,7 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                SUBDIRS="$(PKG_BUILD_DIR)" \
                $(PKG_EXTRA_KCONFIG) \
-               EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(3,10,0)\"" \
+               EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(3,14,0)\"" \
                LINUXINCLUDE="-I$(STAGING_DIR)/usr/include/mac80211-backport/uapi -I$(STAGING_DIR)/usr/include/mac80211-backport \
                        -I$(STAGING_DIR)/usr/include/mac80211/uapi -I$(STAGING_DIR)/usr/include/mac80211 \
                        -I$(LINUX_DIR)/include -I$(LINUX_DIR)/include/$(LINUX_UAPI_DIR) \
index 2ee8c2a..fa4a6be 100644 (file)
@@ -12,11 +12,9 @@ Signed-off-by: Oliver Winker <oliver@oli1170.net>
  pci.c | 26 +++++++++++++++++++++++++-
  2 files changed, 37 insertions(+), 2 deletions(-)
 
-diff --git a/mem.c b/mem.c
-index 87e01f1..f1ff7e2 100644
 --- a/mem.c
 +++ b/mem.c
-@@ -2216,7 +2216,11 @@ int acx100mem_ioctl_set_phy_amp_bias(struct ieee80211_hw *hw,
+@@ -2216,7 +2216,11 @@ int acx100mem_ioctl_set_phy_amp_bias(str
   * ==================================================
   */
  
@@ -28,7 +26,7 @@ index 87e01f1..f1ff7e2 100644
  {
        acx_device_t *adev = NULL;
        const char *chip_name;
-@@ -2392,7 +2396,11 @@ static int __devinit acxmem_probe(struct platform_device *pdev)
+@@ -2392,7 +2396,11 @@ static int __devinit acxmem_probe(struct
   * pdev - ptr to PCI device structure containing info about pci
   * configuration
   */
@@ -40,7 +38,7 @@ index 87e01f1..f1ff7e2 100644
  {
        struct ieee80211_hw *hw = (struct ieee80211_hw *)
                platform_get_drvdata(pdev);
-@@ -2594,8 +2602,11 @@ static struct platform_driver acxmem_driver = {
+@@ -2594,8 +2602,11 @@ static struct platform_driver acxmem_dri
                .name = "acx-mem",
        },
        .probe = acxmem_probe,
@@ -53,11 +51,9 @@ index 87e01f1..f1ff7e2 100644
  #ifdef CONFIG_PM
        .suspend = acxmem_e_suspend,
        .resume = acxmem_e_resume
-diff --git a/pci.c b/pci.c
-index 1da31d1..ae07f5a 100644
 --- a/pci.c
 +++ b/pci.c
-@@ -1039,7 +1039,11 @@ int acx100pci_ioctl_set_phy_amp_bias(struct net_device *ndev,
+@@ -1039,7 +1039,11 @@ int acx100pci_ioctl_set_phy_amp_bias(str
   * id - ptr to the device id entry that matched this device
   */
  #ifdef CONFIG_PCI
@@ -69,7 +65,7 @@ index 1da31d1..ae07f5a 100644
                                const struct pci_device_id *id)
  {
        unsigned long mem_region1 = 0;
-@@ -1292,7 +1296,11 @@ static int __devinit acxpci_probe(struct pci_dev *pdev,
+@@ -1292,7 +1296,11 @@ static int __devinit acxpci_probe(struct
   *
   * pdev - ptr to PCI device structure containing info about pci configuration
   */
@@ -81,7 +77,7 @@ index 1da31d1..ae07f5a 100644
  {
        struct ieee80211_hw *hw
                = (struct ieee80211_hw *) pci_get_drvdata(pdev);
-@@ -1505,7 +1513,11 @@ static struct pci_driver acxpci_driver = {
+@@ -1505,7 +1513,11 @@ static struct pci_driver acxpci_driver =
        .name           = "acx_pci",
        .id_table       = acxpci_id_tbl,
        .probe          = acxpci_probe,
@@ -93,7 +89,7 @@ index 1da31d1..ae07f5a 100644
  #ifdef CONFIG_PM
        .suspend        = acxpci_e_suspend,
        .resume         = acxpci_e_resume
-@@ -1603,8 +1615,12 @@ static struct vlynq_device_id acx_vlynq_id[] = {
+@@ -1603,8 +1615,12 @@ static struct vlynq_device_id acx_vlynq_
  };
  
  
@@ -107,7 +103,7 @@ index 1da31d1..ae07f5a 100644
  {
        int result = -EIO, i;
        u32 addr;
-@@ -1785,7 +1801,11 @@ static __devinit int vlynq_probe(struct vlynq_device *vdev,
+@@ -1785,7 +1801,11 @@ static __devinit int vlynq_probe(struct
        return result;
  }
  
@@ -119,7 +115,7 @@ index 1da31d1..ae07f5a 100644
  {
        struct ieee80211_hw *hw = vlynq_get_drvdata(vdev);
        acx_device_t *adev = hw2adev(hw);
-@@ -1851,7 +1871,11 @@ static struct vlynq_driver acxvlynq_driver = {
+@@ -1851,7 +1871,11 @@ static struct vlynq_driver acxvlynq_driv
        .name = "acx_vlynq",
        .id_table = acx_vlynq_id,
        .probe = vlynq_probe,
@@ -131,6 +127,3 @@ index 1da31d1..ae07f5a 100644
  };
  #endif /* CONFIG_VLYNQ */
  
--- 
-1.8.4.rc1
-
index a063669..c737844 100644 (file)
@@ -9,11 +9,9 @@ Signed-off-by: Oliver Winker <oliver@oli1170.net>
  main.c | 7 +++++++
  1 file changed, 7 insertions(+)
 
-diff --git a/main.c b/main.c
-index 3af6cd0..841592f 100644
 --- a/main.c
 +++ b/main.c
-@@ -682,10 +682,17 @@ int acx_op_config(struct ieee80211_hw *hw, u32 changed)
+@@ -682,10 +682,17 @@ int acx_op_config(struct ieee80211_hw *h
  
        if (changed & IEEE80211_CONF_CHANGE_CHANNEL) {
                logf1(L_DEBUG, "IEEE80211_CONF_CHANGE_CHANNEL,"
@@ -31,6 +29,3 @@ index 3af6cd0..841592f 100644
  
                changed_not_done &= ~IEEE80211_CONF_CHANGE_CHANNEL;
        }
--- 
-1.8.4.rc1
-
diff --git a/package/kernel/acx-mac80211/patches/004-Fix-3.14-build.patch b/package/kernel/acx-mac80211/patches/004-Fix-3.14-build.patch
new file mode 100644 (file)
index 0000000..2eadb8f
--- /dev/null
@@ -0,0 +1,22 @@
+From d17fcac710e629463591f6bd09d76b66ec591583 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Wed, 5 Feb 2014 20:57:07 +0100
+Subject: [PATCH] Fix 3.14 build
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+---
+ main.c |    2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/main.c
++++ b/main.c
+@@ -500,7 +500,9 @@ int acx_init_ieee80211(acx_device_t *ade
+       hw->flags &= ~IEEE80211_HW_RX_INCLUDES_FCS;
+       hw->queues = 1;
+       hw->wiphy->max_scan_ssids = 1;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 14, 0)
+       hw->channel_change_time = 10000;
++#endif
+       /* OW TODO Check if RTS/CTS threshold can be included here */
index 612a876..c0fdd43 100644 (file)
@@ -1,7 +1,7 @@
 --- a/cardsetting.c
 +++ b/cardsetting.c
-@@ -710,10 +710,25 @@ static int acx1xx_get_station_id(acx_dev
-       u8 *stationID = adev->ie_cmd_buf;;
+@@ -715,10 +715,25 @@ int acx1xx_get_station_id(acx_device_t *
+       u8 *stationID = adev->ie_cmd_buf;
        const u8 *paddr;
        int i, res;
 +      const char *prom_addr;