ramips: set -march=24kec for rt305x and rt3883 to enable use of DSP extension
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Mar 2013 12:47:31 +0000 (12:47 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Mar 2013 12:47:31 +0000 (12:47 +0000)
All known rt305x and rt3883 implementations support at
least the 24kec instruction set which includes the DSP
extension. For rt288x, the previous value mips32r2 is
kept.

The cpu target is now set per sub-archtecture, according
to cpu-feature-overrides.h of each SoC family.

[juhosg: define ARCH_PACKAGES variable for rt305x/rt3883
in order to differentiate the packages compiled with
the 24Kec option.]

Signed-off-by: Daniel Golle <dgolle@allnet.de>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35853 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/Makefile
target/linux/ramips/rt288x/target.mk
target/linux/ramips/rt305x/target.mk
target/linux/ramips/rt3883/target.mk

index 039a57c..b02c801 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
 LINUX_VERSION:=3.7.9
 FEATURES:=squashfs
 
 LINUX_VERSION:=3.7.9
index cb3b719..f826eab 100644 (file)
@@ -4,6 +4,7 @@
 
 SUBTARGET:=rt288x
 BOARDNAME:=RT288x based boards
 
 SUBTARGET:=rt288x
 BOARDNAME:=RT288x based boards
+CFLAGS+= -mips32r2 -mtune=mips32r2
 
 define Target/Description
        Build firmware images for Ralink RT288x based boards.
 
 define Target/Description
        Build firmware images for Ralink RT288x based boards.
index 2c78756..e355060 100644 (file)
@@ -4,6 +4,8 @@
 
 SUBTARGET:=rt305x
 BOARDNAME:=RT305x based boards
 
 SUBTARGET:=rt305x
 BOARDNAME:=RT305x based boards
+ARCH_PACKAGES:=ramips_24kec
+CFLAGS+= -march=24kec
 
 define Target/Description
        Build firmware images for Ralink RT305x based boards.
 
 define Target/Description
        Build firmware images for Ralink RT305x based boards.
index 590bb98..85bfc5a 100644 (file)
@@ -4,6 +4,8 @@
 
 SUBTARGET:=rt3883
 BOARDNAME:=RT3662/RT3883 based boards
 
 SUBTARGET:=rt3883
 BOARDNAME:=RT3662/RT3883 based boards
+ARCH_PACKAGES:=ramips_24kec
+CFLAGS+= -march=24kec
 
 define Target/Description
        Build firmware images for Ralink RT3662/RT3883 based boards.
 
 define Target/Description
        Build firmware images for Ralink RT3662/RT3883 based boards.