[package] uhttpd: add explicit stdin eof notification for Lua and CGI childs
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jun 2012 14:56:24 +0000 (14:56 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Jun 2012 14:56:24 +0000 (14:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32027 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uhttpd/Makefile
package/uhttpd/src/uhttpd-cgi.c
package/uhttpd/src/uhttpd-lua.c

index 13da14d..9d8f9fa 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=34
+PKG_RELEASE:=35
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index 2f7ea7a..5e445ca 100644 (file)
@@ -181,6 +181,10 @@ static bool uh_cgi_socket_cb(struct client *cl)
                /* ... write to CGI process */
                len = uh_raw_send(state->wfd, buf, len,
                                                  cl->server->conf->script_timeout);
+
+               /* explicit EOF notification for the child */
+               if (state->content_length <= 0)
+                       close(state->wfd);
        }
 
        /* try to read data from child */
index 7d602f7..e8d932b 100644 (file)
@@ -298,9 +298,13 @@ static bool uh_lua_socket_cb(struct client *cl)
                else
                        state->content_length = 0;
 
-               /* ... write to CGI process */
+               /* ... write to Lua process */
                len = uh_raw_send(state->wfd, buf, len,
                                                  cl->server->conf->script_timeout);
+
+               /* explicit EOF notification for the child */
+               if (state->content_length <= 0)
+                       close(state->wfd);
        }
 
        /* try to read data from child */