fix kmod-fuse build on 2.4
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 2 Apr 2006 01:25:05 +0000 (01:25 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 2 Apr 2006 01:25:05 +0000 (01:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3577 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/package/fuse/patches/101-kmod_build.patch

index feed52a..e541d47 100644 (file)
@@ -25,13 +25,15 @@ diff -Nur fuse-2.5.2/kernel/Makefile.in fuse-2.5.2.patched/kernel/Makefile.in
  fuse_headers = fuse_i.h fuse_kernel.h
  
  dev.o: $(fuse_headers)
-@@ -78,6 +63,16 @@
+@@ -78,6 +63,18 @@
  file.o: $(fuse_headers)
  inode.o: $(fuse_headers)
  
 +EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
 +
-+obj-m := $(fuse_objs)
++O_TARGET := fuse.o
++
++obj-y := $(fuse_objs) 
 +obj-m := $(O_TARGET)
 +
 +-include $(TOPDIR)/Rules.make