[package] kernel: fix usage of CompareKernelPatchVer for kmod-gre
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Mar 2011 14:30:05 +0000 (14:30 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Mar 2011 14:30:05 +0000 (14:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26010 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netsupport.mk

index 8379931..25e2ac4 100644 (file)
@@ -371,11 +371,11 @@ define KernelPackage/gre
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=GRE support
   KCONFIG:=CONFIG_NET_IPGRE \
-    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
+    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
   FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko \
-    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
+    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
   AUTOLOAD:=$(call AutoLoad,39, \
-    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),gre) ip_gre)
+    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),gre) ip_gre)
 endef
 
 define KernelPackage/gre/description