kernel: allow hwmon GSC driver for all targets
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Sep 2013 22:26:30 +0000 (22:26 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Sep 2013 22:26:30 +0000 (22:26 +0000)
- enable using hwmon GSC driver on all targets
- add a kmod package for it

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37933 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/hwmon.mk
target/linux/generic/patches-3.10/880-gateworks_system_controller.patch
target/linux/generic/patches-3.3/880-gateworks_system_controller.patch
target/linux/generic/patches-3.6/880-gateworks_system_controller.patch
target/linux/generic/patches-3.8/880-gateworks_system_controller.patch
target/linux/generic/patches-3.9/880-gateworks_system_controller.patch

index 5af311d..b1f4744 100644 (file)
@@ -219,3 +219,18 @@ define KernelPacakge/hwmon-w83627hf/description
 endef
 
 $(eval $(call KernelPackage,hwmon-w83627hf))
 endef
 
 $(eval $(call KernelPackage,hwmon-w83627hf))
+
+
+define KernelPackage/hwmon-gsc
+  TITLE:=Gateworks GSC monitoring support
+  KCONFIG:=CONFIG_SENSORS_GSC
+  FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
+  AUTOLOAD:=$(call AutoLoad,50,gsc)
+$(call AddDepends/hwmon)
+endef
+
+define KernelPacakge/hwmon-gsc/description
+  Kernel module for the Gateworks System Controller chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-gsc))
index 73dd583..d923485 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends on I2C
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
index 981610d..d9a6481 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends on I2C
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
index 02c9d8f..010dc29 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
index dd78ef8..1ec0960 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends on I2C
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
index efb7c48..3bcca9c 100644 (file)
@@ -6,7 +6,7 @@
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
  
 +config SENSORS_GSC
 +      tristate "Gateworks System Controller"
-+      depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++      depends on I2C
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +
 +      help
 +        If you say yes here you get support for the Gateworks System Controller.
 +