rules.mk: make the locked template available even if flock has not been built yet...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 20 Jan 2016 21:31:38 +0000 (21:31 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 20 Jan 2016 21:31:38 +0000 (21:31 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48414 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index f0c8136..11ed809 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -333,12 +333,16 @@ endef
 # Execute commands under flock
 # $(1) => The shell expression.
 # $(2) => The lock name. If not given, the global lock will be used.
-define locked
+ifneq ($(wildcard $(STAGING_DIR_HOST)/bin/flock),)
+  define locked
        SHELL= \
-       $(STAGING_DIR_HOST)/bin/flock \
+       flock \
                $(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock \
                -c '$(subst ','\'',$(1))'
-endef
+  endef
+else
+  locked=$(1)
+endif
 
 # Recursively copy paths into another directory, purge dangling
 # symlinks before.