Add a PyMod template for python related modules
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 28 Aug 2007 12:41:39 +0000 (12:41 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 28 Aug 2007 12:41:39 +0000 (12:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8522 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index 1e18f8c..4b811f8 100644 (file)
@@ -128,6 +128,15 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
+define Build/Compile/PyMod
+ cd $(PKG_BUILD_DIR); \
+ $(1) \
+ CFLAGS='-I$(STAGING_DIR)/usr/include' \
+ LDFLAGS='$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib' \
+ $(STAGING_DIR)/usr/bin/hostpython ./setup.py $(2) \
+ --prefix=$(PKG_INSTALL_DIR)/usr
+endef
+
 $(PACKAGE_DIR):
        mkdir -p $@