[kernel] generic-2.6: add ip175c stuff for 2.6.29
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Apr 2009 11:16:38 +0000 (11:16 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Apr 2009 11:16:38 +0000 (11:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15505 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic-2.6/config-2.6.29
target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch [new file with mode: 0644]
target/linux/generic-2.6/patches-2.6.29/680-phy_ar8216.patch

index b80a79e..2c1cdf1 100644 (file)
@@ -654,6 +654,7 @@ CONFIG_INIT_ENV_ARG_LIMIT=32
 CONFIG_IOSCHED_DEADLINE=y
 CONFIG_IOSCHED_NOOP=y
 # CONFIG_IP1000 is not set
+# CONFIG_IP175C_PHY is not set
 # CONFIG_IP6_NF_FILTER is not set
 # CONFIG_IP6_NF_IPTABLES is not set
 # CONFIG_IP6_NF_MANGLE is not set
diff --git a/target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch b/target/linux/generic-2.6/patches-2.6.29/670-phy_ip175c.patch
new file mode 100644 (file)
index 0000000..461df50
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -96,6 +96,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+       tristate "Driver for Marvell 88E6060 switches"
++config IP175C_PHY
++      tristate "Driver for IC+ IP175C/IP178C switches"
++      select SWCONFIG
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY)   += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
++obj-$(CONFIG_IP175C_PHY)      += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o
index 2e9bab1..622e657 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -84,6 +84,10 @@ config IP175C_PHY
+@@ -100,6 +100,10 @@ config IP175C_PHY
        tristate "Driver for IC+ IP175C/IP178C switches"
        select SWCONFIG
  
@@ -19,5 +19,5 @@
  obj-$(CONFIG_IP175C_PHY)      += ip175c.o
 +obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
- obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o