fix gcc 4.2.0 compile for ppc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Jun 2007 19:52:09 +0000 (19:52 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Jun 2007 19:52:09 +0000 (19:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7761 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/Makefile
toolchain/gcc/patches/4.2.0/307-long_double_fix.patch [new file with mode: 0644]

index b5502bc..6d46f98 100644 (file)
@@ -119,6 +119,7 @@ define Build/Prepare
        $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(PKG_BUILD_DIR)/gcc/version.c
        $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(PKG_BUILD_DIR)/gcc/version.c
        (cd $(PKG_BUILD_DIR)/libstdc++-v3; autoconf;);
+       $(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(PKG_BUILD_DIR)/libstdc++-v3/configure
 endef
 
 define Build/Configure
diff --git a/toolchain/gcc/patches/4.2.0/307-long_double_fix.patch b/toolchain/gcc/patches/4.2.0/307-long_double_fix.patch
new file mode 100644 (file)
index 0000000..1229bdc
--- /dev/null
@@ -0,0 +1,26 @@
+Index: gcc-4.2.0/gcc/config/rs6000/darwin-ldouble.c
+===================================================================
+--- gcc-4.2.0.orig/gcc/config/rs6000/darwin-ldouble.c  2007-06-28 20:56:39.222667344 +0200
++++ gcc-4.2.0/gcc/config/rs6000/darwin-ldouble.c       2007-06-28 20:57:02.258165416 +0200
+@@ -49,9 +49,10 @@
+    This code currently assumes big-endian.  */
+-#if ((!defined (__NO_FPRS__) || defined (_SOFT_FLOAT)) \
++#if (defined (__LONG_DOUBLE_128__) && \
++      ((!defined (__NO_FPRS__) || defined (_SOFT_FLOAT)) \
+      && !defined (__LITTLE_ENDIAN__) \
+-     && (defined (__MACH__) || defined (__powerpc__) || defined (_AIX)))
++     && (defined (__MACH__) || defined (__powerpc__) || defined (_AIX))))
+ #define fabs(x) __builtin_fabs(x)
+ #define isless(x, y) __builtin_isless (x, y)
+@@ -219,7 +220,7 @@
+   return z.ldval;
+ }
+-#if defined (_SOFT_FLOAT) && defined (__LONG_DOUBLE_128__)
++#ifdef _SOFT_FLOAT
+ long double __gcc_qneg (double, double);
+ int __gcc_qeq (double, double, double, double);