Use 2.6.27 for au1000
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Nov 2008 14:55:08 +0000 (14:55 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Nov 2008 14:55:08 +0000 (14:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13220 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/au1000/Makefile
target/linux/au1000/config-2.6.27 [new file with mode: 0644]
target/linux/au1000/files/arch/mips/au1000/mtx-1/platform.c [deleted file]
target/linux/au1000/patches-2.6.27/001-mtx1_cmdline.patch [new file with mode: 0644]
target/linux/au1000/patches-2.6.27/002-openwrt_rootfs.patch [new file with mode: 0644]
target/linux/au1000/patches-2.6.27/003-au1000_eth_ioctl.patch [new file with mode: 0644]
target/linux/au1000/patches-2.6.27/004-state_led_phy_fix.patch [new file with mode: 0644]
target/linux/au1000/patches-2.6.27/005-mtx1_wdt_fix.patch [new file with mode: 0644]
target/linux/au1000/patches-2.6.27/006-missing_string_header.patch [new file with mode: 0644]

index ecb76ee..097fa7a 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.25.20
+LINUX_VERSION:=2.6.27.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += yamonenv
@@ -28,4 +28,3 @@ define Kernel/BuildImage
 endef
 
 $(eval $(call BuildTarget))
-
diff --git a/target/linux/au1000/config-2.6.27 b/target/linux/au1000/config-2.6.27
new file mode 100644 (file)
index 0000000..5ac35a4
--- /dev/null
@@ -0,0 +1,276 @@
+CONFIG_32BIT=y
+# CONFIG_64BIT is not set
+CONFIG_64BIT_PHYS_ADDR=y
+# CONFIG_8139TOO is not set
+# CONFIG_ARCH_HAS_ILOG2_U32 is not set
+# CONFIG_ARCH_HAS_ILOG2_U64 is not set
+CONFIG_ARCH_POPULATES_NODE_MAP=y
+# CONFIG_ARCH_SUPPORTS_MSI is not set
+CONFIG_ARCH_SUPPORTS_OPROFILE=y
+CONFIG_ARCH_SUSPEND_POSSIBLE=y
+# CONFIG_ATM is not set
+CONFIG_BASE_SMALL=0
+# CONFIG_BCM47XX is not set
+CONFIG_BITREVERSE=y
+# CONFIG_BROADCOM_PHY is not set
+CONFIG_CEVT_R4K=y
+CONFIG_CHR_DEV_SG=m
+CONFIG_CLASSIC_RCU=y
+CONFIG_CMDLINE="root=/dev/mtdblock0 rootfstype=squashfs,jffs2 init=/etc/preinit"
+# CONFIG_CPU_BIG_ENDIAN is not set
+CONFIG_CPU_HAS_LLSC=y
+CONFIG_CPU_HAS_PREFETCH=y
+CONFIG_CPU_HAS_SYNC=y
+CONFIG_CPU_LITTLE_ENDIAN=y
+# CONFIG_CPU_LOONGSON2 is not set
+CONFIG_CPU_MIPS32=y
+CONFIG_CPU_MIPS32_R1=y
+# CONFIG_CPU_MIPS32_R2 is not set
+# CONFIG_CPU_MIPS64_R1 is not set
+# CONFIG_CPU_MIPS64_R2 is not set
+CONFIG_CPU_MIPSR1=y
+# CONFIG_CPU_NEVADA is not set
+# CONFIG_CPU_R10000 is not set
+# CONFIG_CPU_R3000 is not set
+# CONFIG_CPU_R4300 is not set
+# CONFIG_CPU_R4X00 is not set
+# CONFIG_CPU_R5000 is not set
+# CONFIG_CPU_R5432 is not set
+# CONFIG_CPU_R6000 is not set
+# CONFIG_CPU_R8000 is not set
+# CONFIG_CPU_RM7000 is not set
+# CONFIG_CPU_RM9000 is not set
+# CONFIG_CPU_SB1 is not set
+CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
+CONFIG_CPU_SUPPORTS_HIGHMEM=y
+# CONFIG_CPU_TX39XX is not set
+# CONFIG_CPU_TX49XX is not set
+# CONFIG_CPU_VR41XX is not set
+CONFIG_CRAMFS=m
+CONFIG_CRC16=y
+CONFIG_CRYPTO_GF128MUL=m
+CONFIG_CSRC_R4K=y
+CONFIG_DEVPORT=y
+# CONFIG_DM9000 is not set
+CONFIG_DMA_NEED_PCI_MAP_STATE=y
+CONFIG_DMA_NONCOHERENT=y
+CONFIG_DUMMY=m
+CONFIG_ELF_CORE=y
+CONFIG_EXTRA_FIRMWARE=""
+CONFIG_FIRMWARE_IN_KERNEL=y
+# CONFIG_FIXED_PHY is not set
+CONFIG_FS_POSIX_ACL=y
+CONFIG_GENERIC_CLOCKEVENTS=y
+CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
+CONFIG_GENERIC_CMOS_UPDATE=y
+# CONFIG_GENERIC_FIND_FIRST_BIT is not set
+CONFIG_GENERIC_FIND_NEXT_BIT=y
+# CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ is not set
+# CONFIG_HAMRADIO is not set
+CONFIG_HAS_DMA=y
+CONFIG_HAS_IOMEM=y
+CONFIG_HAS_IOPORT=y
+CONFIG_HAVE_ARCH_KGDB=y
+# CONFIG_HAVE_ARCH_TRACEHOOK is not set
+# CONFIG_HAVE_CLK is not set
+# CONFIG_HAVE_DMA_ATTRS is not set
+# CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS is not set
+# CONFIG_HAVE_GENERIC_DMA_COHERENT is not set
+CONFIG_HAVE_IDE=y
+# CONFIG_HAVE_IOREMAP_PROT is not set
+# CONFIG_HAVE_KPROBES is not set
+# CONFIG_HAVE_KRETPROBES is not set
+CONFIG_HAVE_OPROFILE=y
+CONFIG_HID=m
+CONFIG_HID_SUPPORT=y
+CONFIG_HW_HAS_PCI=y
+CONFIG_HW_RANDOM=y
+CONFIG_HZ=250
+# CONFIG_HZ_100 is not set
+CONFIG_HZ_250=y
+CONFIG_I2C=m
+CONFIG_I2C_ALGOBIT=m
+CONFIG_I2C_ALGOPCA=m
+CONFIG_I2C_ALGOPCF=m
+CONFIG_I2C_BOARDINFO=y
+CONFIG_I2C_CHARDEV=m
+# CONFIG_IDE is not set
+CONFIG_INITRAMFS_SOURCE=""
+CONFIG_INPUT=y
+CONFIG_INPUT_KEYBOARD=y
+CONFIG_IRQ_CPU=y
+CONFIG_KEXEC=y
+# CONFIG_KEYBOARD_ATKBD is not set
+# CONFIG_KEYBOARD_LKKBD is not set
+# CONFIG_KEYBOARD_NEWTON is not set
+# CONFIG_KEYBOARD_STOWAWAY is not set
+# CONFIG_KEYBOARD_SUNKBD is not set
+# CONFIG_KEYBOARD_XTKBD is not set
+CONFIG_KMOD=y
+# CONFIG_LEDS_ALIX is not set
+# CONFIG_LEDS_TRIGGERS is not set
+# CONFIG_LEMOTE_FULONG is not set
+CONFIG_MACH_ALCHEMY=y
+# CONFIG_MACH_DECSTATION is not set
+# CONFIG_MACH_JAZZ is not set
+# CONFIG_MACH_TX39XX is not set
+# CONFIG_MACH_TX49XX is not set
+# CONFIG_MACH_VR41XX is not set
+CONFIG_MAGIC_SYSRQ=y
+# CONFIG_MDIO_BITBANG is not set
+CONFIG_MEDIA_TUNER=m
+CONFIG_MEDIA_TUNER_MT20XX=m
+CONFIG_MEDIA_TUNER_SIMPLE=m
+CONFIG_MEDIA_TUNER_TDA8290=m
+CONFIG_MEDIA_TUNER_TDA9887=m
+CONFIG_MEDIA_TUNER_TEA5761=m
+CONFIG_MEDIA_TUNER_TEA5767=m
+CONFIG_MEDIA_TUNER_XC2028=m
+CONFIG_MEDIA_TUNER_XC5000=m
+# CONFIG_MFD_CORE is not set
+# CONFIG_MFD_TMIO is not set
+# CONFIG_MIKROTIK_RB532 is not set
+CONFIG_MIPS=y
+CONFIG_MIPS_AU1X00_ENET=y
+# CONFIG_MIPS_BOSPORUS is not set
+# CONFIG_MIPS_COBALT is not set
+# CONFIG_MIPS_DB1000 is not set
+# CONFIG_MIPS_DB1100 is not set
+# CONFIG_MIPS_DB1200 is not set
+# CONFIG_MIPS_DB1500 is not set
+# CONFIG_MIPS_DB1550 is not set
+CONFIG_MIPS_L1_CACHE_SHIFT=5
+# CONFIG_MIPS_MALTA is not set
+# CONFIG_MIPS_MIRAGE is not set
+CONFIG_MIPS_MTX1=y
+CONFIG_MIPS_MT_DISABLED=y
+# CONFIG_MIPS_MT_SMP is not set
+# CONFIG_MIPS_MT_SMTC is not set
+# CONFIG_MIPS_PB1000 is not set
+# CONFIG_MIPS_PB1100 is not set
+# CONFIG_MIPS_PB1200 is not set
+# CONFIG_MIPS_PB1500 is not set
+# CONFIG_MIPS_PB1550 is not set
+# CONFIG_MIPS_SIM is not set
+# CONFIG_MIPS_XXS1500 is not set
+# CONFIG_MISDN is not set
+CONFIG_MODULE_FORCE_UNLOAD=y
+CONFIG_MTD=y
+# CONFIG_MTD_ABSENT is not set
+# CONFIG_MTD_ALCHEMY is not set
+CONFIG_MTD_BLKDEVS=y
+CONFIG_MTD_BLOCK=y
+# CONFIG_MTD_BLOCK2MTD is not set
+CONFIG_MTD_CFI=y
+# CONFIG_MTD_CFI_ADV_OPTIONS is not set
+CONFIG_MTD_CFI_AMDSTD=y
+CONFIG_MTD_CFI_I1=y
+CONFIG_MTD_CFI_I2=y
+# CONFIG_MTD_CFI_I4 is not set
+# CONFIG_MTD_CFI_I8 is not set
+# CONFIG_MTD_CFI_INTELEXT is not set
+# CONFIG_MTD_CFI_STAA is not set
+CONFIG_MTD_CFI_UTIL=y
+CONFIG_MTD_CHAR=y
+# CONFIG_MTD_CMDLINE_PARTS is not set
+# CONFIG_MTD_COMPLEX_MAPPINGS is not set
+CONFIG_MTD_CONCAT=y
+CONFIG_MTD_GEN_PROBE=y
+# CONFIG_MTD_JEDECPROBE is not set
+CONFIG_MTD_MAP_BANK_WIDTH_1=y
+# CONFIG_MTD_MAP_BANK_WIDTH_16 is not set
+CONFIG_MTD_MAP_BANK_WIDTH_2=y
+# CONFIG_MTD_MAP_BANK_WIDTH_32 is not set
+CONFIG_MTD_MAP_BANK_WIDTH_4=y
+# CONFIG_MTD_MAP_BANK_WIDTH_8 is not set
+# CONFIG_MTD_MTDRAM is not set
+# CONFIG_MTD_ONENAND is not set
+CONFIG_MTD_PARTITIONS=y
+# CONFIG_MTD_PHRAM is not set
+CONFIG_MTD_PHYSMAP=y
+CONFIG_MTD_PHYSMAP_BANKWIDTH=2
+CONFIG_MTD_PHYSMAP_LEN=0
+CONFIG_MTD_PHYSMAP_START=0x8000000
+# CONFIG_MTD_PLATRAM is not set
+# CONFIG_MTD_PMC551 is not set
+# CONFIG_MTD_RAM is not set
+# CONFIG_MTD_REDBOOT_PARTS is not set
+# CONFIG_MTD_ROM is not set
+# CONFIG_MTD_SLRAM is not set
+# CONFIG_NATSEMI is not set
+# CONFIG_NET_SCH_ESFQ_NFCT is not set
+CONFIG_NF_CT_ACCT=y
+# CONFIG_NO_IOPORT is not set
+CONFIG_PAGEFLAGS_EXTENDED=y
+# CONFIG_PAGE_SIZE_16KB is not set
+CONFIG_PAGE_SIZE_4KB=y
+# CONFIG_PAGE_SIZE_64KB is not set
+# CONFIG_PAGE_SIZE_8KB is not set
+CONFIG_PCI=y
+CONFIG_PCI_DOMAINS=y
+CONFIG_PCSPKR_PLATFORM=y
+CONFIG_PHYLIB=y
+# CONFIG_PMC_MSP is not set
+# CONFIG_PMC_YOSEMITE is not set
+# CONFIG_PNX8550_JBS is not set
+# CONFIG_PNX8550_STB810 is not set
+# CONFIG_PPP_MPPE is not set
+# CONFIG_PREVENT_FIRMWARE_BUILD is not set
+# CONFIG_PROBE_INITRD_HEADER is not set
+# CONFIG_QSEMI_PHY is not set
+# CONFIG_R6040 is not set
+# CONFIG_REALTEK_PHY is not set
+CONFIG_RESOURCES_64BIT=y
+CONFIG_RTC_LIB=y
+CONFIG_RWSEM_GENERIC_SPINLOCK=y
+CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
+CONFIG_SCSI_CONSTANTS=y
+# CONFIG_SCSI_PROC_FS is not set
+CONFIG_SCSI_WAIT_SCAN=m
+CONFIG_SERIAL_8250_AU1X00=y
+# CONFIG_SERIAL_8250_EXTENDED is not set
+CONFIG_SERIAL_8250_NR_UARTS=4
+CONFIG_SERIAL_8250_PCI=m
+CONFIG_SERIAL_8250_RUNTIME_UARTS=4
+# CONFIG_SGI_IP22 is not set
+# CONFIG_SGI_IP27 is not set
+# CONFIG_SGI_IP28 is not set
+# CONFIG_SGI_IP32 is not set
+# CONFIG_SIBYTE_BIGSUR is not set
+# CONFIG_SIBYTE_CARMEL is not set
+# CONFIG_SIBYTE_CRHINE is not set
+# CONFIG_SIBYTE_CRHONE is not set
+# CONFIG_SIBYTE_LITTLESUR is not set
+# CONFIG_SIBYTE_RHONE is not set
+# CONFIG_SIBYTE_SENTOSA is not set
+# CONFIG_SIBYTE_SWARM is not set
+# CONFIG_SMSC_PHY is not set
+CONFIG_SOC_AU1500=y
+CONFIG_SOC_AU1X00=y
+CONFIG_SOFT_WATCHDOG=m
+# CONFIG_SPARSEMEM_STATIC is not set
+# CONFIG_SPARSEMEM_VMEMMAP_ENABLE is not set
+CONFIG_SSB_POSSIBLE=y
+# CONFIG_STANDALONE is not set
+CONFIG_SYSVIPC_SYSCTL=y
+CONFIG_SYS_HAS_CPU_MIPS32_R1=y
+CONFIG_SYS_SUPPORTS_32BIT_KERNEL=y
+CONFIG_SYS_SUPPORTS_APM_EMULATION=y
+CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
+CONFIG_SYS_SUPPORTS_LITTLE_ENDIAN=y
+# CONFIG_TC35815 is not set
+# CONFIG_THERMAL is not set
+# CONFIG_THERMAL_HWMON is not set
+CONFIG_TICK_ONESHOT=y
+# CONFIG_TMD_HERMES is not set
+CONFIG_TRAD_SIGNALS=y
+CONFIG_USB_SUPPORT=y
+# CONFIG_VGASTATE is not set
+# CONFIG_VIA_RHINE is not set
+CONFIG_VIDEO_CAPTURE_DRIVERS=y
+CONFIG_VIDEO_MEDIA=m
+CONFIG_VIDEO_V4L2=m
+CONFIG_VIDEO_V4L2_COMMON=m
+# CONFIG_VLAN_8021Q_GVRP is not set
+CONFIG_WDT_MTX1=y
+CONFIG_ZONE_DMA_FLAG=0
diff --git a/target/linux/au1000/files/arch/mips/au1000/mtx-1/platform.c b/target/linux/au1000/files/arch/mips/au1000/mtx-1/platform.c
deleted file mode 100644 (file)
index 5c7fe53..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-/*
- * MTX-1 platform devices registration
- *
- * Copyright (C) 2007, Florian Fainelli <florian@openwrt.org>
- * 
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- * 
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *  
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
- */
-
-#include <linux/autoconf.h>
-#include <linux/init.h>
-#include <linux/types.h>
-#include <linux/platform_device.h>
-#include <linux/leds.h>
-
-#include <asm/gpio.h>
-
-static struct resource mtx1_wdt_res[] = {
-       [0] = {
-               .start = 15,
-               .end = 15,
-               .name = "mtx1-wdt-gpio",
-               .flags = IORESOURCE_IRQ,
-       }
-};
-
-static struct platform_device mtx1_wdt = {
-       .name = "mtx1-wdt",
-       .id = 0,
-       .num_resources = ARRAY_SIZE(mtx1_wdt_res),
-       .resource = mtx1_wdt_res,
-};
-
-static struct gpio_led default_leds[] = {
-        { .name = "mtx1:green", .gpio = 211, },
-       { .name = "mtx1:red", .gpio = 212, },
-};
-
-static struct gpio_led_platform_data mtx1_led_data = {
-       .num_leds = ARRAY_SIZE(default_leds),
-       .leds = default_leds,
-};
-
-static struct platform_device mtx1_gpio_leds = {
-        .name = "leds-gpio",
-        .id = -1,
-        .dev = {
-                .platform_data = &mtx1_led_data,
-        }
-};
-
-static struct platform_device *mtx1_devs[] = {
-       &mtx1_gpio_leds,
-       &mtx1_wdt
-};
-
-static int __init mtx1_register_devices(void)
-{
-       return platform_add_devices(mtx1_devs, ARRAY_SIZE(mtx1_devs));
-}
-
-module_init(mtx1_register_devices);
-
diff --git a/target/linux/au1000/patches-2.6.27/001-mtx1_cmdline.patch b/target/linux/au1000/patches-2.6.27/001-mtx1_cmdline.patch
new file mode 100644 (file)
index 0000000..a41ee6f
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/mips/au1000/mtx-1/init.c
++++ b/arch/mips/au1000/mtx-1/init.c
+@@ -54,7 +54,7 @@ void __init prom_init(void)
+       prom_argv = (char **) fw_arg1;
+       prom_envp = (char **) fw_arg2;
+-      prom_init_cmdline();
++      strcpy(arcs_cmdline, CONFIG_CMDLINE);
+       memsize_str = prom_getenv("memsize");
+       if (!memsize_str)
diff --git a/target/linux/au1000/patches-2.6.27/002-openwrt_rootfs.patch b/target/linux/au1000/patches-2.6.27/002-openwrt_rootfs.patch
new file mode 100644 (file)
index 0000000..00cda25
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN linux-2.6.27.5/arch/mips/au1000/mtx-1/platform.c linux-2.6.27.5.new/arch/mips/au1000/mtx-1/platform.c
+--- linux-2.6.27.5/arch/mips/au1000/mtx-1/platform.c   2008-11-07 18:55:34.000000000 +0100
++++ linux-2.6.27.5.new/arch/mips/au1000/mtx-1/platform.c       2008-11-15 15:33:31.000000000 +0100
+@@ -90,7 +90,7 @@
+ static struct mtd_partition mtx1_mtd_partitions[] = {
+       {
+-              .name   = "filesystem",
++              .name   = "rootfs",
+               .size   = 0x01C00000,
+               .offset = 0,
+       },
diff --git a/target/linux/au1000/patches-2.6.27/003-au1000_eth_ioctl.patch b/target/linux/au1000/patches-2.6.27/003-au1000_eth_ioctl.patch
new file mode 100644 (file)
index 0000000..9358981
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/drivers/net/au1000_eth.c
++++ b/drivers/net/au1000_eth.c
+@@ -1306,9 +1306,12 @@ static void set_rx_mode(struct net_devic
+       }
+ }
++#define AU1000_KNOWN_PHY_IOCTLS               (SIOCGMIIPHY & 0xfff0)
+ static int au1000_ioctl(struct net_device *dev, struct ifreq *rq, int cmd)
+ {
+       struct au1000_private *aup = (struct au1000_private *)dev->priv;
++      if((cmd & AU1000_KNOWN_PHY_IOCTLS) != AU1000_KNOWN_PHY_IOCTLS)
++              return -EINVAL;
+       if (!netif_running(dev)) return -EINVAL;
diff --git a/target/linux/au1000/patches-2.6.27/004-state_led_phy_fix.patch b/target/linux/au1000/patches-2.6.27/004-state_led_phy_fix.patch
new file mode 100644 (file)
index 0000000..3e5a4eb
--- /dev/null
@@ -0,0 +1,31 @@
+--- linux-2.6.27/drivers/net/au1000_eth.c      2008-10-18 22:37:52.000000000 +0200
++++ linux-2.6.27.new/drivers/net/au1000_eth.c  2008-11-02 22:03:14.000000000 +0100
+@@ -187,6 +187,15 @@
+ #  undef AU1XXX_PHY1_IRQ
+ #endif
++#if defined(CONFIG_MIPS_MTX1)
++/*
++ * 4G MeshCube (MTX-1) board
++ * PHY is at address 31 on MAC0
++ * autodetect fails if not searched for highest address !
++ */
++# define AU1XXX_PHY_SEARCH_HIGHEST_ADDR
++#endif
++
+ #if defined(AU1XXX_PHY0_BUSID) && (AU1XXX_PHY0_BUSID > 0)
+ # error MAC0-associated PHY attached 2nd MACs MII bus not supported yet
+ #endif
+@@ -383,6 +392,12 @@
+       aup->old_duplex = -1;
+       aup->phy_dev = phydev;
++#ifdef CONFIG_MIPS_MTX1
++      /* set up ethernet jack LEDs on the 4G MeshCube (MTX-1 board) */
++      printk(KERN_INFO "MTX-1 PHY: updating LED settings\n");
++      phy_write(phydev, 0x11, 0xff80);
++#endif
++
+       printk(KERN_INFO "%s: attached PHY driver [%s] "
+              "(mii_bus:phy_addr=%s, irq=%d)\n",
+              dev->name, phydev->drv->name, phydev->dev.bus_id, phydev->irq);
diff --git a/target/linux/au1000/patches-2.6.27/005-mtx1_wdt_fix.patch b/target/linux/au1000/patches-2.6.27/005-mtx1_wdt_fix.patch
new file mode 100644 (file)
index 0000000..0b0fc02
--- /dev/null
@@ -0,0 +1,23 @@
+diff --git a/drivers/watchdog/mtx-1_wdt.c b/drivers/watchdog/mtx-1_wdt.c
+index b4b7b0a..3acce62 100644
+--- a/drivers/watchdog/mtx-1_wdt.c
++++ b/drivers/watchdog/mtx-1_wdt.c
+@@ -98,6 +98,8 @@ static void mtx1_wdt_reset(void)
+ static void mtx1_wdt_start(void)
+ {
++      unsigned long flags;
++
+       spin_lock_irqsave(&mtx1_wdt_device.lock, flags);
+       if (!mtx1_wdt_device.queue) {
+               mtx1_wdt_device.queue = 1;
+@@ -110,6 +112,8 @@ static void mtx1_wdt_start(void)
+ static int mtx1_wdt_stop(void)
+ {
++      unsigned long flags;
++
+       spin_lock_irqsave(&mtx1_wdt_device.lock, flags);
+       if (mtx1_wdt_device.queue) {
+               mtx1_wdt_device.queue = 0;
+
diff --git a/target/linux/au1000/patches-2.6.27/006-missing_string_header.patch b/target/linux/au1000/patches-2.6.27/006-missing_string_header.patch
new file mode 100644 (file)
index 0000000..ed8a0be
--- /dev/null
@@ -0,0 +1,10 @@
+--- linux-2.6.27.5/arch/mips/au1000/mtx-1/init.c       2008-11-07 18:55:34.000000000 +0100
++++ linux-2.6.27.5.new/arch/mips/au1000/mtx-1/init.c   2008-11-15 16:09:47.000000000 +0100
+@@ -32,6 +32,7 @@
+ #include <linux/init.h>
+ #include <asm/bootinfo.h>
++#include <asm/string.h>
+ #include <prom.h>