kernel: mark kmod-thermal menuconfig symbol as hidden to avoid building it on targets...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Sep 2013 20:44:11 +0000 (20:44 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Sep 2013 20:44:11 +0000 (20:44 +0000)
Should fix build errors with Linux 3.3/3.6 targets, which use different
kconfig symbols

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38238 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index cbce02b..b3e268e 100644 (file)
@@ -765,6 +765,7 @@ $(eval $(call KernelPackage,random-core))
 define KernelPackage/thermal
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Generic Thermal sysfs driver
+  HIDDEN:=1
   KCONFIG:= \
        CONFIG_THERMAL \
        CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \