build: undefine debug helper templates used by subdir.mk if the DEBUG variable is...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Apr 2011 03:40:01 +0000 (03:40 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Apr 2011 03:40:01 +0000 (03:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26434 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/debug.mk

index faead04..bec74d1 100644 (file)
@@ -21,6 +21,8 @@ ifeq ($(DUMP),)
   endif
 endif
 
+ifneq ($(DEBUG),)
+
 define debug
 $$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
 endef
@@ -38,4 +40,12 @@ $(call warn,$(1),$(2),$(3)   $(4))
 $(4)
 endef
 
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif