[package] refresh acx-mac80211 patches
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 May 2009 19:04:41 +0000 (19:04 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 May 2009 19:04:41 +0000 (19:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16157 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/acx-mac80211/patches/001-build_module.diff
package/acx-mac80211/patches/002-rate_definitions.patch
package/acx-mac80211/patches/003-if_types.patch
package/acx-mac80211/patches/004-acx_config_interface_type.patch
package/acx-mac80211/patches/005-pci_fixes.patch

index 38dd590..ee4a8d4 100644 (file)
@@ -1,6 +1,6 @@
---- acx-mac80211-20080802/Makefile     2008-08-02 17:34:09.000000000 +0200
-+++ acx-mac80211-20080802-b/Makefile   2008-08-04 22:24:25.000000000 +0200
-@@ -28,7 +28,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,7 @@ ifneq ($(KERNELRELEASE),)
        obj-$(CONFIG_ACX_MAC80211) += acx-mac80211.o
        acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
        acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
index 458b79a..7c9dc45 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/common.c b/common.c
-index c3a288d..9c607de 100644
 --- a/common.c
 +++ b/common.c
-@@ -1451,60 +1451,66 @@ void acx_free_modes(acx_device_t * adev)
+@@ -1452,60 +1452,66 @@ void acx_free_modes(acx_device_t * adev)
  //        adev->modes = NULL;
  }
  
@@ -105,4 +103,3 @@ index c3a288d..9c607de 100644
  };
  
  int acx_setup_modes(acx_device_t * adev)
-
index 4e52963..27f6ac6 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN acx-mac80211-20080805/acx_mac80211.h acx-mac80211-20080805.new/acx_mac80211.h
---- acx-mac80211-20080805/acx_mac80211.h       2009-05-07 14:32:44.000000000 +0200
-+++ acx-mac80211-20080805.new/acx_mac80211.h   2009-05-07 15:59:45.000000000 +0200
-@@ -36,7 +36,7 @@
+--- a/acx_mac80211.h
++++ b/acx_mac80211.h
+@@ -36,7 +36,7 @@ struct acx_interface {                
          /* Current BSSID (if any). */       
          u8 *bssid;
  
@@ -10,10 +9,9 @@ diff -urN acx-mac80211-20080805/acx_mac80211.h acx-mac80211-20080805.new/acx_mac
          int type; 
          /* Counter of active monitor interfaces. */
          int monitor;
-diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
---- acx-mac80211-20080805/common.c     2009-05-07 14:32:44.000000000 +0200
-+++ acx-mac80211-20080805.new/common.c 2009-05-07 16:11:26.000000000 +0200
-@@ -4105,28 +4105,28 @@
+--- a/common.c
++++ b/common.c
+@@ -4111,28 +4111,28 @@ static void acx_s_select_opmode(acx_devi
  
        if (adev->interface.operating) {
                switch (adev->interface.type) {
@@ -46,7 +44,7 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
                        default:
                                if (adev->mode != ACX_MODE_OFF)
                                {
-@@ -4136,7 +4136,7 @@
+@@ -4142,7 +4142,7 @@ static void acx_s_select_opmode(acx_devi
                        break;
                }
        } else {
@@ -55,7 +53,7 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
                {
                        if (adev->mode != ACX_MODE_MONITOR)
                        {
-@@ -4180,7 +4180,7 @@
+@@ -4186,7 +4186,7 @@ int acx_add_interface(struct ieee80211_h
        FN_ENTER;
        acx_lock(adev, flags);
  
@@ -64,7 +62,7 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
                adev->interface.monitor++;
        } else {
                if (adev->interface.operating)
-@@ -4226,7 +4226,7 @@
+@@ -4232,7 +4232,7 @@ void acx_remove_interface(struct ieee802
        FN_ENTER;
  
        acx_sem_lock(adev);
@@ -73,7 +71,7 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
                adev->interface.monitor--;
  //                assert(bcm->interface.monitor >= 0);
        } else {
-@@ -4380,7 +4380,7 @@
+@@ -4386,7 +4386,7 @@ extern int acx_config_interface(struct i
  
        acx_lock(adev, flags);
  
@@ -82,7 +80,7 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
            && (adev->vif == vif)) {
                if (conf->bssid)
                {
-@@ -4388,7 +4388,7 @@
+@@ -4394,7 +4394,7 @@ extern int acx_config_interface(struct i
                        MAC_COPY(adev->bssid,conf->bssid);
                }
        }
index e6830c5..800dc61 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN acx-mac80211-20080805/acx_func.h acx-mac80211-20080805.new/acx_func.h
---- acx-mac80211-20080805/acx_func.h   2009-05-07 14:32:44.000000000 +0200
-+++ acx-mac80211-20080805.new/acx_func.h       2009-05-07 16:28:17.000000000 +0200
-@@ -619,9 +619,10 @@
+--- a/acx_func.h
++++ b/acx_func.h
+@@ -619,9 +619,10 @@ int acx_net_set_key(struct ieee80211_hw 
                enum set_key_cmd cmd,
                const u8 *local_addr, const u8 *addr,
                struct ieee80211_key_conf *key);
@@ -14,10 +13,9 @@ diff -urN acx-mac80211-20080805/acx_func.h acx-mac80211-20080805.new/acx_func.h
  int acx_net_config(struct ieee80211_hw* ieee, struct ieee80211_conf *conf);
  int acx_net_get_tx_stats(struct ieee80211_hw* ieee, struct ieee80211_tx_queue_stats *stats);
  int acx_net_conf_tx(struct ieee80211_hw* ieee, u16 queue,
-diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
---- acx-mac80211-20080805/common.c     2009-05-07 16:20:37.000000000 +0200
-+++ acx-mac80211-20080805.new/common.c 2009-05-07 16:35:55.000000000 +0200
-@@ -4364,9 +4364,10 @@
+--- a/common.c
++++ b/common.c
+@@ -4370,9 +4370,10 @@ int acx_net_config(struct ieee80211_hw *
  **
  */
  
@@ -30,7 +28,7 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
  {
        acx_device_t *adev = ieee2adev(ieee);
        unsigned long flags;
-@@ -4382,22 +4383,22 @@
+@@ -4388,22 +4389,22 @@ extern int acx_config_interface(struct i
  
        if ((vif->type != NL80211_IFTYPE_MONITOR)
            && (adev->vif == vif)) {
@@ -60,7 +58,7 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
        {
                adev->beacon_interval = DEFAULT_BEACON_INTERVAL;
                adev->beacon_cache = ieee80211_beacon_get(ieee, vif);
-@@ -4412,7 +4413,7 @@
+@@ -4418,7 +4419,7 @@ extern int acx_config_interface(struct i
        err = 0;
  err_out:
        FN_EXIT1(err);
@@ -69,10 +67,9 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
  }
  
  /**
-diff -urN acx-mac80211-20080805/pci.c acx-mac80211-20080805.new/pci.c
---- acx-mac80211-20080805/pci.c        2009-05-07 14:32:44.000000000 +0200
-+++ acx-mac80211-20080805.new/pci.c    2009-05-07 16:27:27.000000000 +0200
-@@ -1469,7 +1469,7 @@
+--- a/pci.c
++++ b/pci.c
+@@ -1469,7 +1469,7 @@ static const struct ieee80211_ops acxpci
        .configure_filter = acx_i_set_multicast_list,
        .stop = acxpci_e_close,
        .config = acx_net_config,
@@ -81,10 +78,9 @@ diff -urN acx-mac80211-20080805/pci.c acx-mac80211-20080805.new/pci.c
        .set_key = acx_net_set_key,
        .get_stats = acx_e_get_stats,
        .get_tx_stats = acx_net_get_tx_stats,
-diff -urN acx-mac80211-20080805/usb.c acx-mac80211-20080805.new/usb.c
---- acx-mac80211-20080805/usb.c        2009-05-07 14:32:44.000000000 +0200
-+++ acx-mac80211-20080805.new/usb.c    2009-05-07 16:27:38.000000000 +0200
-@@ -741,7 +741,7 @@
+--- a/usb.c
++++ b/usb.c
+@@ -741,7 +741,7 @@ static const struct ieee80211_ops acxusb
        .configure_filter = acx_i_set_multicast_list,
        .stop = acxusb_e_close,
        .config = acx_net_config,
index 440ab53..5785ac0 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN acx-mac80211-20080805/acx_func.h acx-mac80211-20080805.new/acx_func.h
---- acx-mac80211-20080805/acx_func.h   2009-05-07 16:36:37.000000000 +0200
-+++ acx-mac80211-20080805.new/acx_func.h       2009-05-07 16:54:21.000000000 +0200
-@@ -623,7 +623,7 @@
+--- a/acx_func.h
++++ b/acx_func.h
+@@ -623,7 +623,7 @@ void acx_config_interface(struct ieee802
                                struct ieee80211_vif *vif,
                                struct ieee80211_bss_conf *info,
                                u32 changes);
@@ -10,10 +9,9 @@ diff -urN acx-mac80211-20080805/acx_func.h acx-mac80211-20080805.new/acx_func.h
  int acx_net_get_tx_stats(struct ieee80211_hw* ieee, struct ieee80211_tx_queue_stats *stats);
  int acx_net_conf_tx(struct ieee80211_hw* ieee, u16 queue,
                const struct ieee80211_tx_queue_params *params);
-diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
---- acx-mac80211-20080805/common.c     2009-05-07 16:36:37.000000000 +0200
-+++ acx-mac80211-20080805.new/common.c 2009-05-07 16:57:45.000000000 +0200
-@@ -4294,9 +4294,10 @@
+--- a/common.c
++++ b/common.c
+@@ -4300,9 +4300,10 @@ int acx_selectchannel(acx_device_t * ade
  ** Derived from mac80211 code, p54, bcm43xx_mac80211
  **
  */
@@ -25,10 +23,9 @@ diff -urN acx-mac80211-20080805/common.c acx-mac80211-20080805.new/common.c
        unsigned long flags;
  
        FN_ENTER;
-diff -urN acx-mac80211-20080805/pci.c acx-mac80211-20080805.new/pci.c
---- acx-mac80211-20080805/pci.c        2009-05-07 16:39:39.000000000 +0200
-+++ acx-mac80211-20080805.new/pci.c    2009-05-07 16:59:07.000000000 +0200
-@@ -3105,7 +3105,7 @@
+--- a/pci.c
++++ b/pci.c
+@@ -3105,7 +3105,7 @@ acxpci_l_tx_data(acx_device_t *adev, tx_
  
        /* let chip do RTS/CTS handshaking before sending
         * in case packet size exceeds threshold */
@@ -37,7 +34,7 @@ diff -urN acx-mac80211-20080805/pci.c acx-mac80211-20080805.new/pci.c
                SET_BIT(Ctl2_8, DESC_CTL2_RTS);
        else
                CLEAR_BIT(Ctl2_8, DESC_CTL2_RTS);
-@@ -3120,7 +3120,7 @@
+@@ -3120,7 +3120,7 @@ acxpci_l_tx_data(acx_device_t *adev, tx_
  /*    put_txcr(adev, txdesc, clt, rate_cur);  deprecated by mac80211 */
  
        txdesc->total_length = cpu_to_le16(len);
@@ -46,7 +43,7 @@ diff -urN acx-mac80211-20080805/pci.c acx-mac80211-20080805.new/pci.c
        hostdesc2->length = cpu_to_le16(len - wlhdr_len);
  /*
        if (!ieeectl->do_not_encrypt && ieeectl->key_idx>= 0)
-@@ -3444,8 +3444,8 @@
+@@ -3444,8 +3444,8 @@ unsigned int acxpci_l_clean_txdesc(acx_d
                /* And finally report upstream */
                if (hostdesc)
                {