[package] w1-gpio-custom: set enable_external_pullup to null (#8952)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 7 Aug 2012 16:08:08 +0000 (16:08 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 7 Aug 2012 16:08:08 +0000 (16:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33034 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/w1-gpio-custom/Makefile
package/w1-gpio-custom/src/w1-gpio-custom.c

index c1441e9..bf50d1a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=w1-gpio-custom
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
index 8f739d4..96cfcab 100644 (file)
@@ -112,6 +112,7 @@ static int __init w1_gpio_custom_add_one(unsigned int id, unsigned int *params)
 
        pdata.pin = params[BUS_PARAM_PIN];
        pdata.is_open_drain = params[BUS_PARAM_OD] ? 1:0;
+       pdata.enable_external_pullup = NULL;
 
        err = platform_device_add_data(pdev, &pdata, sizeof(pdata));
        if (err)